After updating SLES11-SP1 no longer able to login - displays "error in service module"

This document (7008851) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 11 Service Pack 1

Situation

When attempting to login after applying the latest updates to SLES11-SP1 the following message is displayed: " error in service module" and login is denied.

Resolution

  1. Reboot server.
  2. At the boot parameter line of the grub menu enter the number 3 to boot into multi-user mode.
  3. Login as root user.
  4. Backrev the pam-modules package:
  5. zypper in pam-modules-11-1.6.15
    Select option 1 to downgrade
  6. To return to the gui enter the following:
init 5 && exit

Additional Information

Reported to Engineering

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7008851
  • Creation Date: 20-Jun-2011
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback@suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Join Our Community

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.


SUSE Customer Support Quick Reference Guide SUSE Technical Support Handbook Update Advisories
Support FAQ

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.

Go to Customer Center