The xen management console stops working after updating a SLES10 guest to SP1

This document (3029036) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 10 SP1

Situation

SLES10 SP1 - guest system in Xen
After updating SLES10 GA to SP1 in a XEN virtual machine, xm-console stops working correctly.

Resolution

Disable the virtual machine's paravirtualized framebuffer by adding "xencons=tty" to the "extra" line of the virtual machine's configuration file.

Additional Information

The issue here is that a paravirtualized SLES 10 SP1 uses the paravirtualized framebuffer (pvfb) for its primary video device. As such, once the pvfb comes online, output stops going to the console.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:3029036
  • Creation Date: 02-Aug-2007
  • Modified Date:23-Feb-2021
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback@suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Join Our Community

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.


SUSE Customer Support Quick Reference Guide SUSE Technical Support Handbook Update Advisories
Support FAQ

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.

Go to Customer Center