SUSE Support

Here When You Need Us

Newest kernel-xen updates on dom0 makes guests fail to start

This document (7023314) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 11 Service Pack 3 (SLES 11 SP3)
SUSE Linux Enterprise Server 11 Service Pack 4 (SLES 11 SP4)

SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 12 Service Pack 1 (SLES 12 SP1)
SUSE Linux Enterprise Server 12 Service Pack 2 (SLES 12 SP2)
SUSE Linux Enterprise Server 12 Service Pack 3 (SLES 12 SP3)

SUSE Linux Enterprise Server 15


Situation

Since the new maintenance updates for xen the domU's are not starting but crashing:

(XEN) d2 L1TF-vulnerable L1e 000000003bd63160 - Shadowing
(XEN) d2 Failed to enable PG_SH_forced: -12
(XEN) domain_crash called from common.c:3964
(XEN) Domain 2 reported crashed by domain 32767 on cpu#0:

Resolution

As a workaround disable autoballooning on dom0, which is enabled by default.

Add autoballoon=0 to /etc/xen/x1.conf

https://www.suse.com/documentation/sles-12/book_virt/data/sec_xen_vhost_memory.html

Reboot dom0 for changes to take effect and start your domU's

As soon as a permanent fix is available this Bulletin will be updated



Cause

This is caused by the implementation of the L1TF mitigation fixes.

Additional Information

The issue could happen with the following xen releases:

xen-4.2.5_21-45.25.1 (SLE11 SP3)
xen-4.4.4_36-61.37.2 (SLE11 SP4)
xen-4.4.4_36-22.74.1 (SLE12)
xen-4.5.5_26-22.55.2 (SLE12 SP1)
xen-4.7.6_04-43.39.1 (SLE12 SP2)
xen-4.9.2_10-3.41.1 (SLE12 SP3)
xen-4.10.1_08-3.6.1 (SLE15)

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7023314
  • Creation Date: 30-Aug-2018
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.