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A registered client system disappeared from SUSE Manager

This document (7012170) is provided subject to the disclaimer at the end of this document.

Environment


SUSE Manager

Situation

A client system disappeared from the list of the registered systems in SUSE Manager (i.e. it is not longer registered)

Typically this is a problem when working with imaging/cloning.

Resolution

First of all it is necessary to find out the client system which has the same Novell Customer Center (NCC) credentials of the disappeared one.

On SLES 11, NCC credentials are saved in file "/etc/zypp/credentials.d/NCCcredentials". See the example below:

# cat /etc/zypp/credentials.d/NCCcredentials
username=c1a5967a48fe45499750bd42245c437e
password=a5e562a1f2914dbb87fbc040b64990d1

On SLES 10 systems, NCC credentials are saved in the files /etc/zmd/deviceid and /etc/zmd/secret.

Once the client system with the duplicated NCC credentials is found, make the following steps for fixing the issue:
  1. Remove the client systems in SUSE Manager using the web interface.
  2. Run "mgr-ncc-sync" on the SUSE Manager server from command line.
  3. On SLES 11 client systems, move "/etc/zypp/credentials.d/NCCcredentials" to "/tmp" (on SLES 10 client systems, remove /etc/zmd/deviceid and /etc/zmd/secret, then restart zmd).
  4. Run the bootstrap script on the client systems again.
  5. Run again "mgr-ncc-sync" on the SUSE Manager server from command line.

Cause

The cause of the issue is that a new client system has been registered using the same NCC credentials of an existing one, causing the override of it. Most likely the two systems were cloned.

Disclaimer

This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7012170
  • Creation Date:19-APR-13
  • Modified Date:22-APR-13
    • SUSESUSE Manager

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