SUSE Support

Here When You Need Us

Bonding on SLES11SP2 Hyper-V guest fails after update to kernel 3.0.38-0.5 or later

This document (7011418) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 11 Service Pack 2

Situation

A bond configuration based on devices supported by the hv_netvsc kernel driver fails to start after updating a SLES11SP2 virtual machine, running on a Microsoft Server 2008 Hyper-V, to kernel 3.0.38-0.5 or later. The following messages can be seen in /var/log/boot.msg:
 
Setting up (localfs) network interfaces:
    lo      
    lo        IP address: 127.0.0.1/8 
              IP address: 127.0.0.2/8 
done    eth0      name: Virtual Ethernet Card 0
    eth0      Starting DHCP4 client. .
    eth0      IP address: 192.168.1.12/24
done    eth1      name: Virtual Ethernet Card 1
done    eth2      name: Virtual Ethernet Card 2
unused    bond0   
Could not enslave interface 'eth1'
Could not enslave interface 'eth2'
Removing bonding interface 'bond0'
    bond0   
done
Setting up service (localfs) network  .  .  .  .  .  .  .  .  .  .done

Resolution

Enable MAC spoofing in the settings of the virtual machine. To do so:
  1. Start the Hyper-V Manager
  2. Shutdown the virtual machine
  3. Open the  settings for the virtual machine
  4. Activate "enable spoofing of MAC addresses" for each involved network interface supported by the hv_netvsc driver

The legacy network controller is supported by the kernel tulip module and is not affected by this change. 

Cause

Due to a change in the driver starting with 3.0.38 the hv_netvsc driver does not only update the MAC address of the slave devices in the guest but also reports the change to the virtualization host. Because "enable spoofing of MAC addresses" is not activated, the request fails and the bond cannot be set up.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7011418
  • Creation Date: 23-Nov-2012
  • Modified Date:06-Mar-2021
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.