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kernel: nfsd: too many open TCP sockets, consider increasing the number of threads

This document (7010903) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Server 10

Situation

A busy NFS server may occasionally log the following message in /var/log/messages:
 
kernel: nfsd: too many open TCP sockets, consider increasing the number of nfsd threads

Resolution

The threads in question are set in /etc/sysconfig/nfs:
USE_KERNEL_NFSD_NUMBER="4"
 
The default is 4 but can be raised to allow nfsd to handle more requests at once.  After making a change, the nfs server daemon can be restarted with:
 
rcnfsserver restart

Cause

This message is generated by some rule-of-thumb checking, and should not be taken as a indication of a definite problem.  Rather, it warns of a situation which might cause low performance under load.  The number of TCP connections open to nfsd (nfs server, port 2049) is checked and if the number is considered higher than the server might be able to keep up with, the message is logged.
 
The message is given when connections to the NFS server's port 2049 are greater than  [(number of threads + 3) * 20].  For example, at the default of 4, the message will be logged if connections to port 2049 exceed 140.  The presence of connections does not necessarily mean all of them are currently making requests.  However, it does signify a certain number of NFS clients with file systems mounted, and if many of them were heavily using NFS resources, the NFS Server might not keep up with it's work as promptly as desired.
 
When choosing a new setting, it can sometimes be helpful to manually check the number of nfsd connections, especially over time or at peak work times.  To do so, give the following command (at a terminal on the NFS Server).
 
netstat -nt | grep -c :2049
 
Then plug the trended count or peak count into the formula above and calculate the number of threads which would be needed to satisfy the algorithm.

Disclaimer

This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7010903
  • Creation Date:10-OCT-12
  • Modified Date:10-OCT-12
    • SUSESUSE Linux Enterprise Server

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