Upstream information

CVE-2024-3094 at MITRE

Description

Malicious code was discovered in the upstream tarballs of xz, starting with version 5.6.0. Through a series of complex obfuscations, the liblzma build process extracts a prebuilt object file from a disguised test file existing in the source code, which is then used to modify specific functions in the liblzma code. This results in a modified liblzma library that can be used by any software linked against this library, intercepting and modifying the data interaction with this library.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 10 10
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Changed Changed
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entries: 1222124 [NEW], 1222582 [NEW]

SUSE Security Advisories:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SLES15-SP5-CHOST-BYOS-Aliyun xz Not affected
SLES15-SP5-CHOST-BYOS-Azure xz Not affected
SLES15-SP5-CHOST-BYOS-EC2 xz Not affected
SLES15-SP5-CHOST-BYOS-GCE xz Not affected
SLES15-SP5-CHOST-BYOS-SAP-CCloud xz Not affected
SUSE Enterprise Storage 7.1 xz Not affected
SUSE Linux Enterprise Desktop 15 SP5 xz Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 xz Not affected
SUSE Linux Enterprise High Performance Computing 15 SP5 xz Not affected
SUSE Linux Enterprise Micro 5.1 xz Not affected
SUSE Linux Enterprise Micro 5.2 xz Not affected
SUSE Linux Enterprise Micro 5.3 xz Not affected
SUSE Linux Enterprise Micro 5.4 xz Not affected
SUSE Linux Enterprise Micro 5.5 xz Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP5 xz Not affected
SUSE Linux Enterprise Real Time 15 SP3 xz Not affected
SUSE Linux Enterprise Server 12 SP5 xz Not affected
SUSE Linux Enterprise Server 12-LTSS xz Not affected
SUSE Linux Enterprise Server 15 SP5 xz Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 xz Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 xz Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP5 xz Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 xz Not affected
SUSE Manager Proxy 4.3 xz Not affected
SUSE Manager Retail Branch Server 4.3 xz Not affected
SUSE Manager Server 4.3 xz Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SLES15-EC2-CHOST-HVM-BYOS xz Not affected
SLES15-SP1-CHOST-BYOS-Azure xz Not affected
SLES15-SP1-CHOST-BYOS-EC2 xz Not affected
SLES15-SP1-CHOST-BYOS-GCE xz Not affected
SLES15-SP2-CHOST-BYOS-Aliyun xz Not affected
SLES15-SP2-CHOST-BYOS-Azure xz Not affected
SLES15-SP2-CHOST-BYOS-EC2 xz Not affected
SLES15-SP2-CHOST-BYOS-GCE xz Not affected
SLES15-SP3-CHOST-BYOS-Aliyun xz Not affected
SLES15-SP3-CHOST-BYOS-Azure xz Not affected
SLES15-SP3-CHOST-BYOS-EC2 xz Not affected
SLES15-SP3-CHOST-BYOS-GCE xz Not affected
SLES15-SP3-CHOST-BYOS-SAP-CCloud xz Not affected
SLES15-SP4-CHOST-BYOS xz Not affected
SLES15-SP4-CHOST-BYOS-Aliyun xz Not affected
SLES15-SP4-CHOST-BYOS-Azure xz Not affected
SLES15-SP4-CHOST-BYOS-EC2 xz Not affected
SLES15-SP4-CHOST-BYOS-GCE xz Not affected
SLES15-SP4-CHOST-BYOS-SAP-CCloud xz Not affected
SUSE Linux Enterprise Desktop 15 SP4 xz Not affected
SUSE Linux Enterprise High Performance Computing 15 xz Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 xz Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS xz Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS xz Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 xz Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS xz Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS xz Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 xz Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS xz Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS xz Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 xz Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS xz Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS xz Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS xz Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS xz Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 xz Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 xz Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 xz Not affected
SUSE Linux Enterprise Server 15 SP2 xz Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS xz Not affected
SUSE Linux Enterprise Server 15 SP3 xz Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS xz Not affected
SUSE Linux Enterprise Server 15 SP4 xz Not affected
SUSE Linux Enterprise Server 15 SP4-LTSS xz Not affected
SUSE Linux Enterprise Server for SAP Applications 15 xz Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 xz Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 xz Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 xz Not affected
SUSE OpenStack Cloud 8 xz Not affected
SUSE OpenStack Cloud 9 xz Not affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 xz Not affected
SUSE CaaS Platform 3.0 xz Not affected
SUSE CaaS Platform 4.0 xz Not affected
SUSE Enterprise Storage 6 xz Not affected
SUSE Enterprise Storage 7 xz Not affected
SUSE Linux Enterprise Desktop 11 SP4 xz Not affected
SUSE Linux Enterprise Desktop 12 xz Not affected
SUSE Linux Enterprise Desktop 12 SP1 xz Not affected
SUSE Linux Enterprise Desktop 12 SP2 xz Not affected
SUSE Linux Enterprise Desktop 12 SP3 xz Not affected
SUSE Linux Enterprise Desktop 12 SP4 xz Not affected
SUSE Linux Enterprise Desktop 15 xz Not affected
SUSE Linux Enterprise Desktop 15 SP1 xz Not affected
SUSE Linux Enterprise Desktop 15 SP2 xz Not affected
SUSE Linux Enterprise Desktop 15 SP3 xz Not affected
SUSE Linux Enterprise Micro 5.0 xz Not affected
SUSE Linux Enterprise Module for Basesystem 15 xz Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 xz Not affected
SUSE Linux Enterprise Real Time 15 SP2 xz Not affected
SUSE Linux Enterprise Real Time 15 SP4 xz Not affected
SUSE Linux Enterprise Server 11 SP3 xz Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS xz Not affected
SUSE Linux Enterprise Server 11 SP4 xz Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS xz Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS xz Not affected
SUSE Linux Enterprise Server 12 xz Not affected
SUSE Linux Enterprise Server 12 SP1 xz Not affected
SUSE Linux Enterprise Server 12 SP1-LTSS xz Not affected
SUSE Linux Enterprise Server 12 SP2 xz Not affected
SUSE Linux Enterprise Server 12 SP2-BCL xz Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS xz Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS xz Not affected
SUSE Linux Enterprise Server 12 SP3 xz Not affected
SUSE Linux Enterprise Server 12 SP3-BCL xz Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS xz Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS xz Not affected
SUSE Linux Enterprise Server 12 SP4 xz Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS xz Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS xz Not affected
SUSE Linux Enterprise Server 15 xz Not affected
SUSE Linux Enterprise Server 15 SP1 xz Not affected
SUSE Linux Enterprise Server 15 SP1-BCL xz Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS xz Not affected
SUSE Linux Enterprise Server 15 SP2-BCL xz Not affected
SUSE Linux Enterprise Server 15 SP3-BCL xz Not affected
SUSE Linux Enterprise Server 15-LTSS xz Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 xz Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 xz Not affected
SUSE Linux Enterprise Server for SAP Applications 12 xz Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 xz Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 xz Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 xz Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 xz Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 xz Not affected
SUSE Linux Enterprise Software Development Kit 12 xz Not affected
SUSE Linux Enterprise Software Development Kit 12 SP1 xz Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 xz Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 xz Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 xz Not affected
SUSE Manager Proxy 4.0 xz Not affected
SUSE Manager Proxy 4.1 xz Not affected
SUSE Manager Proxy 4.2 xz Not affected
SUSE Manager Retail Branch Server 4.0 xz Not affected
SUSE Manager Retail Branch Server 4.1 xz Not affected
SUSE Manager Retail Branch Server 4.2 xz Not affected
SUSE Manager Server 4.0 xz Not affected
SUSE Manager Server 4.1 xz Not affected
SUSE Manager Server 4.2 xz Not affected
SUSE OpenStack Cloud 7 xz Not affected
SUSE OpenStack Cloud Crowbar 8 xz Not affected
SUSE OpenStack Cloud Crowbar 9 xz Not affected
Container Status
bci/bci-sle15-kernel-module-devel
bci/php-apache:8
rancher/elemental-teal-channel
rancher/elemental-teal-iso/5.4
rancher/elemental-teal-rt-channel
rancher/elemental-teal-rt/5.3
rancher/elemental-teal-rt/5.4
rancher/elemental-teal/5.3
rancher/elemental-teal/5.4
ses/6/cephcsi/cephcsi
ses/6/rook/ceph
ses/7.1/cephcsi/cephcsi
ses/7.1/rook/ceph
ses/7/ceph/ceph
ses/7/cephcsi/cephcsi
ses/7/rook/ceph
suse/hpc/warewulf4-x86_64/sle-hpc-node
suse/manager/4.3/proxy-httpd
suse/sle-micro-rancher/5.2
suse/sle-micro-rancher/5.3
suse/sle-micro-rancher/5.4
suse/sle-micro/5.5
suse/sle-micro/kvm-5.5
suse/sle-micro/rt-5.5
suse/sles/15.2/virt-launcher:0.38.1
suse/sles/15.3/libguestfs-tools:0.45.0
suse/sles/15.3/virt-launcher:0.45.0
suse/sles/15.4/libguestfs-tools:0.49.0
suse/sles/15.4/virt-launcher:0.49.0
suse/sles/15.5/libguestfs-tools:0.58.0
suse/sles/15.5/virt-launcher:0.58.0
suse/sles12sp3
xzNot affected


SUSE Timeline for this CVE

CVE page created: Thu Mar 28 13:00:06 2024
CVE page last modified: Fri Apr 19 19:31:38 2024