Upstream information

CVE-2023-5002 at MITRE

Description

A flaw was found in pgAdmin. This issue occurs when the pgAdmin server HTTP API validates the path a user selects to external PostgreSQL utilities such as pg_dump and pg_restore. Versions of pgAdmin prior to 7.6 failed to properly control the server code executed on this API, allowing an authenticated user to run arbitrary commands on the server.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6 8.3
Vector CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:H/A:H CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
Attack Vector Network Network
Attack Complexity High Low
Privileges Required High Low
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact Low High
Integrity Impact High High
Availability Impact High Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1215603 [IN_PROGRESS]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • pgadmin4 >= 7.8-1.1
  • pgadmin4-desktop >= 7.8-1.1
  • pgadmin4-doc >= 7.8-1.1
  • pgadmin4-web-uwsgi >= 7.8-1.1
Patchnames:
openSUSE Tumbleweed GA pgadmin4-7.8-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 pgadmin4 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP5 pgadmin4 Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP5 pgadmin4 Not affected
SUSE Linux Enterprise Real Time 15 SP3 pgadmin4 Not affected
SUSE Linux Enterprise Server 15 SP5 pgadmin4 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 pgadmin4 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP5 pgadmin4 Not affected
SUSE Manager Proxy 4.3 pgadmin4 Not affected
SUSE Manager Retail Branch Server 4.3 pgadmin4 Not affected
SUSE Manager Server 4.3 pgadmin4 Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 SP1 pgadmin4 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS pgadmin4 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS pgadmin4 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 pgadmin4 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS pgadmin4 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS pgadmin4 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 pgadmin4 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS pgadmin4 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS pgadmin4 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 pgadmin4 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS pgadmin4 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS pgadmin4 Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP2 pgadmin4 Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP3 pgadmin4 Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP4 pgadmin4 Not affected
SUSE Linux Enterprise Server 15 SP2 pgadmin4 Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS pgadmin4 Not affected
SUSE Linux Enterprise Server 15 SP3 pgadmin4 Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS pgadmin4 Not affected
SUSE Linux Enterprise Server 15 SP4 pgadmin4 Not affected
SUSE Linux Enterprise Server 15 SP4-LTSS pgadmin4 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 pgadmin4 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 pgadmin4 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 pgadmin4 Not affected
Products past their end of life and not receiving proactive updates anymore.
SUSE CaaS Platform 4.0 pgadmin4 Not affected
SUSE Enterprise Storage 6 pgadmin4 Not affected
SUSE Enterprise Storage 7 pgadmin4 Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP1 pgadmin4 Not affected
SUSE Linux Enterprise Real Time 15 SP2 pgadmin4 Not affected
SUSE Linux Enterprise Real Time 15 SP4 pgadmin4 Not affected
SUSE Linux Enterprise Server 15 SP1 pgadmin4 Not affected
SUSE Linux Enterprise Server 15 SP1-BCL pgadmin4 Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS pgadmin4 Not affected
SUSE Linux Enterprise Server 15 SP2-BCL pgadmin4 Not affected
SUSE Linux Enterprise Server 15 SP3-BCL pgadmin4 Not affected
SUSE Manager Proxy 4.0 pgadmin4 Not affected
SUSE Manager Proxy 4.1 pgadmin4 Not affected
SUSE Manager Proxy 4.2 pgadmin4 Not affected
SUSE Manager Retail Branch Server 4.0 pgadmin4 Not affected
SUSE Manager Retail Branch Server 4.1 pgadmin4 Not affected
SUSE Manager Retail Branch Server 4.2 pgadmin4 Not affected
SUSE Manager Server 4.0 pgadmin4 Not affected
SUSE Manager Server 4.1 pgadmin4 Not affected
SUSE Manager Server 4.2 pgadmin4 Not affected


SUSE Timeline for this CVE

CVE page created: Thu Sep 21 18:00:08 2023
CVE page last modified: Thu Feb 1 01:45:32 2024