Upstream information

CVE-2023-32182 at MITRE

Description

A Improper Link Resolution Before File Access ('Link Following') vulnerability in SUSE SUSE Linux Enterprise Desktop 15 SP5 postfix, SUSE SUSE Linux Enterprise High Performance Computing 15 SP5 postfix, SUSE openSUSE Leap 15.5 postfix.This issue affects SUSE Linux Enterprise Desktop 15 SP5: before 3.7.3-150500.3.5.1; SUSE Linux Enterprise High Performance Computing 15 SP5: before 3.7.3-150500.3.5.1; openSUSE Leap 15.5 : before 3.7.3-150500.3.5.1.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.9 5.5
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Attack Vector Local Local
Attack Complexity Low Low
Privileges Required None Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact Low None
Integrity Impact Low High
Availability Impact Low None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1211196 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES15-SP2-SAP-Azure-LI-BYOS-Production
Image SLES15-SP2-SAP-Azure-VLI-BYOS-Production
  • postfix >= 3.4.7-150200.3.12.2
Image SLES15-SP3-SAP-Azure-LI-BYOS-Production
Image SLES15-SP3-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP4-Manager-Server-4-3
Image SLES15-SP4-Manager-Server-4-3-Azure-llc
Image SLES15-SP4-Manager-Server-4-3-Azure-ltd
Image SLES15-SP4-Manager-Server-4-3-BYOS
Image SLES15-SP4-Manager-Server-4-3-BYOS-Azure
Image SLES15-SP4-Manager-Server-4-3-BYOS-EC2
Image SLES15-SP4-Manager-Server-4-3-BYOS-GCE
Image SLES15-SP4-Manager-Server-4-3-EC2-llc
Image SLES15-SP4-Manager-Server-4-3-EC2-ltd
  • postfix >= 3.5.9-150300.5.12.2
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
  • postfix >= 3.5.9-150300.5.12.2
  • postfix-devel >= 3.5.9-150300.5.12.2
  • postfix-doc >= 3.5.9-150300.5.12.2
  • postfix-ldap >= 3.5.9-150300.5.12.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP4-2023-3945
SUSE Linux Enterprise Desktop 15 SP5
SUSE Linux Enterprise Module for Basesystem 15 SP5
  • postfix >= 3.7.3-150500.3.5.1
  • postfix-devel >= 3.7.3-150500.3.5.1
  • postfix-doc >= 3.7.3-150500.3.5.1
  • postfix-ldap >= 3.7.3-150500.3.5.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP5-2023-3394
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • postfix >= 3.5.9-150300.5.12.2
  • postfix-bdb >= 3.5.9-150300.5.12.2
  • postfix-bdb-lmdb >= 3.5.9-150300.5.12.2
  • postfix-devel >= 3.5.9-150300.5.12.2
  • postfix-doc >= 3.5.9-150300.5.12.2
  • postfix-ldap >= 3.5.9-150300.5.12.2
  • postfix-mysql >= 3.5.9-150300.5.12.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP4-2023-3945
SUSE-SLE-Module-Legacy-15-SP4-2023-3945
SUSE-SLE-Module-Server-Applications-15-SP4-2023-3945
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • postfix >= 3.7.3-150500.3.5.1
  • postfix-bdb >= 3.7.3-150500.3.5.1
  • postfix-bdb-lmdb >= 3.7.3-150500.3.5.1
  • postfix-devel >= 3.7.3-150500.3.5.1
  • postfix-doc >= 3.7.3-150500.3.5.1
  • postfix-ldap >= 3.7.3-150500.3.5.1
  • postfix-mysql >= 3.7.3-150500.3.5.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP5-2023-3394
SUSE-SLE-Module-Legacy-15-SP5-2023-3394
SUSE-SLE-Module-Server-Applications-15-SP5-2023-3394
SUSE Linux Enterprise Module for Legacy 15 SP4
  • postfix-bdb >= 3.5.9-150300.5.12.2
  • postfix-bdb-lmdb >= 3.5.9-150300.5.12.2
Patchnames:
SUSE-SLE-Module-Legacy-15-SP4-2023-3945
SUSE Linux Enterprise Module for Legacy 15 SP5
  • postfix-bdb >= 3.7.3-150500.3.5.1
  • postfix-bdb-lmdb >= 3.7.3-150500.3.5.1
Patchnames:
SUSE-SLE-Module-Legacy-15-SP5-2023-3394
SUSE Linux Enterprise Module for Server Applications 15 SP4
  • postfix-mysql >= 3.5.9-150300.5.12.2
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP4-2023-3945
SUSE Linux Enterprise Module for Server Applications 15 SP5
  • postfix-mysql >= 3.7.3-150500.3.5.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP5-2023-3394
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • postfix >= 3.2.10-3.27.2
  • postfix-devel >= 3.2.10-3.27.2
  • postfix-doc >= 3.2.10-3.27.2
  • postfix-mysql >= 3.2.10-3.27.2
Patchnames:
SUSE-SLE-SDK-12-SP5-2023-3732
SUSE-SLE-SERVER-12-SP5-2023-3732
SUSE Linux Enterprise Software Development Kit 12 SP5
  • postfix-devel >= 3.2.10-3.27.2
Patchnames:
SUSE-SLE-SDK-12-SP5-2023-3732
SUSE Manager Proxy 4.2
  • postfix >= 3.5.9-150300.5.12.2
  • postfix-devel >= 3.5.9-150300.5.12.2
  • postfix-doc >= 3.5.9-150300.5.12.2
  • postfix-ldap >= 3.5.9-150300.5.12.2
  • postfix-mysql >= 3.5.9-150300.5.12.2
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.2-2023-3945
SUSE Manager Retail Branch Server 4.2
  • postfix >= 3.5.9-150300.5.12.2
  • postfix-devel >= 3.5.9-150300.5.12.2
  • postfix-doc >= 3.5.9-150300.5.12.2
  • postfix-ldap >= 3.5.9-150300.5.12.2
  • postfix-mysql >= 3.5.9-150300.5.12.2
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.2-2023-3945
SUSE Manager Server 4.2
  • postfix >= 3.5.9-150300.5.12.2
  • postfix-devel >= 3.5.9-150300.5.12.2
  • postfix-doc >= 3.5.9-150300.5.12.2
  • postfix-ldap >= 3.5.9-150300.5.12.2
  • postfix-mysql >= 3.5.9-150300.5.12.2
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.2-2023-3945
openSUSE Leap 15.4
  • postfix >= 3.5.9-150300.5.12.2
  • postfix-bdb >= 3.5.9-150300.5.12.2
  • postfix-bdb-lmdb >= 3.5.9-150300.5.12.2
  • postfix-devel >= 3.5.9-150300.5.12.2
  • postfix-doc >= 3.5.9-150300.5.12.2
  • postfix-ldap >= 3.5.9-150300.5.12.2
  • postfix-lmdb >= 3.4.7-150200.3.12.2
  • postfix-mysql >= 3.5.9-150300.5.12.2
  • postfix-postgresql >= 3.5.9-150300.5.12.2
Patchnames:
openSUSE-SLE-15.4-2023-3791
openSUSE-SLE-15.4-2023-3945
openSUSE Leap 15.5
  • postfix >= 3.7.3-150500.3.5.1
  • postfix-bdb >= 3.7.3-150500.3.5.1
  • postfix-bdb-lmdb >= 3.7.3-150500.3.5.1
  • postfix-devel >= 3.7.3-150500.3.5.1
  • postfix-doc >= 3.7.3-150500.3.5.1
  • postfix-ldap >= 3.7.3-150500.3.5.1
  • postfix-mysql >= 3.7.3-150500.3.5.1
  • postfix-postgresql >= 3.7.3-150500.3.5.1
Patchnames:
openSUSE-SLE-15.5-2023-3394
openSUSE Tumbleweed
  • postfix >= 3.8.3-1.1
  • postfix-devel >= 3.8.3-1.1
  • postfix-doc >= 3.8.3-1.1
  • postfix-ldap >= 3.8.3-1.1
  • postfix-mysql >= 3.8.3-1.1
  • postfix-postgresql >= 3.8.3-1.1
Patchnames:
openSUSE Tumbleweed GA postfix-3.8.3-1.1


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 postfix Unsupported
SUSE Linux Enterprise Desktop 15 SP5 postfix Released
SUSE Linux Enterprise High Performance Computing 12 SP5 postfix Released
SUSE Linux Enterprise High Performance Computing 15 SP5 postfix Released
SUSE Linux Enterprise High Performance Computing 15 SP5 postfix-bdb Released
SUSE Linux Enterprise Module for Basesystem 15 SP5 postfix Released
SUSE Linux Enterprise Module for Legacy 15 SP5 postfix-bdb Released
SUSE Linux Enterprise Module for Server Applications 15 SP5 postfix Released
SUSE Linux Enterprise Real Time 15 SP3 postfix Unsupported
SUSE Linux Enterprise Server 12 SP5 postfix Released
SUSE Linux Enterprise Server 12-LTSS postfix Ignore
SUSE Linux Enterprise Server 15 SP5 postfix Released
SUSE Linux Enterprise Server 15 SP5 postfix-bdb Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 postfix Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 postfix Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 postfix-bdb Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 postfix Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 postfix-bdb Released
SUSE Linux Enterprise Software Development Kit 12 SP5 postfix Released
SUSE Manager Proxy 4.3 postfix Released
SUSE Manager Proxy 4.3 postfix-bdb Released
SUSE Manager Retail Branch Server 4.3 postfix Released
SUSE Manager Retail Branch Server 4.3 postfix-bdb Released
SUSE Manager Server 4.3 postfix Released
SUSE Manager Server 4.3 postfix-bdb Released
openSUSE Leap 15.5 postfix Released
openSUSE Leap 15.5 postfix-bdb Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 postfix Released
SUSE Linux Enterprise High Performance Computing 15 postfix Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1 postfix Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS postfix Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS postfix Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2 postfix Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS postfix Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS postfix Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 postfix Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS postfix Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS postfix Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP4 postfix Released
SUSE Linux Enterprise High Performance Computing 15 SP4 postfix-bdb Released
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS postfix Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS postfix Unsupported
SUSE Linux Enterprise High Performance Computing 15-ESPOS postfix Unsupported
SUSE Linux Enterprise High Performance Computing 15-LTSS postfix Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP2 postfix Affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 postfix Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP4 postfix Released
SUSE Linux Enterprise Module for Legacy 15 SP4 postfix-bdb Released
SUSE Linux Enterprise Module for Server Applications 15 SP2 postfix Affected
SUSE Linux Enterprise Module for Server Applications 15 SP3 postfix Unsupported
SUSE Linux Enterprise Module for Server Applications 15 SP4 postfix Released
SUSE Linux Enterprise Server 12 SP2-BCL postfix Affected
SUSE Linux Enterprise Server 15 SP2 postfix Affected
SUSE Linux Enterprise Server 15 SP2-LTSS postfix Affected
SUSE Linux Enterprise Server 15 SP3 postfix Unsupported
SUSE Linux Enterprise Server 15 SP3-LTSS postfix Unsupported
SUSE Linux Enterprise Server 15 SP4 postfix Released
SUSE Linux Enterprise Server 15 SP4 postfix-bdb Released
SUSE Linux Enterprise Server 15 SP4-LTSS postfix Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 postfix Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP1 postfix Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP2 postfix Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 postfix Unsupported
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 postfix Affected
SUSE CaaS Platform 4.0 postfix Unsupported
SUSE Enterprise Storage 6 postfix Unsupported
SUSE Enterprise Storage 7 postfix Affected
SUSE Linux Enterprise Desktop 11 SP4 postfix Affected
SUSE Linux Enterprise Desktop 12 postfix Ignore
SUSE Linux Enterprise Desktop 12 SP1 postfix Ignore
SUSE Linux Enterprise Desktop 12 SP2 postfix Unsupported
SUSE Linux Enterprise Desktop 12 SP3 postfix Affected
SUSE Linux Enterprise Desktop 12 SP4 postfix Affected
SUSE Linux Enterprise Desktop 15 postfix Unsupported
SUSE Linux Enterprise Desktop 15 SP1 postfix Unsupported
SUSE Linux Enterprise Desktop 15 SP2 postfix Affected
SUSE Linux Enterprise Desktop 15 SP3 postfix Unsupported
SUSE Linux Enterprise High Performance Computing 12 SP3 postfix Ignore
SUSE Linux Enterprise Module for Basesystem 15 postfix Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP1 postfix Unsupported
SUSE Linux Enterprise Module for Server Applications 15 postfix Unsupported
SUSE Linux Enterprise Module for Server Applications 15 SP1 postfix Unsupported
SUSE Linux Enterprise Real Time 15 SP2 postfix Affected
SUSE Linux Enterprise Real Time 15 SP4 postfix Unsupported
SUSE Linux Enterprise Server 11 SP3 postfix Affected
SUSE Linux Enterprise Server 11 SP3-LTSS postfix Affected
SUSE Linux Enterprise Server 11 SP4 postfix Affected
SUSE Linux Enterprise Server 11 SP4 LTSS postfix Affected
SUSE Linux Enterprise Server 11 SP4-LTSS postfix Affected
SUSE Linux Enterprise Server 12 postfix Ignore
SUSE Linux Enterprise Server 12 SP1 postfix Ignore
SUSE Linux Enterprise Server 12 SP1-LTSS postfix Ignore
SUSE Linux Enterprise Server 12 SP2 postfix Unsupported
SUSE Linux Enterprise Server 12 SP2-ESPOS postfix Unsupported
SUSE Linux Enterprise Server 12 SP2-LTSS postfix Unsupported
SUSE Linux Enterprise Server 12 SP3 postfix Ignore
SUSE Linux Enterprise Server 12 SP3-BCL postfix Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS postfix Affected
SUSE Linux Enterprise Server 12 SP3-LTSS postfix Affected
SUSE Linux Enterprise Server 12 SP4 postfix Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS postfix Affected
SUSE Linux Enterprise Server 12 SP4-LTSS postfix Affected
SUSE Linux Enterprise Server 15 postfix Unsupported
SUSE Linux Enterprise Server 15 SP1 postfix Unsupported
SUSE Linux Enterprise Server 15 SP1-BCL postfix Unsupported
SUSE Linux Enterprise Server 15 SP1-LTSS postfix Unsupported
SUSE Linux Enterprise Server 15 SP2-BCL postfix Affected
SUSE Linux Enterprise Server 15 SP3-BCL postfix Unsupported
SUSE Linux Enterprise Server 15-LTSS postfix Unsupported
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 postfix Unsupported
SUSE Linux Enterprise Server for SAP Applications 11 SP4 postfix Affected
SUSE Linux Enterprise Server for SAP Applications 12 postfix Ignore
SUSE Linux Enterprise Server for SAP Applications 12 SP1 postfix Ignore
SUSE Linux Enterprise Server for SAP Applications 12 SP2 postfix Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 postfix Ignore
SUSE Linux Enterprise Server for SAP Applications 12 SP4 postfix Affected
SUSE Linux Enterprise Software Development Kit 11 SP4 postfix Affected
SUSE Linux Enterprise Software Development Kit 12 postfix Ignore
SUSE Linux Enterprise Software Development Kit 12 SP1 postfix Ignore
SUSE Linux Enterprise Software Development Kit 12 SP2 postfix Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP3 postfix Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 postfix Affected
SUSE Manager Proxy 4.0 postfix Unsupported
SUSE Manager Proxy 4.1 postfix Affected
SUSE Manager Proxy 4.2 postfix Released
SUSE Manager Retail Branch Server 4.0 postfix Unsupported
SUSE Manager Retail Branch Server 4.1 postfix Affected
SUSE Manager Retail Branch Server 4.2 postfix Released
SUSE Manager Server 4.0 postfix Unsupported
SUSE Manager Server 4.1 postfix Affected
SUSE Manager Server 4.2 postfix Released
SUSE OpenStack Cloud 7 postfix Unsupported
SUSE OpenStack Cloud 8 postfix Affected
SUSE OpenStack Cloud 9 postfix Affected
SUSE OpenStack Cloud Crowbar 8 postfix Affected
SUSE OpenStack Cloud Crowbar 9 postfix Affected
openSUSE Leap 15.3 postfix Released
openSUSE Leap 15.3 postfix-bdb Released
openSUSE Leap 15.4 postfix Released
openSUSE Leap 15.4 postfix-bdb Released


SUSE Timeline for this CVE

CVE page created: Mon May 22 15:15:18 2023
CVE page last modified: Thu Feb 22 17:23:52 2024