Upstream information

CVE-2022-3964 at MITRE

Description

A vulnerability classified as problematic has been found in ffmpeg. This affects an unknown part of the file libavcodec/rpzaenc.c of the component QuickTime RPZA Video Encoder. The manipulation of the argument y_size leads to out-of-bounds read. It is possible to initiate the attack remotely. The name of the patch is 92f9b28ed84a77138105475beba16c146bdaf984. It is recommended to apply a patch to fix this issue. The associated identifier of this vulnerability is VDB-213543.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.1 7.1
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:H
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1205388 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
  • libavcodec58_134 >= 4.4-150400.3.5.1
  • libavformat58_76 >= 4.4-150400.3.5.1
  • libavutil56_70 >= 4.4-150400.3.5.1
  • libswresample3_9 >= 4.4-150400.3.5.1
  • libswscale5_9 >= 4.4-150400.3.5.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP4-2022-4194
SUSE-SLE-Module-Packagehub-Subpackages-15-SP4-2022-4194
SUSE-SLE-Product-WE-15-SP4-2022-4194
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • libavcodec58_134 >= 4.4-150400.3.5.1
  • libavformat58_76 >= 4.4-150400.3.5.1
  • libavutil56_70 >= 4.4-150400.3.5.1
  • libswresample3_9 >= 4.4-150400.3.5.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP4-2022-4194
SUSE-SLE-Module-Packagehub-Subpackages-15-SP4-2022-4194
SUSE Linux Enterprise Module for Desktop Applications 15 SP4
  • libavcodec58_134 >= 4.4-150400.3.5.1
  • libavutil56_70 >= 4.4-150400.3.5.1
  • libswresample3_9 >= 4.4-150400.3.5.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP4-2022-4194
SUSE Linux Enterprise Module for Package Hub 15 SP4
  • libavformat58_76 >= 4.4-150400.3.5.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP4-2022-4194
SUSE Linux Enterprise Workstation Extension 15 SP4
  • libavformat58_76 >= 4.4-150400.3.5.1
  • libswscale5_9 >= 4.4-150400.3.5.1
Patchnames:
SUSE-SLE-Product-WE-15-SP4-2022-4194
openSUSE Leap 15.4
  • ffmpeg-4 >= 4.4-150400.3.5.1
  • ffmpeg-4-libavcodec-devel >= 4.4-150400.3.5.1
  • ffmpeg-4-libavdevice-devel >= 4.4-150400.3.5.1
  • ffmpeg-4-libavfilter-devel >= 4.4-150400.3.5.1
  • ffmpeg-4-libavformat-devel >= 4.4-150400.3.5.1
  • ffmpeg-4-libavresample-devel >= 4.4-150400.3.5.1
  • ffmpeg-4-libavutil-devel >= 4.4-150400.3.5.1
  • ffmpeg-4-libpostproc-devel >= 4.4-150400.3.5.1
  • ffmpeg-4-libswresample-devel >= 4.4-150400.3.5.1
  • ffmpeg-4-libswscale-devel >= 4.4-150400.3.5.1
  • ffmpeg-4-private-devel >= 4.4-150400.3.5.1
  • libavcodec58_134 >= 4.4-150400.3.5.1
  • libavcodec58_134-32bit >= 4.4-150400.3.5.1
  • libavdevice58_13 >= 4.4-150400.3.5.1
  • libavdevice58_13-32bit >= 4.4-150400.3.5.1
  • libavfilter7_110 >= 4.4-150400.3.5.1
  • libavfilter7_110-32bit >= 4.4-150400.3.5.1
  • libavformat58_76 >= 4.4-150400.3.5.1
  • libavformat58_76-32bit >= 4.4-150400.3.5.1
  • libavresample4_0 >= 4.4-150400.3.5.1
  • libavresample4_0-32bit >= 4.4-150400.3.5.1
  • libavutil56_70 >= 4.4-150400.3.5.1
  • libavutil56_70-32bit >= 4.4-150400.3.5.1
  • libpostproc55_9 >= 4.4-150400.3.5.1
  • libpostproc55_9-32bit >= 4.4-150400.3.5.1
  • libswresample3_9 >= 4.4-150400.3.5.1
  • libswresample3_9-32bit >= 4.4-150400.3.5.1
  • libswscale5_9 >= 4.4-150400.3.5.1
  • libswscale5_9-32bit >= 4.4-150400.3.5.1
Patchnames:
openSUSE-SLE-15.4-2022-4194
openSUSE Tumbleweed
  • ffmpeg-4 >= 4.4.3-2.1
  • ffmpeg-4-libavcodec-devel >= 4.4.3-2.1
  • ffmpeg-4-libavdevice-devel >= 4.4.3-2.1
  • ffmpeg-4-libavfilter-devel >= 4.4.3-2.1
  • ffmpeg-4-libavformat-devel >= 4.4.3-2.1
  • ffmpeg-4-libavresample-devel >= 4.4.3-2.1
  • ffmpeg-4-libavutil-devel >= 4.4.3-2.1
  • ffmpeg-4-libpostproc-devel >= 4.4.3-2.1
  • ffmpeg-4-libswresample-devel >= 4.4.3-2.1
  • ffmpeg-4-libswscale-devel >= 4.4.3-2.1
  • ffmpeg-4-private-devel >= 4.4.3-2.1
  • ffmpeg-5 >= 5.1.2-4.1
  • ffmpeg-5-libavcodec-devel >= 5.1.2-4.1
  • ffmpeg-5-libavdevice-devel >= 5.1.2-4.1
  • ffmpeg-5-libavfilter-devel >= 5.1.2-4.1
  • ffmpeg-5-libavformat-devel >= 5.1.2-4.1
  • ffmpeg-5-libavutil-devel >= 5.1.2-4.1
  • ffmpeg-5-libpostproc-devel >= 5.1.2-4.1
  • ffmpeg-5-libswresample-devel >= 5.1.2-4.1
  • ffmpeg-5-libswscale-devel >= 5.1.2-4.1
  • ffmpeg-5-private-devel >= 5.1.2-4.1
  • libavcodec58_134 >= 4.4.3-2.1
  • libavcodec58_134-32bit >= 4.4.3-2.1
  • libavcodec59 >= 5.1.2-4.1
  • libavcodec59-32bit >= 5.1.2-4.1
  • libavdevice58_13 >= 4.4.3-2.1
  • libavdevice58_13-32bit >= 4.4.3-2.1
  • libavdevice59 >= 5.1.2-4.1
  • libavdevice59-32bit >= 5.1.2-4.1
  • libavfilter7_110 >= 4.4.3-2.1
  • libavfilter7_110-32bit >= 4.4.3-2.1
  • libavfilter8 >= 5.1.2-4.1
  • libavfilter8-32bit >= 5.1.2-4.1
  • libavformat58_76 >= 4.4.3-2.1
  • libavformat58_76-32bit >= 4.4.3-2.1
  • libavformat59 >= 5.1.2-4.1
  • libavformat59-32bit >= 5.1.2-4.1
  • libavresample4_0 >= 4.4.3-2.1
  • libavresample4_0-32bit >= 4.4.3-2.1
  • libavutil56_70 >= 4.4.3-2.1
  • libavutil56_70-32bit >= 4.4.3-2.1
  • libavutil57 >= 5.1.2-4.1
  • libavutil57-32bit >= 5.1.2-4.1
  • libpostproc55_9 >= 4.4.3-2.1
  • libpostproc55_9-32bit >= 4.4.3-2.1
  • libpostproc56 >= 5.1.2-4.1
  • libpostproc56-32bit >= 5.1.2-4.1
  • libswresample3_9 >= 4.4.3-2.1
  • libswresample3_9-32bit >= 4.4.3-2.1
  • libswresample4 >= 5.1.2-4.1
  • libswresample4-32bit >= 5.1.2-4.1
  • libswscale5_9 >= 4.4.3-2.1
  • libswscale5_9-32bit >= 4.4.3-2.1
  • libswscale6 >= 5.1.2-4.1
  • libswscale6-32bit >= 5.1.2-4.1
Patchnames:
openSUSE Tumbleweed GA ffmpeg-4-4.4.3-2.1
openSUSE Tumbleweed GA ffmpeg-5-5.1.2-4.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7 ffmpeg Not affected
SUSE Enterprise Storage 7.1 ffmpeg Not affected
SUSE Linux Enterprise Desktop 15 SP4 ffmpeg Not affected
SUSE Linux Enterprise Desktop 15 SP4 ffmpeg-4 Released
SUSE Linux Enterprise High Performance Computing 15 SP4 ffmpeg Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 ffmpeg-4 Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 ffmpeg Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 ffmpeg-4 Released
SUSE Linux Enterprise Module for Package Hub 15 SP4 ffmpeg Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP4 ffmpeg-4 Released
SUSE Linux Enterprise Real Time 15 SP3 ffmpeg Not affected
SUSE Linux Enterprise Server 15 SP4 ffmpeg Not affected
SUSE Linux Enterprise Server 15 SP4 ffmpeg-4 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 ffmpeg Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 ffmpeg-4 Released
SUSE Linux Enterprise Workstation Extension 15 SP4 ffmpeg Not affected
SUSE Linux Enterprise Workstation Extension 15 SP4 ffmpeg-4 Released
SUSE Manager Proxy 4.2 ffmpeg Not affected
SUSE Manager Proxy 4.3 ffmpeg Not affected
SUSE Manager Proxy 4.3 ffmpeg-4 Released
SUSE Manager Retail Branch Server 4.2 ffmpeg Not affected
SUSE Manager Retail Branch Server 4.3 ffmpeg Not affected
SUSE Manager Retail Branch Server 4.3 ffmpeg-4 Released
SUSE Manager Server 4.2 ffmpeg Not affected
SUSE Manager Server 4.3 ffmpeg Not affected
SUSE Manager Server 4.3 ffmpeg-4 Released
SUSE Package Hub 15 SP4 ffmpeg-4 Released
openSUSE Leap 15.4 ffmpeg-4 Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 ffmpeg Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ffmpeg Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS ffmpeg Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS ffmpeg Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 ffmpeg Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS ffmpeg Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS ffmpeg Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 ffmpeg Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS ffmpeg Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS ffmpeg Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS ffmpeg Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS ffmpeg Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 ffmpeg Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 ffmpeg Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 ffmpeg Not affected
SUSE Linux Enterprise Server 15 SP1 ffmpeg Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS ffmpeg Not affected
SUSE Linux Enterprise Server 15 SP2 ffmpeg Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS ffmpeg Not affected
SUSE Linux Enterprise Server 15 SP3 ffmpeg Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS ffmpeg Not affected
SUSE Linux Enterprise Server 15-ESPOS ffmpeg Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 ffmpeg Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 ffmpeg Not affected
SUSE Linux Enterprise Server for SAP Applications 15 ffmpeg Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 ffmpeg Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 ffmpeg Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 ffmpeg Not affected
Products past their end of life and not receiving proactive updates anymore.
SUSE CaaS Platform 4.0 ffmpeg Not affected
SUSE Enterprise Storage 6 ffmpeg Not affected
SUSE Linux Enterprise Desktop 15 ffmpeg Not affected
SUSE Linux Enterprise Desktop 15 SP1 ffmpeg Not affected
SUSE Linux Enterprise Desktop 15 SP2 ffmpeg Not affected
SUSE Linux Enterprise Desktop 15 SP3 ffmpeg Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 ffmpeg Not affected
SUSE Linux Enterprise Module for Package Hub 15 ffmpeg Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP1 ffmpeg Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP2 ffmpeg Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP3 ffmpeg Not affected
SUSE Linux Enterprise Real Time 15 SP2 ffmpeg Not affected
SUSE Linux Enterprise Server 15 ffmpeg Not affected
SUSE Linux Enterprise Server 15 SP1-BCL ffmpeg Not affected
SUSE Linux Enterprise Server 15 SP2-BCL ffmpeg Not affected
SUSE Linux Enterprise Server 15 SP3-BCL ffmpeg Not affected
SUSE Linux Enterprise Server 15-LTSS ffmpeg Not affected
SUSE Linux Enterprise Workstation Extension 15 ffmpeg Not affected
SUSE Linux Enterprise Workstation Extension 15 SP1 ffmpeg Not affected
SUSE Linux Enterprise Workstation Extension 15 SP2 ffmpeg Not affected
SUSE Linux Enterprise Workstation Extension 15 SP3 ffmpeg Not affected
SUSE Manager Proxy 4.0 ffmpeg Not affected
SUSE Manager Proxy 4.1 ffmpeg Not affected
SUSE Manager Retail Branch Server 4.0 ffmpeg Not affected
SUSE Manager Retail Branch Server 4.1 ffmpeg Not affected
SUSE Manager Server 4.0 ffmpeg Not affected
SUSE Manager Server 4.1 ffmpeg Not affected


SUSE Timeline for this CVE

CVE page created: Mon Nov 14 01:00:00 2022
CVE page last modified: Fri Jan 20 16:24:29 2023