Upstream information

CVE-2022-28463 at MITRE

Description

ImageMagick 7.1.0-27 is vulnerable to Buffer Overflow.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 5.5
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
Access Vector Local Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High None
Availability Impact High None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1199350 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.172.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.172.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.172.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.172.1
Patchnames:
HPE-Helion-OpenStack-8-2022-1885
SUSE Linux Enterprise Desktop 12 SP5
SUSE Linux Enterprise Workstation Extension 12 SP5
  • ImageMagick >= 6.8.8.1-71.172.1
  • libMagick++-6_Q16-3 >= 6.8.8.1-71.172.1
  • libMagickCore-6_Q16-1-32bit >= 6.8.8.1-71.172.1
Patchnames:
SUSE-SLE-WE-12-SP5-2022-1885
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Storage 7.1
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • ImageMagick >= 7.0.7.34-150200.10.26.1
  • ImageMagick-config-7-SUSE >= 7.0.7.34-150200.10.26.1
  • ImageMagick-config-7-upstream >= 7.0.7.34-150200.10.26.1
  • ImageMagick-devel >= 7.0.7.34-150200.10.26.1
  • libMagick++-7_Q16HDRI4 >= 7.0.7.34-150200.10.26.1
  • libMagick++-devel >= 7.0.7.34-150200.10.26.1
  • libMagickCore-7_Q16HDRI6 >= 7.0.7.34-150200.10.26.1
  • libMagickWand-7_Q16HDRI6 >= 7.0.7.34-150200.10.26.1
  • perl-PerlMagick >= 7.0.7.34-150200.10.26.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP3-2022-1762
SUSE-SLE-Module-Development-Tools-15-SP3-2022-1762
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
  • ImageMagick >= 7.0.7.34-150200.10.26.1
  • ImageMagick-config-7-SUSE >= 7.0.7.34-150200.10.26.1
  • ImageMagick-config-7-upstream >= 7.0.7.34-150200.10.26.1
  • ImageMagick-devel >= 7.0.7.34-150200.10.26.1
  • libMagick++-7_Q16HDRI4 >= 7.0.7.34-150200.10.26.1
  • libMagick++-devel >= 7.0.7.34-150200.10.26.1
  • libMagickCore-7_Q16HDRI6 >= 7.0.7.34-150200.10.26.1
  • libMagickWand-7_Q16HDRI6 >= 7.0.7.34-150200.10.26.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP3-2022-1762
SUSE Linux Enterprise Module for Development Tools 15 SP3
  • perl-PerlMagick >= 7.0.7.34-150200.10.26.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP3-2022-1762
SUSE Linux Enterprise Server 12 SP2-BCL
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.172.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.172.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.172.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.172.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2022-1885
SUSE Linux Enterprise Server 12 SP3-BCL
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.172.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.172.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.172.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.172.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2022-1885
SUSE Linux Enterprise Server 12 SP3-ESPOS
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.172.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.172.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.172.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.172.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2022-1885
SUSE Linux Enterprise Server 12 SP3-LTSS
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.172.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.172.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.172.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.172.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2022-1885
SUSE Linux Enterprise Server 12 SP4-ESPOS
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.172.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.172.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.172.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.172.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-ESPOS-2022-1885
SUSE Linux Enterprise Server 12 SP4-LTSS
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.172.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.172.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.172.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.172.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-LTSS-2022-1885
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • ImageMagick >= 6.8.8.1-71.172.1
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.172.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.172.1
  • ImageMagick-devel >= 6.8.8.1-71.172.1
  • libMagick++-6_Q16-3 >= 6.8.8.1-71.172.1
  • libMagick++-devel >= 6.8.8.1-71.172.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.172.1
  • libMagickCore-6_Q16-1-32bit >= 6.8.8.1-71.172.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.172.1
  • perl-PerlMagick >= 6.8.8.1-71.172.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2022-1885
SUSE-SLE-SERVER-12-SP5-2022-1885
SUSE-SLE-WE-12-SP5-2022-1885
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.172.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.172.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.172.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.172.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2022-1885
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.172.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.172.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.172.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.172.1
Patchnames:
SUSE-SLE-SAP-12-SP4-2022-1885
SUSE Linux Enterprise Software Development Kit 12 SP5
  • ImageMagick >= 6.8.8.1-71.172.1
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.172.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.172.1
  • ImageMagick-devel >= 6.8.8.1-71.172.1
  • libMagick++-6_Q16-3 >= 6.8.8.1-71.172.1
  • libMagick++-devel >= 6.8.8.1-71.172.1
  • perl-PerlMagick >= 6.8.8.1-71.172.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2022-1885
SUSE OpenStack Cloud 8
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.172.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.172.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.172.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.172.1
Patchnames:
SUSE-OpenStack-Cloud-8-2022-1885
SUSE OpenStack Cloud 9
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.172.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.172.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.172.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.172.1
Patchnames:
SUSE-OpenStack-Cloud-9-2022-1885
SUSE OpenStack Cloud Crowbar 8
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.172.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.172.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.172.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.172.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2022-1885
SUSE OpenStack Cloud Crowbar 9
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.172.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.172.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.172.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.172.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2022-1885
openSUSE Leap 15.3
  • ImageMagick >= 7.0.7.34-150200.10.26.1
  • ImageMagick-config-7-SUSE >= 7.0.7.34-150200.10.26.1
  • ImageMagick-config-7-upstream >= 7.0.7.34-150200.10.26.1
  • ImageMagick-devel >= 7.0.7.34-150200.10.26.1
  • ImageMagick-devel-32bit >= 7.0.7.34-150200.10.26.1
  • ImageMagick-doc >= 7.0.7.34-150200.10.26.1
  • ImageMagick-extra >= 7.0.7.34-150200.10.26.1
  • libMagick++-7_Q16HDRI4 >= 7.0.7.34-150200.10.26.1
  • libMagick++-7_Q16HDRI4-32bit >= 7.0.7.34-150200.10.26.1
  • libMagick++-devel >= 7.0.7.34-150200.10.26.1
  • libMagick++-devel-32bit >= 7.0.7.34-150200.10.26.1
  • libMagickCore-7_Q16HDRI6 >= 7.0.7.34-150200.10.26.1
  • libMagickCore-7_Q16HDRI6-32bit >= 7.0.7.34-150200.10.26.1
  • libMagickWand-7_Q16HDRI6 >= 7.0.7.34-150200.10.26.1
  • libMagickWand-7_Q16HDRI6-32bit >= 7.0.7.34-150200.10.26.1
  • perl-PerlMagick >= 7.0.7.34-150200.10.26.1
Patchnames:
openSUSE-SLE-15.3-2022-1762
openSUSE Leap 15.4
  • libMagick++-7_Q16HDRI4 >= 7.0.7.34-150200.10.26.1
  • libMagick++-7_Q16HDRI4-32bit >= 7.0.7.34-150200.10.26.1
  • libMagickCore-7_Q16HDRI6 >= 7.0.7.34-150200.10.26.1
  • libMagickCore-7_Q16HDRI6-32bit >= 7.0.7.34-150200.10.26.1
  • libMagickWand-7_Q16HDRI6 >= 7.0.7.34-150200.10.26.1
  • libMagickWand-7_Q16HDRI6-32bit >= 7.0.7.34-150200.10.26.1
Patchnames:
openSUSE-SLE-15.4-2022-1762


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 ImageMagick Released
SUSE CaaS Platform 4.0 ImageMagick In progress
SUSE Enterprise Storage 6 ImageMagick In progress
SUSE Enterprise Storage 7 ImageMagick Released
SUSE Linux Enterprise Desktop 12 SP5 ImageMagick Released
SUSE Linux Enterprise Desktop 15 SP3 ImageMagick Released
SUSE Linux Enterprise Desktop 15 SP4 ImageMagick Affected
SUSE Linux Enterprise High Performance Computing 12 SP5 ImageMagick Released
SUSE Linux Enterprise High Performance Computing 15 LTSS ImageMagick In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS ImageMagick In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS ImageMagick In progress
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS ImageMagick Released
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS ImageMagick Released
SUSE Linux Enterprise High Performance Computing 15 SP3 ImageMagick Released
SUSE Linux Enterprise High Performance Computing 15 SP4 ImageMagick Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 ImageMagick Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 ImageMagick Affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 ImageMagick Released
SUSE Linux Enterprise Module for Development Tools 15 SP4 ImageMagick Affected
SUSE Linux Enterprise Real Time 15 SP2 ImageMagick Released
SUSE Linux Enterprise Server 12 SP2 BCL ImageMagick Released
SUSE Linux Enterprise Server 12 SP3 BCL ImageMagick Released
SUSE Linux Enterprise Server 12 SP3 ESPOS ImageMagick Released
SUSE Linux Enterprise Server 12 SP3 LTSS ImageMagick Released
SUSE Linux Enterprise Server 12 SP4 ESPOS ImageMagick Released
SUSE Linux Enterprise Server 12 SP4 LTSS ImageMagick Released
SUSE Linux Enterprise Server 12 SP5 ImageMagick Released
SUSE Linux Enterprise Server 15 ESPOS ImageMagick In progress
SUSE Linux Enterprise Server 15 LTSS ImageMagick In progress
SUSE Linux Enterprise Server 15 SP1 LTSS ImageMagick In progress
SUSE Linux Enterprise Server 15 SP2 LTSS ImageMagick Released
SUSE Linux Enterprise Server 15 SP3 ImageMagick Released
SUSE Linux Enterprise Server 15 SP4 ImageMagick Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 ImageMagick In progress
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 ImageMagick Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 ImageMagick Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 ImageMagick Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 ImageMagick Released
SUSE Linux Enterprise Server for SAP Applications 15 ImageMagick In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP1 ImageMagick In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP2 ImageMagick Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 ImageMagick Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 ImageMagick Affected
SUSE Linux Enterprise Software Development Kit 12 SP5 ImageMagick Released
SUSE Linux Enterprise Storage 7.1 ImageMagick Released
SUSE Linux Enterprise Workstation Extension 12 SP5 ImageMagick Released
SUSE Manager Proxy 4.1 ImageMagick Released
SUSE Manager Proxy 4.2 ImageMagick Released
SUSE Manager Proxy 4.3 ImageMagick Affected
SUSE Manager Retail Branch Server 4.1 ImageMagick Released
SUSE Manager Retail Branch Server 4.2 ImageMagick Released
SUSE Manager Retail Branch Server 4.3 ImageMagick Affected
SUSE Manager Server 4.1 ImageMagick Released
SUSE Manager Server 4.2 ImageMagick Released
SUSE Manager Server 4.3 ImageMagick Affected
SUSE OpenStack Cloud 8 ImageMagick Released
SUSE OpenStack Cloud 9 ImageMagick Released
SUSE OpenStack Cloud Crowbar 8 ImageMagick Released
SUSE OpenStack Cloud Crowbar 9 ImageMagick Released