Upstream information

CVE-2022-26981 at MITRE

Description

Liblouis through 3.21.0 has a buffer overflow in compilePassOpcode in compileTranslationTable.c (called, indirectly, by tools/lou_checktable.c).

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 7.1
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H
Access Vector Local Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High None
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1197085 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 7
  • liblouis-data >= 3.11.0-150200.3.3.1
  • liblouis-devel >= 3.11.0-150200.3.3.1
  • liblouis19 >= 3.11.0-150200.3.3.1
  • python3-louis >= 3.11.0-150200.3.3.1
Patchnames:
SUSE-Storage-7-2022-2184
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Storage 7.1
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • liblouis-data >= 3.11.0-150200.3.3.1
  • liblouis-devel >= 3.11.0-150200.3.3.1
  • liblouis19 >= 3.11.0-150200.3.3.1
  • python3-louis >= 3.11.0-150200.3.3.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP3-2022-2184
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS
  • liblouis-data >= 3.11.0-150200.3.3.1
  • liblouis-devel >= 3.11.0-150200.3.3.1
  • liblouis19 >= 3.11.0-150200.3.3.1
  • python3-louis >= 3.11.0-150200.3.3.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP2-ESPOS-2022-2184
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS
  • liblouis-data >= 3.11.0-150200.3.3.1
  • liblouis-devel >= 3.11.0-150200.3.3.1
  • liblouis19 >= 3.11.0-150200.3.3.1
  • python3-louis >= 3.11.0-150200.3.3.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP2-LTSS-2022-2184
SUSE Linux Enterprise Server 15 SP2-BCL
  • liblouis-data >= 3.11.0-150200.3.3.1
  • liblouis-devel >= 3.11.0-150200.3.3.1
  • liblouis19 >= 3.11.0-150200.3.3.1
  • python3-louis >= 3.11.0-150200.3.3.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP2-BCL-2022-2184
SUSE Linux Enterprise Server 15 SP2-LTSS
  • liblouis-data >= 3.11.0-150200.3.3.1
  • liblouis-devel >= 3.11.0-150200.3.3.1
  • liblouis19 >= 3.11.0-150200.3.3.1
  • python3-louis >= 3.11.0-150200.3.3.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP2-LTSS-2022-2184
SUSE Linux Enterprise Server for SAP Applications 15 SP2
  • liblouis-data >= 3.11.0-150200.3.3.1
  • liblouis-devel >= 3.11.0-150200.3.3.1
  • liblouis19 >= 3.11.0-150200.3.3.1
  • python3-louis >= 3.11.0-150200.3.3.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP2-2022-2184
SUSE Manager Proxy 4.1
  • liblouis-data >= 3.11.0-150200.3.3.1
  • liblouis-devel >= 3.11.0-150200.3.3.1
  • liblouis19 >= 3.11.0-150200.3.3.1
  • python3-louis >= 3.11.0-150200.3.3.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.1-2022-2184
SUSE Manager Retail Branch Server 4.1
  • liblouis-data >= 3.11.0-150200.3.3.1
  • liblouis-devel >= 3.11.0-150200.3.3.1
  • liblouis19 >= 3.11.0-150200.3.3.1
  • python3-louis >= 3.11.0-150200.3.3.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.1-2022-2184
SUSE Manager Server 4.1
  • liblouis-data >= 3.11.0-150200.3.3.1
  • liblouis-devel >= 3.11.0-150200.3.3.1
  • liblouis19 >= 3.11.0-150200.3.3.1
  • python3-louis >= 3.11.0-150200.3.3.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.1-2022-2184
openSUSE Leap 15.3
  • liblouis-data >= 3.11.0-150200.3.3.1
  • liblouis-devel >= 3.11.0-150200.3.3.1
  • liblouis-doc >= 3.11.0-150200.3.3.1
  • liblouis-tools >= 3.11.0-150200.3.3.1
  • liblouis19 >= 3.11.0-150200.3.3.1
  • python3-louis >= 3.11.0-150200.3.3.1
Patchnames:
openSUSE-SLE-15.3-2022-2184
openSUSE Leap 15.4
  • liblouis19 >= 3.11.0-150200.3.3.1
Patchnames:
openSUSE-SLE-15.4-2022-2184
openSUSE Tumbleweed
  • liblouis-data >= 3.21.0-2.1
  • liblouis-devel >= 3.21.0-2.1
  • liblouis-doc >= 3.21.0-2.1
  • liblouis-tools >= 3.21.0-2.1
  • liblouis20 >= 3.21.0-2.1
  • python3-louis >= 3.21.0-2.1
Patchnames:
openSUSE Tumbleweed GA liblouis-data-3.21.0-2.1

List of packages in QA

Product(s) Package(s)
SUSE CaaS Platform 4.0
  • liblouis-data >= 3.3.0-150000.4.8.1
  • liblouis-devel >= 3.3.0-150000.4.8.1
  • liblouis14 >= 3.3.0-150000.4.8.1
  • python3-louis >= 3.3.0-150000.4.8.1
SUSE Enterprise Storage 6
  • liblouis-data >= 3.3.0-150000.4.8.1
  • liblouis-devel >= 3.3.0-150000.4.8.1
  • liblouis14 >= 3.3.0-150000.4.8.1
  • python3-louis >= 3.3.0-150000.4.8.1
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS
  • liblouis-data >= 3.3.0-150000.4.8.1
  • liblouis-devel >= 3.3.0-150000.4.8.1
  • liblouis14 >= 3.3.0-150000.4.8.1
  • python3-louis >= 3.3.0-150000.4.8.1
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS
  • liblouis-data >= 3.3.0-150000.4.8.1
  • liblouis-devel >= 3.3.0-150000.4.8.1
  • liblouis14 >= 3.3.0-150000.4.8.1
  • python3-louis >= 3.3.0-150000.4.8.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS
  • liblouis-data >= 3.3.0-150000.4.8.1
  • liblouis-devel >= 3.3.0-150000.4.8.1
  • liblouis14 >= 3.3.0-150000.4.8.1
  • python3-louis >= 3.3.0-150000.4.8.1
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • liblouis-data >= 3.3.0-150000.4.8.1
  • liblouis-devel >= 3.3.0-150000.4.8.1
  • liblouis14 >= 3.3.0-150000.4.8.1
  • python3-louis >= 3.3.0-150000.4.8.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP4
  • liblouis-data >= 3.20.0-150400.3.3.1
  • liblouis-devel >= 3.20.0-150400.3.3.1
  • liblouis20 >= 3.20.0-150400.3.3.1
  • python3-louis >= 3.20.0-150400.3.3.1
SUSE Linux Enterprise Server 15 SP4
  • liblouis-data >= 3.20.0-150400.3.3.1
  • liblouis-devel >= 3.20.0-150400.3.3.1
  • liblouis20 >= 3.20.0-150400.3.3.1
  • python3-louis >= 3.20.0-150400.3.3.1
SUSE Linux Enterprise Desktop 15 SP4
  • liblouis-data >= 3.20.0-150400.3.3.1
  • liblouis-devel >= 3.20.0-150400.3.3.1
  • liblouis20 >= 3.20.0-150400.3.3.1
  • python3-louis >= 3.20.0-150400.3.3.1
SUSE Linux Enterprise Server for SAP Applications 15 SP4
  • liblouis-data >= 3.20.0-150400.3.3.1
  • liblouis-devel >= 3.20.0-150400.3.3.1
  • liblouis20 >= 3.20.0-150400.3.3.1
  • python3-louis >= 3.20.0-150400.3.3.1
SUSE Linux Enterprise High Performance Computing 15 SP4
  • liblouis-data >= 3.20.0-150400.3.3.1
  • liblouis-devel >= 3.20.0-150400.3.3.1
  • liblouis20 >= 3.20.0-150400.3.3.1
  • python3-louis >= 3.20.0-150400.3.3.1
SUSE Manager Server 4.3
  • liblouis-data >= 3.20.0-150400.3.3.1
  • liblouis-devel >= 3.20.0-150400.3.3.1
  • liblouis20 >= 3.20.0-150400.3.3.1
  • python3-louis >= 3.20.0-150400.3.3.1
SUSE Manager Proxy 4.3
  • liblouis-data >= 3.20.0-150400.3.3.1
  • liblouis-devel >= 3.20.0-150400.3.3.1
  • liblouis20 >= 3.20.0-150400.3.3.1
  • python3-louis >= 3.20.0-150400.3.3.1
SUSE Manager Retail Branch Server 4.3
  • liblouis-data >= 3.20.0-150400.3.3.1
  • liblouis-devel >= 3.20.0-150400.3.3.1
  • liblouis20 >= 3.20.0-150400.3.3.1
  • python3-louis >= 3.20.0-150400.3.3.1
SUSE Linux Enterprise Server 15 SP1-BCL
  • liblouis-data >= 3.3.0-150000.4.8.1
  • liblouis-devel >= 3.3.0-150000.4.8.1
  • liblouis14 >= 3.3.0-150000.4.8.1
  • python3-louis >= 3.3.0-150000.4.8.1
SUSE Linux Enterprise Server 15 SP1-LTSS
  • liblouis-data >= 3.3.0-150000.4.8.1
  • liblouis-devel >= 3.3.0-150000.4.8.1
  • liblouis14 >= 3.3.0-150000.4.8.1
  • python3-louis >= 3.3.0-150000.4.8.1
SUSE Linux Enterprise Server 15-LTSS
  • liblouis-data >= 3.3.0-150000.4.8.1
  • liblouis-devel >= 3.3.0-150000.4.8.1
  • liblouis14 >= 3.3.0-150000.4.8.1
  • python3-louis >= 3.3.0-150000.4.8.1
SUSE Linux Enterprise Server for SAP Applications 15
  • liblouis-data >= 3.3.0-150000.4.8.1
  • liblouis-devel >= 3.3.0-150000.4.8.1
  • liblouis14 >= 3.3.0-150000.4.8.1
  • python3-louis >= 3.3.0-150000.4.8.1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • liblouis-data >= 3.3.0-150000.4.8.1
  • liblouis-devel >= 3.3.0-150000.4.8.1
  • liblouis14 >= 3.3.0-150000.4.8.1
  • python3-louis >= 3.3.0-150000.4.8.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 liblouis Not affected
SUSE CaaS Platform 4.0 liblouis In progress
SUSE Enterprise Storage 6 liblouis In progress
SUSE Enterprise Storage 7 liblouis Released
SUSE Linux Enterprise Desktop 15 SP3 liblouis Released
SUSE Linux Enterprise Desktop 15 SP4 liblouis In progress
SUSE Linux Enterprise High Performance Computing 12 SP5 liblouis Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS liblouis In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS liblouis In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS liblouis In progress
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS liblouis Released
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS liblouis Released
SUSE Linux Enterprise High Performance Computing 15 SP3 liblouis Released
SUSE Linux Enterprise High Performance Computing 15 SP4 liblouis In progress
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 liblouis Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 liblouis In progress
SUSE Linux Enterprise Real Time 15 SP2 liblouis Affected
SUSE Linux Enterprise Server 11 SP1 liblouis Not affected
SUSE Linux Enterprise Server 11 SP3 liblouis Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS liblouis Not affected
SUSE Linux Enterprise Server 12 SP2 BCL liblouis Not affected
SUSE Linux Enterprise Server 12 SP3 BCL liblouis Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS liblouis Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS liblouis Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS liblouis Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS liblouis Not affected
SUSE Linux Enterprise Server 12 SP5 liblouis Not affected
SUSE Linux Enterprise Server 15 ESPOS liblouis In progress
SUSE Linux Enterprise Server 15 LTSS liblouis In progress
SUSE Linux Enterprise Server 15 SP1 LTSS liblouis In progress
SUSE Linux Enterprise Server 15 SP2 LTSS liblouis Released
SUSE Linux Enterprise Server 15 SP3 liblouis Released
SUSE Linux Enterprise Server 15 SP4 liblouis In progress
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 liblouis In progress
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 liblouis Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 liblouis Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 liblouis Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 liblouis Not affected
SUSE Linux Enterprise Server for SAP Applications 15 liblouis In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP1 liblouis In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP2 liblouis Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 liblouis Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 liblouis In progress
SUSE Linux Enterprise Storage 7.1 liblouis Released
SUSE Manager Proxy 4.1 liblouis Released
SUSE Manager Proxy 4.2 liblouis Released
SUSE Manager Proxy 4.3 liblouis In progress
SUSE Manager Retail Branch Server 4.1 liblouis Released
SUSE Manager Retail Branch Server 4.2 liblouis Released
SUSE Manager Retail Branch Server 4.3 liblouis In progress
SUSE Manager Server 4.1 liblouis Released
SUSE Manager Server 4.2 liblouis Released
SUSE Manager Server 4.3 liblouis In progress
SUSE OpenStack Cloud 8 liblouis Not affected
SUSE OpenStack Cloud 9 liblouis Not affected
SUSE OpenStack Cloud Crowbar 8 liblouis Not affected
SUSE OpenStack Cloud Crowbar 9 liblouis Not affected