Upstream information

CVE-2022-26491 at MITRE

Description

An issue was discovered in Pidgin before 2.14.9. A remote attacker who can spoof DNS responses can redirect a client connection to a malicious server. The client will perform TLS certificate verification of the malicious domain name instead of the original XMPP service domain, allowing the attacker to take over control over the XMPP connection and to obtain user credentials and all communication content. This is similar to CVE-2022-24968.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.9 8.1
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Access Vector Network Network
Access Complexity High Low
Privileges Required None Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact None High
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1199025 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP5
SUSE Linux Enterprise Workstation Extension 12 SP5
  • finch >= 2.12.0-3.6.1
  • libpurple >= 2.12.0-3.6.1
  • libpurple-branding-upstream >= 2.12.0-3.6.1
  • libpurple-lang >= 2.12.0-3.6.1
  • libpurple-plugin-sametime >= 2.12.0-3.6.1
  • libpurple-tcl >= 2.12.0-3.6.1
  • pidgin >= 2.12.0-3.6.1
Patchnames:
SUSE-SLE-WE-12-SP5-2022-1664
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Workstation Extension 15 SP3
  • libpurple >= 2.13.0-150200.12.6.1
  • libpurple-branding-upstream >= 2.13.0-150200.12.6.1
  • libpurple-devel >= 2.13.0-150200.12.6.1
  • libpurple-lang >= 2.13.0-150200.12.6.1
  • libpurple-plugin-sametime >= 2.13.0-150200.12.6.1
  • pidgin >= 2.13.0-150200.12.6.1
  • pidgin-devel >= 2.13.0-150200.12.6.1
Patchnames:
SUSE-SLE-Product-WE-15-SP3-2022-1665
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Linux Enterprise Workstation Extension 15 SP4
  • libpurple >= 2.14.8-150400.3.3.1
  • libpurple-branding-upstream >= 2.14.8-150400.3.3.1
  • libpurple-client0 >= 2.14.8-150400.3.3.1
  • libpurple-devel >= 2.14.8-150400.3.3.1
  • libpurple-lang >= 2.14.8-150400.3.3.1
  • libpurple-plugin-sametime >= 2.14.8-150400.3.3.1
  • libpurple0 >= 2.14.8-150400.3.3.1
  • pidgin >= 2.14.8-150400.3.3.1
  • pidgin-devel >= 2.14.8-150400.3.3.1
Patchnames:
SUSE-SLE-Product-WE-15-SP4-2022-1693
SUSE Linux Enterprise Module for Package Hub 15 SP3
  • finch >= 2.13.0-150200.12.6.1
  • finch-devel >= 2.13.0-150200.12.6.1
  • libpurple >= 2.13.0-150200.12.6.1
  • libpurple-branding-upstream >= 2.13.0-150200.12.6.1
  • libpurple-devel >= 2.13.0-150200.12.6.1
  • libpurple-lang >= 2.13.0-150200.12.6.1
  • libpurple-plugin-sametime >= 2.13.0-150200.12.6.1
  • libpurple-tcl >= 2.13.0-150200.12.6.1
  • pidgin >= 2.13.0-150200.12.6.1
  • pidgin-devel >= 2.13.0-150200.12.6.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP3-2022-1665
SUSE Linux Enterprise Module for Package Hub 15 SP4
  • finch >= 2.14.8-150400.3.3.1
  • finch-devel >= 2.14.8-150400.3.3.1
  • libpurple >= 2.14.8-150400.3.3.1
  • libpurple-branding-upstream >= 2.14.8-150400.3.3.1
  • libpurple-devel >= 2.14.8-150400.3.3.1
  • libpurple-lang >= 2.14.8-150400.3.3.1
  • libpurple-plugin-sametime >= 2.14.8-150400.3.3.1
  • libpurple-tcl >= 2.14.8-150400.3.3.1
  • pidgin >= 2.14.8-150400.3.3.1
  • pidgin-devel >= 2.14.8-150400.3.3.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP4-2022-1693
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • finch >= 2.12.0-3.6.1
  • finch-devel >= 2.12.0-3.6.1
  • libpurple >= 2.12.0-3.6.1
  • libpurple-branding-upstream >= 2.12.0-3.6.1
  • libpurple-devel >= 2.12.0-3.6.1
  • libpurple-lang >= 2.12.0-3.6.1
  • libpurple-plugin-sametime >= 2.12.0-3.6.1
  • libpurple-tcl >= 2.12.0-3.6.1
  • pidgin >= 2.12.0-3.6.1
  • pidgin-devel >= 2.12.0-3.6.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2022-1664
SUSE-SLE-WE-12-SP5-2022-1664
SUSE Linux Enterprise Software Development Kit 12 SP5
  • finch-devel >= 2.12.0-3.6.1
  • libpurple >= 2.12.0-3.6.1
  • libpurple-devel >= 2.12.0-3.6.1
  • libpurple-lang >= 2.12.0-3.6.1
  • pidgin-devel >= 2.12.0-3.6.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2022-1664
openSUSE Leap 15.3
  • finch >= 2.13.0-150200.12.6.1
  • finch-devel >= 2.13.0-150200.12.6.1
  • libpurple >= 2.13.0-150200.12.6.1
  • libpurple-branding-upstream >= 2.13.0-150200.12.6.1
  • libpurple-devel >= 2.13.0-150200.12.6.1
  • libpurple-lang >= 2.13.0-150200.12.6.1
  • libpurple-plugin-sametime >= 2.13.0-150200.12.6.1
  • libpurple-tcl >= 2.13.0-150200.12.6.1
  • pidgin >= 2.13.0-150200.12.6.1
  • pidgin-devel >= 2.13.0-150200.12.6.1
Patchnames:
openSUSE-SLE-15.3-2022-1665
openSUSE Leap 15.4
  • finch >= 2.13.0-150200.12.6.1
  • finch-devel >= 2.13.0-150200.12.6.1
  • libpurple >= 2.13.0-150200.12.6.1
  • libpurple-branding-upstream >= 2.13.0-150200.12.6.1
  • libpurple-devel >= 2.13.0-150200.12.6.1
  • libpurple-lang >= 2.13.0-150200.12.6.1
  • libpurple-plugin-sametime >= 2.13.0-150200.12.6.1
  • libpurple-tcl >= 2.13.0-150200.12.6.1
  • pidgin >= 2.13.0-150200.12.6.1
  • pidgin-devel >= 2.13.0-150200.12.6.1
Patchnames:
openSUSE-SLE-15.4-2022-1665
openSUSE Tumbleweed
  • finch >= 2.14.9-1.1
  • finch-devel >= 2.14.9-1.1
  • libpurple >= 2.14.9-1.1
  • libpurple-branding-upstream >= 2.14.9-1.1
  • libpurple-client0 >= 2.14.9-1.1
  • libpurple-devel >= 2.14.9-1.1
  • libpurple-lang >= 2.14.9-1.1
  • libpurple-plugin-sametime >= 2.14.9-1.1
  • libpurple-tcl >= 2.14.9-1.1
  • libpurple0 >= 2.14.9-1.1
  • pidgin >= 2.14.9-1.1
  • pidgin-devel >= 2.14.9-1.1
Patchnames:
openSUSE Tumbleweed GA finch-2.14.9-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP5 pidgin Released
SUSE Linux Enterprise Desktop 15 SP3 pidgin Released
SUSE Linux Enterprise Desktop 15 SP4 pidgin Released
SUSE Linux Enterprise Server 12 SP5 pidgin Released
SUSE Linux Enterprise Server 15 SP3 pidgin Released
SUSE Linux Enterprise Server 15 SP4 pidgin Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 pidgin Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 pidgin Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 pidgin Released
SUSE Linux Enterprise Software Development Kit 12 SP5 pidgin Released
SUSE Linux Enterprise Workstation Extension 12 SP5 pidgin Released
SUSE Linux Enterprise Workstation Extension 15 SP3 pidgin Released
SUSE Linux Enterprise Workstation Extension 15 SP4 pidgin Released
SUSE Package Hub 15 SP3 pidgin Released
SUSE Package Hub 15 SP4 pidgin Released