Upstream information

CVE-2022-21653 at MITRE

Description

Jawn is an open source JSON parser. Extenders of the `org.typelevel.jawn.SimpleFacade` and `org.typelevel.jawn.MutableFacade` who don't override `objectContext()` are vulnerable to a hash collision attack which may result in a denial of service. Most applications do not implement these traits directly, but inherit from a library. `jawn-parser-1.3.1` fixes this issue and users are advised to upgrade. For users unable to upgrade override `objectContext()` to use a collision-safe collection.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1194358 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub 15 SP2
  • jawn-ast >= 0.14.1-bp152.2.3.1
  • jawn-json4s >= 0.14.1-bp152.2.3.1
  • jawn-parser >= 0.14.1-bp152.2.3.1
  • jawn-util >= 0.14.1-bp152.2.3.1
Patchnames:
openSUSE-2022-45
SUSE Package Hub 15 SP3
  • jawn-ast >= 0.14.1-bp153.2.3.1
  • jawn-json4s >= 0.14.1-bp153.2.3.1
  • jawn-parser >= 0.14.1-bp153.2.3.1
  • jawn-util >= 0.14.1-bp153.2.3.1
Patchnames:
openSUSE-2022-11
openSUSE Leap 15.3
  • jawn-ast >= 0.14.1-3.3.1
  • jawn-json4s >= 0.14.1-3.3.1
  • jawn-parser >= 0.14.1-3.3.1
  • jawn-util >= 0.14.1-3.3.1
Patchnames:
openSUSE-2022-11
openSUSE-SLE-15.3-2022-106
openSUSE Tumbleweed
  • jawn-ast >= 0.14.1-2.1
  • jawn-json4s >= 0.14.1-2.1
  • jawn-parser >= 0.14.1-2.1
  • jawn-util >= 0.14.1-2.1
Patchnames:
openSUSE Tumbleweed GA jawn-ast-0.14.1-2.1