Upstream information

CVE-2021-41098 at MITRE

Description

Nokogiri is a Rubygem providing HTML, XML, SAX, and Reader parsers with XPath and CSS selector support. In Nokogiri v1.12.4 and earlier, on JRuby only, the SAX parser resolves external entities by default. Users of Nokogiri on JRuby who parse untrusted documents using any of these classes are affected: Nokogiri::XML::SAX::Parse, Nokogiri::HTML4::SAX::Parser or its alias Nokogiri::HTML::SAX::Parser, Nokogiri::XML::SAX::PushParser, and Nokogiri::HTML4::SAX::PushParser or its alias Nokogiri::HTML::SAX::PushParser. JRuby users should upgrade to Nokogiri v1.12.5 or later to receive a patch for this issue. There are no workarounds available for v1.12.4 or earlier. CRuby users are not affected.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact None
Availability Impact None
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1191029 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • ruby2.7-rubygem-nokogiri >= 1.12.5-1.1
  • ruby3.0-rubygem-nokogiri >= 1.12.5-1.1
  • ruby3.1-rubygem-nokogiri >= 1.13.3-1.1
Patchnames:
openSUSE Tumbleweed GA ruby2.7-rubygem-nokogiri-1.12.5-1.1
openSUSE Tumbleweed GA ruby3.1-rubygem-nokogiri-1.13.3-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Availability Extension 15 rubygem-nokogiri Not affected
SUSE Linux Enterprise High Availability Extension 15 SP1 rubygem-nokogiri Not affected
SUSE Linux Enterprise High Availability Extension 15 SP2 rubygem-nokogiri Not affected
SUSE Linux Enterprise High Performance Computing 15 rubygem-nokogiri Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 rubygem-nokogiri Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 rubygem-nokogiri Not affected
SUSE Linux Enterprise Server 15 rubygem-nokogiri Not affected
SUSE Linux Enterprise Server 15 SP1 rubygem-nokogiri Not affected
SUSE Linux Enterprise Server 15 SP2 rubygem-nokogiri Not affected
SUSE Linux Enterprise Server for SAP Applications 15 rubygem-nokogiri Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 rubygem-nokogiri Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 rubygem-nokogiri Not affected
SUSE Manager Proxy 4.0 rubygem-nokogiri Not affected
SUSE Manager Proxy 4.1 rubygem-nokogiri Not affected
SUSE Manager Retail Branch Server 4.0 rubygem-nokogiri Not affected
SUSE Manager Retail Branch Server 4.1 rubygem-nokogiri Not affected
SUSE Manager Server 4.0 rubygem-nokogiri Not affected
SUSE Manager Server 4.1 rubygem-nokogiri Not affected
SUSE OpenStack Cloud Crowbar 8 rubygem-nokogiri Not affected
SUSE OpenStack Cloud Crowbar 9 rubygem-nokogiri Not affected