Upstream information

CVE-2021-40323 at MITRE

Description

Cobbler before 3.3.0 allows log poisoning, and resultant Remote Code Execution, via an XMLRPC method that logs to the logfile for template injection.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 9.1
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1189458 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES15-SP2-Manager-4-1-Server-BYOS-Azure
Image SLES15-SP2-Manager-4-1-Server-BYOS-EC2-HVM
Image SLES15-SP2-Manager-4-1-Server-BYOS-GCE
  • cobbler >= 3.0.0+git20190806.32c4bae0-8.22.6.1
Image SLES15-SP3-Manager-4-2-Server-BYOS-Azure
Image SLES15-SP3-Manager-4-2-Server-BYOS-EC2-HVM
Image SLES15-SP3-Manager-4-2-Server-BYOS-GCE
  • cobbler >= 3.1.2-5.8.1
SUSE Manager Server Module 4.1
  • cobbler >= 3.0.0+git20190806.32c4bae0-8.22.6.1
Patchnames:
SUSE-SLE-Module-SUSE-Manager-Server-4.1-2021-3151
SUSE Manager Server Module 4.2
  • cobbler >= 3.1.2-5.8.1
Patchnames:
SUSE-SLE-Module-SUSE-Manager-Server-4.2-2021-3170
SUSE Package Hub 15 SP3
  • cobbler >= 3.1.2-bp153.2.3.1
  • cobbler-tests >= 3.1.2-bp153.2.3.1
  • cobbler-web >= 3.1.2-bp153.2.3.1
Patchnames:
openSUSE-2022-62
openSUSE Leap 15.3
  • cobbler >= 3.1.2-bp153.2.3.1
  • cobbler-tests >= 3.1.2-bp153.2.3.1
  • cobbler-web >= 3.1.2-bp153.2.3.1
Patchnames:
openSUSE-2022-62


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise Server 11 SP3-CLIENT-TOOLS cobbler Not affected
SUSE Linux Enterprise Server 11 SP4-CLIENT-TOOLS cobbler Not affected
SUSE Manager Client Tools Beta for SLE 12 cobbler Released
SUSE Manager Client Tools for SLE 12 cobbler Released
SUSE Manager Server 4.2 release-notes-susemanager Released
SUSE Manager Server 4.3 release-notes-susemanager Already fixed
SUSE Manager Server Module 4.2 cobbler Released
SUSE Manager Tools 12 cobbler Affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 cobbler Released
SUSE Manager Server 3.0 cobbler Affected
SUSE Manager Server Module 4.0 cobbler Affected
SUSE Manager Server Module 4.1 cobbler Released
SUSE OpenStack Cloud 8 cobbler Released
SUSE OpenStack Cloud 9 cobbler Released
SUSE Package Hub 15 SP3 cobbler Released


SUSE Timeline for this CVE

CVE page created: Mon Aug 16 11:15:15 2021
CVE page last modified: Thu Mar 16 16:04:36 2023