Upstream information

CVE-2021-37600 at MITRE

Description

** DISPUTED ** An integer overflow in util-linux through 2.37.1 can potentially cause a buffer overflow if an attacker were able to use system resources in a way that leads to a large number in the /proc/sysvipc/sem file. NOTE: this is unexploitable in GNU C Library environments, and possibly in all realistic environments.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 1.2
Vector AV:L/AC:H/Au:N/C:N/I:N/A:P
Access Vector Local
Access Complexity High
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 5.5
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Access Vector Local Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1188921 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container suse/sle15:15.3
  • libblkid1 >= 2.36.2-4.5.1
  • libfdisk1 >= 2.36.2-4.5.1
  • libmount1 >= 2.36.2-4.5.1
  • libsmartcols1 >= 2.36.2-4.5.1
  • libuuid1 >= 2.36.2-4.5.1
  • util-linux >= 2.36.2-4.5.1
Container suse/sles12sp5:latest
  • libblkid1 >= 2.33.2-4.11.1
  • libfdisk1 >= 2.33.2-4.11.1
  • libmount1 >= 2.33.2-4.11.1
  • libsmartcols1 >= 2.33.2-4.11.1
  • libuuid1 >= 2.33.2-4.11.1
  • util-linux >= 2.33.2-4.11.1
HPE Helion Openstack 8
  • libblkid1 >= 2.29.2-3.24.1
  • libblkid1-32bit >= 2.29.2-3.24.1
  • libfdisk1 >= 2.29.2-3.24.1
  • libmount1 >= 2.29.2-3.24.1
  • libmount1-32bit >= 2.29.2-3.24.1
  • libsmartcols1 >= 2.29.2-3.24.1
  • libuuid1 >= 2.29.2-3.24.1
  • libuuid1-32bit >= 2.29.2-3.24.1
  • python-libmount >= 2.29.2-3.24.1
  • util-linux >= 2.29.2-3.24.1
  • util-linux-lang >= 2.29.2-3.24.1
  • util-linux-systemd >= 2.29.2-3.24.1
  • uuidd >= 2.29.2-3.24.1
Patchnames:
HPE-Helion-OpenStack-8-2021-3463
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libblkid-devel >= 2.36.2-4.5.1
  • libblkid-devel-static >= 2.36.2-4.5.1
  • libblkid1 >= 2.36.2-4.5.1
  • libblkid1-32bit >= 2.36.2-4.5.1
  • libfdisk-devel >= 2.36.2-4.5.1
  • libfdisk1 >= 2.36.2-4.5.1
  • libmount-devel >= 2.36.2-4.5.1
  • libmount1 >= 2.36.2-4.5.1
  • libmount1-32bit >= 2.36.2-4.5.1
  • libsmartcols-devel >= 2.36.2-4.5.1
  • libsmartcols1 >= 2.36.2-4.5.1
  • libuuid-devel >= 2.36.2-4.5.1
  • libuuid-devel-static >= 2.36.2-4.5.1
  • libuuid1 >= 2.36.2-4.5.1
  • libuuid1-32bit >= 2.36.2-4.5.1
  • util-linux >= 2.36.2-4.5.1
  • util-linux-lang >= 2.36.2-4.5.1
  • util-linux-systemd >= 2.36.2-4.5.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2021-3474
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP3
  • libblkid-devel-32bit >= 2.36.2-4.5.1
  • libfdisk-devel-32bit >= 2.36.2-4.5.1
  • libfdisk-devel-static >= 2.36.2-4.5.1
  • libfdisk1-32bit >= 2.36.2-4.5.1
  • libmount-devel-32bit >= 2.36.2-4.5.1
  • libmount-devel-static >= 2.36.2-4.5.1
  • libsmartcols-devel-32bit >= 2.36.2-4.5.1
  • libsmartcols-devel-static >= 2.36.2-4.5.1
  • libsmartcols1-32bit >= 2.36.2-4.5.1
  • libuuid-devel-32bit >= 2.36.2-4.5.1
  • python3-libmount >= 2.36.2-4.5.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP3-2021-3474
SUSE Linux Enterprise Module for Server Applications 15 SP3
  • uuidd >= 2.36.2-4.5.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP3-2021-3474
SUSE Linux Enterprise Server 12 SP3-BCL
  • libblkid1 >= 2.29.2-3.24.1
  • libblkid1-32bit >= 2.29.2-3.24.1
  • libfdisk1 >= 2.29.2-3.24.1
  • libmount1 >= 2.29.2-3.24.1
  • libmount1-32bit >= 2.29.2-3.24.1
  • libsmartcols1 >= 2.29.2-3.24.1
  • libuuid1 >= 2.29.2-3.24.1
  • libuuid1-32bit >= 2.29.2-3.24.1
  • python-libmount >= 2.29.2-3.24.1
  • util-linux >= 2.29.2-3.24.1
  • util-linux-lang >= 2.29.2-3.24.1
  • util-linux-systemd >= 2.29.2-3.24.1
  • uuidd >= 2.29.2-3.24.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2021-3463
SUSE Linux Enterprise Server 12 SP3-ESPOS
  • libblkid1 >= 2.29.2-3.24.1
  • libblkid1-32bit >= 2.29.2-3.24.1
  • libfdisk1 >= 2.29.2-3.24.1
  • libmount1 >= 2.29.2-3.24.1
  • libmount1-32bit >= 2.29.2-3.24.1
  • libsmartcols1 >= 2.29.2-3.24.1
  • libuuid1 >= 2.29.2-3.24.1
  • libuuid1-32bit >= 2.29.2-3.24.1
  • python-libmount >= 2.29.2-3.24.1
  • util-linux >= 2.29.2-3.24.1
  • util-linux-lang >= 2.29.2-3.24.1
  • util-linux-systemd >= 2.29.2-3.24.1
  • uuidd >= 2.29.2-3.24.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2021-3463
SUSE Linux Enterprise Server 12 SP3-LTSS
  • libblkid1 >= 2.29.2-3.24.1
  • libblkid1-32bit >= 2.29.2-3.24.1
  • libfdisk1 >= 2.29.2-3.24.1
  • libmount1 >= 2.29.2-3.24.1
  • libmount1-32bit >= 2.29.2-3.24.1
  • libsmartcols1 >= 2.29.2-3.24.1
  • libuuid1 >= 2.29.2-3.24.1
  • libuuid1-32bit >= 2.29.2-3.24.1
  • python-libmount >= 2.29.2-3.24.1
  • util-linux >= 2.29.2-3.24.1
  • util-linux-lang >= 2.29.2-3.24.1
  • util-linux-systemd >= 2.29.2-3.24.1
  • uuidd >= 2.29.2-3.24.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2021-3463
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libblkid1 >= 2.33.2-4.11.1
  • libblkid1-32bit >= 2.33.2-4.11.1
  • libfdisk1 >= 2.33.2-4.11.1
  • libmount1 >= 2.33.2-4.11.1
  • libmount1-32bit >= 2.33.2-4.11.1
  • libsmartcols1 >= 2.33.2-4.11.1
  • libuuid1 >= 2.33.2-4.11.1
  • libuuid1-32bit >= 2.33.2-4.11.1
  • python-libmount >= 2.33.2-4.11.1
  • util-linux >= 2.33.2-4.11.1
  • util-linux-lang >= 2.33.2-4.11.1
  • util-linux-systemd >= 2.33.2-4.11.1
  • uuidd >= 2.33.2-4.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2021-3475
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libblkid1 >= 2.29.2-3.24.1
  • libblkid1-32bit >= 2.29.2-3.24.1
  • libfdisk1 >= 2.29.2-3.24.1
  • libmount1 >= 2.29.2-3.24.1
  • libmount1-32bit >= 2.29.2-3.24.1
  • libsmartcols1 >= 2.29.2-3.24.1
  • libuuid1 >= 2.29.2-3.24.1
  • libuuid1-32bit >= 2.29.2-3.24.1
  • python-libmount >= 2.29.2-3.24.1
  • util-linux >= 2.29.2-3.24.1
  • util-linux-lang >= 2.29.2-3.24.1
  • util-linux-systemd >= 2.29.2-3.24.1
  • uuidd >= 2.29.2-3.24.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2021-3463
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libblkid-devel >= 2.33.2-4.11.1
  • libmount-devel >= 2.33.2-4.11.1
  • libsmartcols-devel >= 2.33.2-4.11.1
  • libuuid-devel >= 2.33.2-4.11.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2021-3475
SUSE Linux Enterprise Workstation Extension 12 SP5
  • libuuid-devel >= 2.33.2-4.11.1
Patchnames:
SUSE-SLE-WE-12-SP5-2021-3475
SUSE MicroOS 5.1
  • libblkid1 >= 2.36.2-4.5.1
  • libfdisk1 >= 2.36.2-4.5.1
  • libmount1 >= 2.36.2-4.5.1
  • libsmartcols1 >= 2.36.2-4.5.1
  • libuuid1 >= 2.36.2-4.5.1
  • util-linux >= 2.36.2-4.5.1
  • util-linux-systemd >= 2.36.2-4.5.1
Patchnames:
SUSE-SUSE-MicroOS-5.1-2021-3474
SUSE OpenStack Cloud 8
  • libblkid1 >= 2.29.2-3.24.1
  • libblkid1-32bit >= 2.29.2-3.24.1
  • libfdisk1 >= 2.29.2-3.24.1
  • libmount1 >= 2.29.2-3.24.1
  • libmount1-32bit >= 2.29.2-3.24.1
  • libsmartcols1 >= 2.29.2-3.24.1
  • libuuid1 >= 2.29.2-3.24.1
  • libuuid1-32bit >= 2.29.2-3.24.1
  • python-libmount >= 2.29.2-3.24.1
  • util-linux >= 2.29.2-3.24.1
  • util-linux-lang >= 2.29.2-3.24.1
  • util-linux-systemd >= 2.29.2-3.24.1
  • uuidd >= 2.29.2-3.24.1
Patchnames:
SUSE-OpenStack-Cloud-8-2021-3463
SUSE OpenStack Cloud Crowbar 8
  • libblkid1 >= 2.29.2-3.24.1
  • libblkid1-32bit >= 2.29.2-3.24.1
  • libfdisk1 >= 2.29.2-3.24.1
  • libmount1 >= 2.29.2-3.24.1
  • libmount1-32bit >= 2.29.2-3.24.1
  • libsmartcols1 >= 2.29.2-3.24.1
  • libuuid1 >= 2.29.2-3.24.1
  • libuuid1-32bit >= 2.29.2-3.24.1
  • python-libmount >= 2.29.2-3.24.1
  • util-linux >= 2.29.2-3.24.1
  • util-linux-lang >= 2.29.2-3.24.1
  • util-linux-systemd >= 2.29.2-3.24.1
  • uuidd >= 2.29.2-3.24.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2021-3463
openSUSE Leap 15.3
  • libblkid-devel >= 2.36.2-4.5.1
  • libblkid-devel-32bit >= 2.36.2-4.5.1
  • libblkid-devel-static >= 2.36.2-4.5.1
  • libblkid1 >= 2.36.2-4.5.1
  • libblkid1-32bit >= 2.36.2-4.5.1
  • libfdisk-devel >= 2.36.2-4.5.1
  • libfdisk-devel-32bit >= 2.36.2-4.5.1
  • libfdisk-devel-static >= 2.36.2-4.5.1
  • libfdisk1 >= 2.36.2-4.5.1
  • libfdisk1-32bit >= 2.36.2-4.5.1
  • libmount-devel >= 2.36.2-4.5.1
  • libmount-devel-32bit >= 2.36.2-4.5.1
  • libmount-devel-static >= 2.36.2-4.5.1
  • libmount1 >= 2.36.2-4.5.1
  • libmount1-32bit >= 2.36.2-4.5.1
  • libsmartcols-devel >= 2.36.2-4.5.1
  • libsmartcols-devel-32bit >= 2.36.2-4.5.1
  • libsmartcols-devel-static >= 2.36.2-4.5.1
  • libsmartcols1 >= 2.36.2-4.5.1
  • libsmartcols1-32bit >= 2.36.2-4.5.1
  • libuuid-devel >= 2.36.2-4.5.1
  • libuuid-devel-32bit >= 2.36.2-4.5.1
  • libuuid-devel-static >= 2.36.2-4.5.1
  • libuuid1 >= 2.36.2-4.5.1
  • libuuid1-32bit >= 2.36.2-4.5.1
  • python3-libmount >= 2.36.2-4.5.1
  • util-linux >= 2.36.2-4.5.1
  • util-linux-lang >= 2.36.2-4.5.1
  • util-linux-systemd >= 2.36.2-4.5.1
  • uuidd >= 2.36.2-4.5.1
Patchnames:
openSUSE-SLE-15.3-2021-3474

List of packages in QA

Product(s) Package(s)
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • libblkid-devel >= 2.33.2-4.16.1
  • libblkid-devel-static >= 2.33.2-4.16.1
  • libblkid1 >= 2.33.2-4.16.1
  • libblkid1-32bit >= 2.33.2-4.16.1
  • libfdisk-devel >= 2.33.2-4.16.1
  • libfdisk1 >= 2.33.2-4.16.1
  • libmount-devel >= 2.33.2-4.16.1
  • libmount1 >= 2.33.2-4.16.1
  • libmount1-32bit >= 2.33.2-4.16.1
  • libsmartcols-devel >= 2.33.2-4.16.1
  • libsmartcols1 >= 2.33.2-4.16.1
  • libuuid-devel >= 2.33.2-4.16.1
  • libuuid-devel-static >= 2.33.2-4.16.1
  • libuuid1 >= 2.33.2-4.16.1
  • libuuid1-32bit >= 2.33.2-4.16.1
  • util-linux >= 2.33.2-4.16.1
  • util-linux-lang >= 2.33.2-4.16.1
  • util-linux-systemd >= 2.33.2-4.16.1
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • libblkid-devel-32bit >= 2.33.2-4.16.1
  • libfdisk-devel-static >= 2.33.2-4.16.1
  • libmount-devel-32bit >= 2.33.2-4.16.1
  • libmount-devel-static >= 2.33.2-4.16.1
  • libsmartcols-devel-static >= 2.33.2-4.16.1
  • libuuid-devel-32bit >= 2.33.2-4.16.1
  • python3-libmount >= 2.33.2-4.16.1
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • uuidd >= 2.33.2-4.16.1
SUSE MicroOS 5.0
  • libblkid1 >= 2.33.2-4.16.1
  • libfdisk1 >= 2.33.2-4.16.1
  • libmount1 >= 2.33.2-4.16.1
  • libsmartcols1 >= 2.33.2-4.16.1
  • libuuid1 >= 2.33.2-4.16.1
  • util-linux >= 2.33.2-4.16.1
  • util-linux-systemd >= 2.33.2-4.16.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
Carwos 1 util-linux Affected
HPE Helion OpenStack 8 util-linux Released
SUSE CaaS Platform 4.0 util-linux In progress
SUSE Enterprise Storage 6 util-linux In progress
SUSE Linux Enterprise High Performance Computing 12 SP5 util-linux Released
SUSE Linux Enterprise High Performance Computing 15 LTSS util-linux In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS util-linux In progress
SUSE Linux Enterprise Micro 5.1 util-linux Released
SUSE Linux Enterprise Module for Basesystem 15 SP2 util-linux In progress
SUSE Linux Enterprise Module for Basesystem 15 SP3 util-linux Released
SUSE Linux Enterprise Point of Service 11 SP3 util-linux Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS util-linux Not affected
SUSE Linux Enterprise Server 12 SP2 BCL util-linux In progress
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON util-linux In progress
SUSE Linux Enterprise Server 12 SP2 LTSS SAP util-linux In progress
SUSE Linux Enterprise Server 12 SP3 BCL util-linux Released
SUSE Linux Enterprise Server 12 SP3 ESPOS util-linux Released
SUSE Linux Enterprise Server 12 SP3 LTSS util-linux Released
SUSE Linux Enterprise Server 12 SP4 ESPOS util-linux In progress
SUSE Linux Enterprise Server 12 SP4 LTSS util-linux In progress
SUSE Linux Enterprise Server 12 SP5 util-linux Released
SUSE Linux Enterprise Server 15 LTSS util-linux In progress
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux util-linux In progress
SUSE Linux Enterprise Server 15 SP1 LTSS util-linux In progress
SUSE Linux Enterprise Server ESPOS 15 util-linux In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP3 util-linux Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 util-linux In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP5 util-linux In progress
SUSE Linux Enterprise Server for SAP Applications 15 util-linux In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP1 util-linux In progress
SUSE Linux Enterprise Software Development Kit 12 SP5 util-linux Released
SUSE Linux Enterprise Workstation Extension 12 util-linux Released
SUSE Manager Proxy 4.0 util-linux Unsupported
SUSE Manager Retail Branch Server 4.0 util-linux Unsupported
SUSE Manager Server 4.0 util-linux Unsupported
SUSE OpenStack Cloud 8 util-linux Released
SUSE OpenStack Cloud 9 util-linux In progress
SUSE OpenStack Cloud Crowbar 8 util-linux Released
SUSE OpenStack Cloud Crowbar 9 util-linux In progress