Upstream information

CVE-2021-22116 at MITRE

Description

RabbitMQ all versions prior to 3.8.16 are prone to a denial of service vulnerability due to improper input validation in AMQP 1.0 client connection endpoint. A malicious user can exploit the vulnerability by sending malicious AMQP messages to the target RabbitMQ instance having the AMQP 1.0 plugin enabled.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 5.9
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network Network
Access Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1186203 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • erlang-rabbitmq-client >= 3.8.3-3.3.4
  • rabbitmq-server >= 3.8.3-3.3.4
  • rabbitmq-server-plugins >= 3.8.3-3.3.4
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP2-2021-3254
SUSE Linux Enterprise Module for Server Applications 15 SP3
  • erlang-rabbitmq-client >= 3.8.11-3.3.3
  • rabbitmq-server >= 3.8.11-3.3.3
  • rabbitmq-server-plugins >= 3.8.11-3.3.3
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP3-2021-3325
openSUSE Leap 15.2
  • erlang-rabbitmq-client >= 3.8.3-lp152.2.3.1
  • rabbitmq-server >= 3.8.3-lp152.2.3.1
  • rabbitmq-server-plugins >= 3.8.3-lp152.2.3.1
Patchnames:
openSUSE-2021-1334
openSUSE Leap 15.3
  • erlang-rabbitmq-client >= 3.8.11-3.3.3
  • rabbitmq-server >= 3.8.11-3.3.3
  • rabbitmq-server-plugins >= 3.8.11-3.3.3
Patchnames:
openSUSE-SLE-15.3-2021-3325


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 rabbitmq-server Affected
SUSE CaaS Platform 4.5 rabbitmq-server Released
SUSE Enterprise Storage 7 rabbitmq-server Released
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS rabbitmq-server Released
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS rabbitmq-server Released
SUSE Linux Enterprise Module for Server Applications 15 SP2 rabbitmq-server Released
SUSE Linux Enterprise Module for Server Applications 15 SP3 rabbitmq-server Released
SUSE Linux Enterprise Module for Server Applications 15 SP4 rabbitmq-server Released
SUSE Linux Enterprise Server 15 SP2 LTSS rabbitmq-server Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 rabbitmq-server Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 rabbitmq-server Released
SUSE Manager Proxy 4.1 rabbitmq-server Released
SUSE Manager Retail Branch Server 4.1 rabbitmq-server Released
SUSE Manager Server 4.1 rabbitmq-server Released
SUSE OpenStack Cloud 7 rabbitmq-server Unsupported
SUSE OpenStack Cloud 8 rabbitmq-server Affected
SUSE OpenStack Cloud 9 rabbitmq-server Affected
SUSE OpenStack Cloud Crowbar 8 rabbitmq-server Affected
SUSE OpenStack Cloud Crowbar 9 rabbitmq-server Affected