Upstream information

CVE-2020-8032 at MITRE

Description

A Insecure Temporary File vulnerability in the packaging of cyrus-sasl of openSUSE Factory allows local attackers to escalate to root. This issue affects: openSUSE Factory cyrus-sasl version 2.1.27-4.2 and prior versions.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.9
Vector AV:L/AC:M/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7 8.4
Vector CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Local Local
Access Complexity High Low
Privileges Required Low None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1180669 [IN_PROGRESS]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • cyrus-sasl >= 2.1.27-2.2
  • cyrus-sasl-32bit >= 2.1.27-2.2
  • cyrus-sasl-crammd5 >= 2.1.27-2.2
  • cyrus-sasl-crammd5-32bit >= 2.1.27-2.2
  • cyrus-sasl-devel >= 2.1.27-2.2
  • cyrus-sasl-digestmd5 >= 2.1.27-2.2
  • cyrus-sasl-digestmd5-32bit >= 2.1.27-2.2
  • cyrus-sasl-gssapi >= 2.1.27-2.2
  • cyrus-sasl-gssapi-32bit >= 2.1.27-2.2
  • cyrus-sasl-otp >= 2.1.27-2.2
  • cyrus-sasl-plain >= 2.1.27-2.2
  • cyrus-sasl-plain-32bit >= 2.1.27-2.2
  • libsasl2-3 >= 2.1.27-2.2
  • libsasl2-3-32bit >= 2.1.27-2.2
openSUSE Tumbleweed
  • cyrus-sasl >= 2.1.27-5.7
  • cyrus-sasl-32bit >= 2.1.27-5.7
  • cyrus-sasl-crammd5 >= 2.1.27-5.7
  • cyrus-sasl-crammd5-32bit >= 2.1.27-5.7
  • cyrus-sasl-devel >= 2.1.27-5.7
  • cyrus-sasl-devel-32bit >= 2.1.27-5.7
  • cyrus-sasl-digestmd5 >= 2.1.27-5.7
  • cyrus-sasl-digestmd5-32bit >= 2.1.27-5.7
  • cyrus-sasl-gs2 >= 2.1.27-5.7
  • cyrus-sasl-gssapi >= 2.1.27-5.7
  • cyrus-sasl-gssapi-32bit >= 2.1.27-5.7
  • cyrus-sasl-ntlm >= 2.1.27-5.7
  • cyrus-sasl-otp >= 2.1.27-5.7
  • cyrus-sasl-otp-32bit >= 2.1.27-5.7
  • cyrus-sasl-plain >= 2.1.27-5.7
  • cyrus-sasl-plain-32bit >= 2.1.27-5.7
  • cyrus-sasl-scram >= 2.1.27-5.7
  • libsasl2-3 >= 2.1.27-5.7
  • libsasl2-3-32bit >= 2.1.27-5.7
Patchnames:
openSUSE Tumbleweed GA cyrus-sasl-2.1.27-5.7


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 cyrus-sasl Not affected
SUSE CaaS Platform 4.0 cyrus-sasl Not affected
SUSE Enterprise Storage 5 cyrus-sasl Unsupported
SUSE Enterprise Storage 6 cyrus-sasl Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 cyrus-sasl Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS cyrus-sasl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS cyrus-sasl Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 cyrus-sasl Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP2 cyrus-sasl Not affected
SUSE Linux Enterprise Point of Service 11 SP3 cyrus-sasl Not affected
SUSE Linux Enterprise Point of Service Image Server 12 SP2 cyrus-sasl Unsupported
SUSE Linux Enterprise Server 11 SP4 LTSS cyrus-sasl Not affected
SUSE Linux Enterprise Server 12 SP2 ESPOS cyrus-sasl Unsupported
SUSE Linux Enterprise Server 12 SP2 LTSS cyrus-sasl Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS cyrus-sasl Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS cyrus-sasl Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS cyrus-sasl Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS cyrus-sasl Not affected
SUSE Linux Enterprise Server 12 SP5 cyrus-sasl Not affected
SUSE Linux Enterprise Server 15 ESPOS cyrus-sasl Not affected
SUSE Linux Enterprise Server 15 LTSS cyrus-sasl Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS cyrus-sasl Not affected
SUSE Linux Enterprise Server BCL 12 SP2 cyrus-sasl Not affected
SUSE Linux Enterprise Server BCL 12 SP3 cyrus-sasl Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 cyrus-sasl Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 cyrus-sasl Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 cyrus-sasl Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 cyrus-sasl Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 cyrus-sasl Not affected
SUSE Linux Enterprise Server for SAP Applications 15 cyrus-sasl Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 cyrus-sasl Not affected
SUSE Linux Enterprise Workstation Extension 12 SP5 cyrus-sasl Not affected
SUSE Manager Proxy 4.0 cyrus-sasl Not affected
SUSE Manager Retail Branch Server 4.0 cyrus-sasl Not affected
SUSE Manager Server 4.0 cyrus-sasl Not affected
SUSE OpenStack Cloud 7 cyrus-sasl Not affected
SUSE OpenStack Cloud 8 cyrus-sasl Not affected
SUSE OpenStack Cloud 9 cyrus-sasl Not affected
SUSE OpenStack Cloud Crowbar 8 cyrus-sasl Not affected
SUSE OpenStack Cloud Crowbar 9 cyrus-sasl Not affected