Upstream information

CVE-2020-36314 at MITRE

Description

fr-archive-libarchive.c in GNOME file-roller through 3.38.0, as used by GNOME Shell and other software, allows Directory Traversal during extraction because it lacks a check of whether a file's parent is a symlink in certain complex situations. NOTE: this issue exists because of an incomplete fix for CVE-2020-11736.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.6
Vector AV:L/AC:H/Au:N/C:N/I:P/A:P
Access Vector Local
Access Complexity High
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 3.9 3.9
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:L CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:L
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low Low
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact Low Low
Availability Impact Low Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1189131 [NEW]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • file-roller >= 3.40.0-3.2
  • file-roller-lang >= 3.40.0-3.2
  • nautilus-file-roller >= 3.40.0-3.2
Patchnames:
openSUSE Tumbleweed GA file-roller-3.40.0-3.2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 file-roller Affected
SUSE CaaS Platform 4.0 file-roller Affected
SUSE Enterprise Storage 6 file-roller Affected
SUSE Linux Enterprise High Performance Computing 12 SP5 file-roller Affected
SUSE Linux Enterprise High Performance Computing 15 LTSS file-roller Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS file-roller Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 file-roller Affected
SUSE Linux Enterprise Point of Service 11 SP3 file-roller Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS file-roller Not affected
SUSE Linux Enterprise Server 12 SP2 BCL file-roller Affected
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON file-roller Affected
SUSE Linux Enterprise Server 12 SP2 LTSS SAP file-roller Affected
SUSE Linux Enterprise Server 12 SP3 BCL file-roller Affected
SUSE Linux Enterprise Server 12 SP3 ESPOS file-roller Affected
SUSE Linux Enterprise Server 12 SP3 LTSS file-roller Affected
SUSE Linux Enterprise Server 12 SP4 ESPOS file-roller Affected
SUSE Linux Enterprise Server 12 SP4 LTSS file-roller Affected
SUSE Linux Enterprise Server 12 SP5 file-roller Affected
SUSE Linux Enterprise Server 15 LTSS file-roller Affected
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux file-roller Affected
SUSE Linux Enterprise Server 15 SP1 LTSS file-roller Affected
SUSE Linux Enterprise Server ESPOS 15 file-roller Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 file-roller Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 file-roller Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 file-roller Affected
SUSE Linux Enterprise Server for SAP Applications 15 file-roller Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 file-roller Affected
SUSE Manager Proxy 4.0 file-roller Unsupported
SUSE Manager Retail Branch Server 4.0 file-roller Unsupported
SUSE Manager Server 4.0 file-roller Unsupported
SUSE OpenStack Cloud 8 file-roller Affected
SUSE OpenStack Cloud 9 file-roller Affected
SUSE OpenStack Cloud Crowbar 8 file-roller Affected
SUSE OpenStack Cloud Crowbar 9 file-roller Affected