Upstream information

CVE-2020-16135 at MITRE

Description

libssh 0.9.4 has a NULL pointer dereference in tftpserver.c if ssh_buffer_new returns NULL.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.9 5.9
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network Network
Attack Complexity High High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1174713 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container suse/ltss/sle15.3/sle15:15.3.4.8
Container suse/sle-micro-rancher/5.2:latest
Container suse/sle15:15.2.9.5.406
Image SLES15-SP2-SAP-Azure-LI-BYOS-Production
Image SLES15-SP2-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP3-SAP-Azure-LI-BYOS-Production
Image SLES15-SP3-SAP-Azure-VLI-BYOS-Production
  • libssh-config >= 0.9.8-150200.13.3.1
  • libssh4 >= 0.9.8-150200.13.3.1
Container suse/sles12sp5:6.5.566
Image SLES12-SP5-Azure-BYOS
Image SLES12-SP5-SAP-Azure-LI-BYOS-Production
Image SLES12-SP5-SAP-Azure-VLI-BYOS-Production
  • libssh-config >= 0.9.8-3.12.2
  • libssh4 >= 0.9.8-3.12.2
SUSE Enterprise Storage 7.1
  • libssh-config >= 0.9.8-150200.13.3.1
  • libssh-devel >= 0.9.8-150200.13.3.1
  • libssh4 >= 0.9.8-150200.13.3.1
  • libssh4-32bit >= 0.9.8-150200.13.3.1
Patchnames:
SUSE-Storage-7.1-2024-525
SUSE Liberty Linux 8
  • libssh >= 0.9.4-3.el8
  • libssh-config >= 0.9.4-3.el8
  • libssh-devel >= 0.9.4-3.el8
Patchnames:
RHSA-2021:4387
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • libssh-config >= 0.9.6-150400.1.5
  • libssh-devel >= 0.9.6-150400.1.5
  • libssh4 >= 0.9.6-150400.1.5
  • libssh4-32bit >= 0.9.6-150400.1.5
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA libssh-config-0.9.6-150400.1.5
SUSE Linux Enterprise Desktop 15 SP5
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Module for Basesystem 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • libssh-config >= 0.9.6-150400.1.5
  • libssh-devel >= 0.9.6-150400.1.5
  • libssh4 >= 0.9.6-150400.1.5
  • libssh4-32bit >= 0.9.6-150400.1.5
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP5 GA libssh-config-0.9.6-150400.1.5
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS
  • libssh-config >= 0.9.8-150200.13.3.1
  • libssh-devel >= 0.9.8-150200.13.3.1
  • libssh4 >= 0.9.8-150200.13.3.1
  • libssh4-32bit >= 0.9.8-150200.13.3.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP2-LTSS-2024-525
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS
  • libssh-config >= 0.9.8-150200.13.3.1
  • libssh-devel >= 0.9.8-150200.13.3.1
  • libssh4 >= 0.9.8-150200.13.3.1
  • libssh4-32bit >= 0.9.8-150200.13.3.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP3-LTSS-2024-525
SUSE Linux Enterprise Micro 5.1
  • libssh-config >= 0.9.8-150200.13.3.1
  • libssh4 >= 0.9.8-150200.13.3.1
Patchnames:
SUSE-SUSE-MicroOS-5.1-2024-525
SUSE Linux Enterprise Micro 5.2
  • libssh-config >= 0.9.8-150200.13.3.1
  • libssh4 >= 0.9.8-150200.13.3.1
Patchnames:
SUSE-SUSE-MicroOS-5.2-2024-525
SUSE Linux Enterprise Micro 5.3
  • libssh-config >= 0.9.6-150400.1.5
  • libssh4 >= 0.9.6-150400.1.5
Patchnames:
SUSE Linux Enterprise Micro 5.3 GA libssh-config-0.9.6-150400.1.5
SUSE Linux Enterprise Micro 5.4
  • libssh-config >= 0.9.6-150400.1.5
  • libssh4 >= 0.9.6-150400.1.5
Patchnames:
SUSE Linux Enterprise Micro 5.4 GA libssh-config-0.9.6-150400.1.5
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libssh-config >= 0.9.8-3.12.2
  • libssh-devel >= 0.9.8-3.12.2
  • libssh4 >= 0.9.8-3.12.2
  • libssh4-32bit >= 0.9.8-3.12.2
Patchnames:
SUSE-SLE-SDK-12-SP5-2024-539
SUSE-SLE-SERVER-12-SP5-2024-539
SUSE Linux Enterprise Server 15 SP2-LTSS
  • libssh-config >= 0.9.8-150200.13.3.1
  • libssh-devel >= 0.9.8-150200.13.3.1
  • libssh4 >= 0.9.8-150200.13.3.1
  • libssh4-32bit >= 0.9.8-150200.13.3.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP2-LTSS-2024-525
SUSE Linux Enterprise Server 15 SP3-LTSS
  • libssh-config >= 0.9.8-150200.13.3.1
  • libssh-devel >= 0.9.8-150200.13.3.1
  • libssh4 >= 0.9.8-150200.13.3.1
  • libssh4-32bit >= 0.9.8-150200.13.3.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP3-LTSS-2024-525
SUSE Linux Enterprise Server for SAP Applications 15 SP2
  • libssh-config >= 0.9.8-150200.13.3.1
  • libssh-devel >= 0.9.8-150200.13.3.1
  • libssh4 >= 0.9.8-150200.13.3.1
  • libssh4-32bit >= 0.9.8-150200.13.3.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP2-2024-525
SUSE Linux Enterprise Server for SAP Applications 15 SP3
  • libssh-config >= 0.9.8-150200.13.3.1
  • libssh-devel >= 0.9.8-150200.13.3.1
  • libssh4 >= 0.9.8-150200.13.3.1
  • libssh4-32bit >= 0.9.8-150200.13.3.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP3-2024-525
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libssh-devel >= 0.9.8-3.12.2
  • libssh4 >= 0.9.8-3.12.2
Patchnames:
SUSE-SLE-SDK-12-SP5-2024-539
openSUSE Leap 15.4
  • libssh-config >= 0.9.6-150400.1.5
  • libssh4 >= 0.9.6-150400.1.5
  • libssh4-32bit >= 0.9.6-150400.1.5
Patchnames:
openSUSE Leap 15.4 GA libssh-config-0.9.6-150400.1.5
openSUSE Tumbleweed
  • libssh-config >= 0.9.6-1.2
  • libssh-devel >= 0.9.6-1.2
  • libssh4 >= 0.9.6-1.2
  • libssh4-32bit >= 0.9.6-1.2
Patchnames:
openSUSE Tumbleweed GA libssh-config-0.9.6-1.2


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 libssh Released
SUSE Linux Enterprise Desktop 15 SP5 libssh Already fixed
SUSE Linux Enterprise High Performance Computing 12 SP5 libssh Released
SUSE Linux Enterprise High Performance Computing 15 SP5 libssh Already fixed
SUSE Linux Enterprise Micro 5.1 libssh Released
SUSE Linux Enterprise Micro 5.2 libssh Released
SUSE Linux Enterprise Micro 5.3 libssh Already fixed
SUSE Linux Enterprise Micro 5.4 libssh Already fixed
SUSE Linux Enterprise Micro 5.5 libssh Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP5 libssh Already fixed
SUSE Linux Enterprise Real Time 15 SP3 libssh Affected
SUSE Linux Enterprise Server 12 SP5 libssh Released
SUSE Linux Enterprise Server 15 SP5 libssh Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libssh Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 libssh Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP5 libssh Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP5 libssh Released
SUSE Manager Proxy 4.3 libssh Already fixed
SUSE Manager Retail Branch Server 4.3 libssh Already fixed
SUSE Manager Server 4.3 libssh Already fixed
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 libssh Already fixed
SUSE Linux Enterprise High Performance Computing 15 libssh Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 libssh Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS libssh Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS libssh Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 libssh Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS libssh Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS libssh Released
SUSE Linux Enterprise High Performance Computing 15 SP3 libssh Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS libssh Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS libssh Released
SUSE Linux Enterprise High Performance Computing 15 SP4 libssh Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS libssh Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS libssh Already fixed
SUSE Linux Enterprise High Performance Computing 15-ESPOS libssh Affected
SUSE Linux Enterprise High Performance Computing 15-LTSS libssh Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP2 libssh Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP3 libssh Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP4 libssh Already fixed
SUSE Linux Enterprise Server 15 SP2 libssh Unsupported
SUSE Linux Enterprise Server 15 SP2-LTSS libssh Released
SUSE Linux Enterprise Server 15 SP3 libssh Unsupported
SUSE Linux Enterprise Server 15 SP3-LTSS libssh Released
SUSE Linux Enterprise Server 15 SP4 libssh Already fixed
SUSE Linux Enterprise Server 15 SP4-LTSS libssh Already fixed
SUSE Linux Enterprise Server 15-ESPOS libssh Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 libssh Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 libssh Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 libssh Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 libssh Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP2 libssh Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 libssh Released
Products past their end of life and not receiving proactive updates anymore.
SUSE CaaS Platform 4.0 libssh Affected
SUSE CaaS Platform 4.5 libssh Unsupported
SUSE Enterprise Storage 6 libssh Unsupported
SUSE Enterprise Storage 7 libssh Affected
SUSE Linux Enterprise Desktop 12 libssh Affected
SUSE Linux Enterprise Desktop 12 SP1 libssh Affected
SUSE Linux Enterprise Desktop 12 SP2 libssh Affected
SUSE Linux Enterprise Desktop 12 SP3 libssh Affected
SUSE Linux Enterprise Desktop 12 SP4 libssh Affected
SUSE Linux Enterprise Desktop 15 libssh Affected
SUSE Linux Enterprise Desktop 15 SP1 libssh Unsupported
SUSE Linux Enterprise Desktop 15 SP2 libssh Unsupported
SUSE Linux Enterprise Desktop 15 SP3 libssh Unsupported
SUSE Linux Enterprise High Performance Computing 12 SP4 libssh Affected
SUSE Linux Enterprise Micro 5.0 libssh Unsupported
SUSE Linux Enterprise Module for Basesystem 15 libssh Affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 libssh Unsupported
SUSE Linux Enterprise Real Time 15 SP2 libssh Unsupported
SUSE Linux Enterprise Real Time 15 SP4 libssh Already fixed
SUSE Linux Enterprise Server 12 libssh Affected
SUSE Linux Enterprise Server 12 SP1 libssh Affected
SUSE Linux Enterprise Server 12 SP2 libssh Affected
SUSE Linux Enterprise Server 12 SP3 libssh Affected
SUSE Linux Enterprise Server 12 SP4 libssh Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS libssh Affected
SUSE Linux Enterprise Server 12 SP4-LTSS libssh Affected
SUSE Linux Enterprise Server 15 libssh Affected
SUSE Linux Enterprise Server 15 SP1 libssh Unsupported
SUSE Linux Enterprise Server 15 SP1-BCL libssh Affected
SUSE Linux Enterprise Server 15 SP1-LTSS libssh Affected
SUSE Linux Enterprise Server 15 SP2-BCL libssh Affected
SUSE Linux Enterprise Server 15 SP3-BCL libssh Affected
SUSE Linux Enterprise Server 15-LTSS libssh Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 libssh Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 libssh Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libssh Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libssh Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libssh Affected
SUSE Linux Enterprise Software Development Kit 12 libssh Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 libssh Affected
SUSE Linux Enterprise Software Development Kit 12 SP2 libssh Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 libssh Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 libssh Affected
SUSE Linux Enterprise Workstation Extension 12 libssh Affected
SUSE Linux Enterprise Workstation Extension 12 SP1 libssh Affected
SUSE Linux Enterprise Workstation Extension 12 SP2 libssh Affected
SUSE Linux Enterprise Workstation Extension 12 SP3 libssh Affected
SUSE Manager Proxy 4.0 libssh Unsupported
SUSE Manager Proxy 4.1 libssh Unsupported
SUSE Manager Proxy 4.2 libssh Unsupported
SUSE Manager Retail Branch Server 4.0 libssh Unsupported
SUSE Manager Retail Branch Server 4.1 libssh Unsupported
SUSE Manager Retail Branch Server 4.2 libssh Unsupported
SUSE Manager Server 4.0 libssh Unsupported
SUSE Manager Server 4.1 libssh Unsupported
SUSE Manager Server 4.2 libssh Unsupported
SUSE OpenStack Cloud 9 libssh Affected
SUSE OpenStack Cloud Crowbar 9 libssh Affected


SUSE Timeline for this CVE

CVE page created: Thu Jul 30 06:07:39 2020
CVE page last modified: Fri Mar 1 11:38:01 2024