Upstream information

CVE-2020-13943 at MITRE

Description

If an HTTP/2 client connecting to Apache Tomcat 10.0.0-M1 to 10.0.0-M7, 9.0.0.M1 to 9.0.37 or 8.5.0 to 8.5.57 exceeded the agreed maximum number of concurrent streams for a connection (in violation of the HTTP/2 protocol), it was possible that a subsequent request made on that connection could contain HTTP headers - including HTTP/2 pseudo headers - from a previous request rather than the intended headers. This could lead to users seeing responses for unexpected resources.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4
Vector AV:N/AC:L/Au:S/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 4.3 5.3
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Access Vector Network Network
Access Complexity Low Low
Privileges Required Low None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact Low Low
Integrity Impact None None
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1177582 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • tomcat >= 9.0.36-3.74.1
  • tomcat-admin-webapps >= 9.0.36-3.74.1
  • tomcat-el-3_0-api >= 9.0.36-3.74.1
  • tomcat-jsp-2_3-api >= 9.0.36-3.74.1
  • tomcat-lib >= 9.0.36-3.74.1
  • tomcat-servlet-4_0-api >= 9.0.36-3.74.1
  • tomcat-webapps >= 9.0.36-3.74.1
Patchnames:
SUSE-SLE-Product-HPC-15-2021-40
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • tomcat-docs-webapp >= 9.0.36-4.47.3
  • tomcat-embed >= 9.0.36-4.47.3
  • tomcat-javadoc >= 9.0.36-4.47.3
  • tomcat-jsvc >= 9.0.36-4.47.3
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-3069
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • tomcat-docs-webapp >= 9.0.36-3.12.3
  • tomcat-embed >= 9.0.36-3.12.3
  • tomcat-javadoc >= 9.0.36-3.12.3
  • tomcat-jsvc >= 9.0.36-3.12.3
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2020-3068
SUSE Linux Enterprise Module for Web Scripting 15 SP1
  • tomcat >= 9.0.36-4.47.3
  • tomcat-admin-webapps >= 9.0.36-4.47.3
  • tomcat-el-3_0-api >= 9.0.36-4.47.3
  • tomcat-jsp-2_3-api >= 9.0.36-4.47.3
  • tomcat-lib >= 9.0.36-4.47.3
  • tomcat-servlet-4_0-api >= 9.0.36-4.47.3
  • tomcat-webapps >= 9.0.36-4.47.3
Patchnames:
SUSE-SLE-Module-Web-Scripting-15-SP1-2020-3069
SUSE Linux Enterprise Module for Web Scripting 15 SP2
  • tomcat >= 9.0.36-3.12.3
  • tomcat-admin-webapps >= 9.0.36-3.12.3
  • tomcat-el-3_0-api >= 9.0.36-3.12.3
  • tomcat-jsp-2_3-api >= 9.0.36-3.12.3
  • tomcat-lib >= 9.0.36-3.12.3
  • tomcat-servlet-4_0-api >= 9.0.36-3.12.3
  • tomcat-webapps >= 9.0.36-3.12.3
Patchnames:
SUSE-SLE-Module-Web-Scripting-15-SP2-2020-3068
SUSE Linux Enterprise Module for Web Scripting 15 SP3
  • tomcat >= 9.0.36-3.24.1
  • tomcat-admin-webapps >= 9.0.36-3.24.1
  • tomcat-el-3_0-api >= 9.0.36-3.24.1
  • tomcat-jsp-2_3-api >= 9.0.36-3.24.1
  • tomcat-lib >= 9.0.36-3.24.1
  • tomcat-servlet-4_0-api >= 9.0.36-3.24.1
  • tomcat-webapps >= 9.0.36-3.24.1
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • tomcat >= 9.0.36-3.50.1
  • tomcat-admin-webapps >= 9.0.36-3.50.1
  • tomcat-docs-webapp >= 9.0.36-3.50.1
  • tomcat-el-3_0-api >= 9.0.36-3.50.1
  • tomcat-javadoc >= 9.0.36-3.50.1
  • tomcat-jsp-2_3-api >= 9.0.36-3.50.1
  • tomcat-lib >= 9.0.36-3.50.1
  • tomcat-servlet-4_0-api >= 9.0.36-3.50.1
  • tomcat-webapps >= 9.0.36-3.50.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2020-2996
SUSE Linux Enterprise Server 15-LTSS
  • tomcat >= 9.0.36-3.74.1
  • tomcat-admin-webapps >= 9.0.36-3.74.1
  • tomcat-el-3_0-api >= 9.0.36-3.74.1
  • tomcat-jsp-2_3-api >= 9.0.36-3.74.1
  • tomcat-lib >= 9.0.36-3.74.1
  • tomcat-servlet-4_0-api >= 9.0.36-3.74.1
  • tomcat-webapps >= 9.0.36-3.74.1
Patchnames:
SUSE-SLE-Product-SLES-15-2021-40
SUSE Linux Enterprise Server for SAP Applications 15
  • tomcat >= 9.0.36-3.74.1
  • tomcat-admin-webapps >= 9.0.36-3.74.1
  • tomcat-el-3_0-api >= 9.0.36-3.74.1
  • tomcat-jsp-2_3-api >= 9.0.36-3.74.1
  • tomcat-lib >= 9.0.36-3.74.1
  • tomcat-servlet-4_0-api >= 9.0.36-3.74.1
  • tomcat-webapps >= 9.0.36-3.74.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2021-40
openSUSE Leap 15.1
  • tomcat >= 9.0.36-lp151.3.33.1
  • tomcat-admin-webapps >= 9.0.36-lp151.3.33.1
  • tomcat-docs-webapp >= 9.0.36-lp151.3.33.1
  • tomcat-el-3_0-api >= 9.0.36-lp151.3.33.1
  • tomcat-embed >= 9.0.36-lp151.3.33.1
  • tomcat-javadoc >= 9.0.36-lp151.3.33.1
  • tomcat-jsp-2_3-api >= 9.0.36-lp151.3.33.1
  • tomcat-jsvc >= 9.0.36-lp151.3.33.1
  • tomcat-lib >= 9.0.36-lp151.3.33.1
  • tomcat-servlet-4_0-api >= 9.0.36-lp151.3.33.1
  • tomcat-webapps >= 9.0.36-lp151.3.33.1
Patchnames:
openSUSE-2020-1842
openSUSE Leap 15.2
  • tomcat >= 9.0.36-lp152.2.10.1
  • tomcat-admin-webapps >= 9.0.36-lp152.2.10.1
  • tomcat-docs-webapp >= 9.0.36-lp152.2.10.1
  • tomcat-el-3_0-api >= 9.0.36-lp152.2.10.1
  • tomcat-embed >= 9.0.36-lp152.2.10.1
  • tomcat-javadoc >= 9.0.36-lp152.2.10.1
  • tomcat-jsp-2_3-api >= 9.0.36-lp152.2.10.1
  • tomcat-jsvc >= 9.0.36-lp152.2.10.1
  • tomcat-lib >= 9.0.36-lp152.2.10.1
  • tomcat-servlet-4_0-api >= 9.0.36-lp152.2.10.1
  • tomcat-webapps >= 9.0.36-lp152.2.10.1
Patchnames:
openSUSE-2020-1799
openSUSE Tumbleweed
  • tomcat >= 9.0.36-8.4
  • tomcat-admin-webapps >= 9.0.36-8.4
  • tomcat-docs-webapp >= 9.0.36-8.4
  • tomcat-el-3_0-api >= 9.0.36-8.4
  • tomcat-embed >= 9.0.36-8.4
  • tomcat-javadoc >= 9.0.36-8.4
  • tomcat-jsp-2_3-api >= 9.0.36-8.4
  • tomcat-jsvc >= 9.0.36-8.4
  • tomcat-lib >= 9.0.36-8.4
  • tomcat-servlet-4_0-api >= 9.0.36-8.4
  • tomcat-webapps >= 9.0.36-8.4
Patchnames:
openSUSE Tumbleweed GA tomcat-9.0.36-8.4


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 tomcat Not affected
SUSE CaaS Platform 4.0 tomcat In progress
SUSE Enterprise Storage 5 tomcat Not affected
SUSE Enterprise Storage 6 tomcat In progress
SUSE Linux Enterprise High Performance Computing 12 SP5 tomcat Released
SUSE Linux Enterprise High Performance Computing 15 LTSS tomcat Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS tomcat In progress
SUSE Linux Enterprise Module for Web and Scripting 15 SP1 tomcat Released
SUSE Linux Enterprise Module for Web and Scripting 15 SP2 tomcat Released
SUSE Linux Enterprise Point of Service 11 SP3 tomcat6 Not affected
SUSE Linux Enterprise Point of Service Image Server 12 SP2 tomcat Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS tomcat6 Not affected
SUSE Linux Enterprise Server 12 SP2 ESPOS tomcat Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS tomcat Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS tomcat Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS tomcat Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS tomcat In progress
SUSE Linux Enterprise Server 12 SP4 LTSS tomcat In progress
SUSE Linux Enterprise Server 12 SP5 tomcat Released
SUSE Linux Enterprise Server 15 ESPOS tomcat Released
SUSE Linux Enterprise Server 15 LTSS tomcat Released
SUSE Linux Enterprise Server 15 SP1 LTSS tomcat In progress
SUSE Linux Enterprise Server BCL 12 SP2 tomcat Not affected
SUSE Linux Enterprise Server BCL 12 SP3 tomcat Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 tomcat In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP2 tomcat Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 tomcat Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 tomcat In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP5 tomcat Released
SUSE Linux Enterprise Server for SAP Applications 15 tomcat Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 tomcat In progress
SUSE Manager Proxy 4.0 tomcat In progress
SUSE Manager Retail Branch Server 4.0 tomcat In progress
SUSE Manager Server 4.0 tomcat In progress
SUSE OpenStack Cloud 7 tomcat Not affected
SUSE OpenStack Cloud 8 tomcat Not affected
SUSE OpenStack Cloud 9 tomcat In progress
SUSE OpenStack Cloud Crowbar 8 tomcat Not affected
SUSE OpenStack Cloud Crowbar 9 tomcat In progress