Upstream information

CVE-2020-12658 at MITRE

Description

** DISPUTED ** gssproxy (aka gss-proxy) before 0.8.3 does not unlock cond_mutex before pthread exit in gp_worker_main() in gp_workers.c. NOTE: An upstream comment states "We are already on a shutdown path when running the code in question, so a DoS there doesn't make any sense, and there has been no additional information provided us (as upstream) to indicate why this would be a problem."

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 5.3
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High None
Integrity Impact High None
Availability Impact High Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1180515 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • gssproxy >= 0.8.2-3.6.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2021-1029
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • gssproxy >= 0.8.2-4.5.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2021-1030
openSUSE Leap 15.2
  • gssproxy >= 0.8.2-lp152.2.3.1
  • gssproxy-debuginfo >= 0.8.2-lp152.2.3.1
  • gssproxy-debugsource >= 0.8.2-lp152.2.3.1
Patchnames:
openSUSE-2021-531


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 gssproxy Released
SUSE Enterprise Storage 6 gssproxy Released
SUSE Linux Enterprise High Performance Computing 12 SP5 gssproxy Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS gssproxy Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 gssproxy Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP2 gssproxy Released
SUSE Linux Enterprise Server 12 SP5 gssproxy Released
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux gssproxy Released
SUSE Linux Enterprise Server 15 SP1 LTSS gssproxy Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 gssproxy Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 gssproxy Released
SUSE Manager Proxy 4.0 gssproxy Released
SUSE Manager Retail Branch Server 4.0 gssproxy Released
SUSE Manager Server 4.0 gssproxy Released