Upstream information

CVE-2020-11741 at MITRE

Description

An issue was discovered in xenoprof in Xen through 4.13.x, allowing guest OS users (with active profiling) to obtain sensitive information about other guests, cause a denial of service, or possibly gain privileges. For guests for which "active" profiling was enabled by the administrator, the xenoprof code uses the standard Xen shared ring structure. Unfortunately, this code did not treat the guest as a potential adversary: it trusts the guest not to modify buffer size information or modify head / tail pointers in unexpected ways. This can crash the host (DoS). Privilege escalation cannot be ruled out.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.9
Vector AV:L/AC:M/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.8
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Changed
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1168140 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • xen >= 4.9.4_06-3.62.1
  • xen-doc-html >= 4.9.4_06-3.62.1
  • xen-libs >= 4.9.4_06-3.62.1
  • xen-libs-32bit >= 4.9.4_06-3.62.1
  • xen-tools >= 4.9.4_06-3.62.1
  • xen-tools-domU >= 4.9.4_06-3.62.1
Patchnames:
HPE-Helion-OpenStack-8-2020-1630
Image SLES15-EC2-CHOST-HVM-BYOS
  • xen-libs >= 4.10.4_10-3.31.1
  • xen-tools-domU >= 4.10.4_10-3.31.1
Image SLES15-SP1-CHOST-BYOS-EC2
  • xen-libs >= 4.12.2_04-3.15.1
  • xen-tools-domU >= 4.12.2_04-3.15.1
SUSE Enterprise Storage 5
  • xen >= 4.9.4_06-3.62.1
  • xen-doc-html >= 4.9.4_06-3.62.1
  • xen-libs >= 4.9.4_06-3.62.1
  • xen-libs-32bit >= 4.9.4_06-3.62.1
  • xen-tools >= 4.9.4_06-3.62.1
  • xen-tools-domU >= 4.9.4_06-3.62.1
Patchnames:
SUSE-Storage-5-2020-1630
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • xen >= 4.10.4_10-3.31.1
  • xen-devel >= 4.10.4_10-3.31.1
  • xen-libs >= 4.10.4_10-3.31.1
  • xen-tools >= 4.10.4_10-3.31.1
  • xen-tools-domU >= 4.10.4_10-3.31.1
Patchnames:
SUSE-SLE-Product-HPC-15-2020-1634
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • xen >= 4.12.2_04-3.15.1
  • xen-libs >= 4.12.2_04-3.15.1
  • xen-tools-domU >= 4.12.2_04-3.15.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2020-1124
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • xen >= 4.12.2_04-3.15.1
  • xen-devel >= 4.12.2_04-3.15.1
  • xen-doc-html >= 4.12.2_04-3.15.1
  • xen-libs >= 4.12.2_04-3.15.1
  • xen-libs-32bit >= 4.12.2_04-3.15.1
  • xen-tools >= 4.12.2_04-3.15.1
  • xen-tools-domU >= 4.12.2_04-3.15.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-1124
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • xen >= 4.12.2_04-3.15.1
  • xen-devel >= 4.12.2_04-3.15.1
  • xen-tools >= 4.12.2_04-3.15.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP1-2020-1124
SUSE Linux Enterprise Point of Sale 11 SP3
  • xen >= 4.2.5_22-45.36.1
  • xen-kmp-default >= 4.2.5_22_3.0.101_0.47.106.59-45.36.1
  • xen-kmp-pae >= 4.2.5_22_3.0.101_0.47.106.59-45.36.1
  • xen-libs >= 4.2.5_22-45.36.1
  • xen-tools-domU >= 4.2.5_22-45.36.1
Patchnames:
sleposp3-xen-14448
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • xen >= 4.7.6_08-43.64.1
  • xen-doc-html >= 4.7.6_08-43.64.1
  • xen-libs >= 4.7.6_08-43.64.1
  • xen-libs-32bit >= 4.7.6_08-43.64.1
  • xen-tools >= 4.7.6_08-43.64.1
  • xen-tools-domU >= 4.7.6_08-43.64.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2020-2234
SUSE Linux Enterprise Server 11 SP4-LTSS
SUSE Linux Enterprise Server for SAP Applications 11 SP4-LTSS
  • xen >= 4.4.4_42-61.52.1
  • xen-doc-html >= 4.4.4_42-61.52.1
  • xen-kmp-default >= 4.4.4_42_3.0.101_108.114-61.52.1
  • xen-kmp-pae >= 4.4.4_42_3.0.101_108.114-61.52.1
  • xen-libs >= 4.4.4_42-61.52.1
  • xen-libs-32bit >= 4.4.4_42-61.52.1
  • xen-tools >= 4.4.4_42-61.52.1
  • xen-tools-domU >= 4.4.4_42-61.52.1
Patchnames:
slessp4-xen-14444
SUSE Linux Enterprise Server 12 SP2-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • xen >= 4.7.6_08-43.64.1
  • xen-doc-html >= 4.7.6_08-43.64.1
  • xen-libs >= 4.7.6_08-43.64.1
  • xen-libs-32bit >= 4.7.6_08-43.64.1
  • xen-tools >= 4.7.6_08-43.64.1
  • xen-tools-domU >= 4.7.6_08-43.64.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2020-2234
SUSE Linux Enterprise Server 12 SP2-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • xen >= 4.7.6_08-43.64.1
  • xen-doc-html >= 4.7.6_08-43.64.1
  • xen-libs >= 4.7.6_08-43.64.1
  • xen-libs-32bit >= 4.7.6_08-43.64.1
  • xen-tools >= 4.7.6_08-43.64.1
  • xen-tools-domU >= 4.7.6_08-43.64.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2020-2234
SUSE Linux Enterprise Server 12 SP2-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • xen >= 4.7.6_08-43.64.1
  • xen-doc-html >= 4.7.6_08-43.64.1
  • xen-libs >= 4.7.6_08-43.64.1
  • xen-libs-32bit >= 4.7.6_08-43.64.1
  • xen-tools >= 4.7.6_08-43.64.1
  • xen-tools-domU >= 4.7.6_08-43.64.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2020-2234
SUSE Linux Enterprise Server 12 SP3-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • xen >= 4.9.4_06-3.62.1
  • xen-doc-html >= 4.9.4_06-3.62.1
  • xen-libs >= 4.9.4_06-3.62.1
  • xen-libs-32bit >= 4.9.4_06-3.62.1
  • xen-tools >= 4.9.4_06-3.62.1
  • xen-tools-domU >= 4.9.4_06-3.62.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2020-1630
SUSE Linux Enterprise Server 12 SP3-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • xen >= 4.9.4_06-3.62.1
  • xen-doc-html >= 4.9.4_06-3.62.1
  • xen-libs >= 4.9.4_06-3.62.1
  • xen-libs-32bit >= 4.9.4_06-3.62.1
  • xen-tools >= 4.9.4_06-3.62.1
  • xen-tools-domU >= 4.9.4_06-3.62.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2020-1630
SUSE Linux Enterprise Server 12 SP3-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • xen >= 4.9.4_06-3.62.1
  • xen-doc-html >= 4.9.4_06-3.62.1
  • xen-libs >= 4.9.4_06-3.62.1
  • xen-libs-32bit >= 4.9.4_06-3.62.1
  • xen-tools >= 4.9.4_06-3.62.1
  • xen-tools-domU >= 4.9.4_06-3.62.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2020-1630
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • xen >= 4.11.3_04-2.23.1
  • xen-doc-html >= 4.11.3_04-2.23.1
  • xen-libs >= 4.11.3_04-2.23.1
  • xen-libs-32bit >= 4.11.3_04-2.23.1
  • xen-tools >= 4.11.3_04-2.23.1
  • xen-tools-domU >= 4.11.3_04-2.23.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2020-1138
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • xen >= 4.12.2_04-3.11.1
  • xen-doc-html >= 4.12.2_04-3.11.1
  • xen-libs >= 4.12.2_04-3.11.1
  • xen-libs-32bit >= 4.12.2_04-3.11.1
  • xen-tools >= 4.12.2_04-3.11.1
  • xen-tools-domU >= 4.12.2_04-3.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2020-1139
SUSE Linux Enterprise Server 15-LTSS
  • xen >= 4.10.4_10-3.31.1
  • xen-devel >= 4.10.4_10-3.31.1
  • xen-libs >= 4.10.4_10-3.31.1
  • xen-tools >= 4.10.4_10-3.31.1
  • xen-tools-domU >= 4.10.4_10-3.31.1
Patchnames:
SUSE-SLE-Product-SLES-15-2020-1634
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • xen >= 4.7.6_08-43.64.1
  • xen-doc-html >= 4.7.6_08-43.64.1
  • xen-libs >= 4.7.6_08-43.64.1
  • xen-libs-32bit >= 4.7.6_08-43.64.1
  • xen-tools >= 4.7.6_08-43.64.1
  • xen-tools-domU >= 4.7.6_08-43.64.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2020-2234
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • xen >= 4.9.4_06-3.62.1
  • xen-doc-html >= 4.9.4_06-3.62.1
  • xen-libs >= 4.9.4_06-3.62.1
  • xen-libs-32bit >= 4.9.4_06-3.62.1
  • xen-tools >= 4.9.4_06-3.62.1
  • xen-tools-domU >= 4.9.4_06-3.62.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2020-1630
SUSE Linux Enterprise Server for SAP Applications 15
  • xen >= 4.10.4_10-3.31.1
  • xen-devel >= 4.10.4_10-3.31.1
  • xen-libs >= 4.10.4_10-3.31.1
  • xen-tools >= 4.10.4_10-3.31.1
  • xen-tools-domU >= 4.10.4_10-3.31.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2020-1634
SUSE Linux Enterprise Software Development Kit 12 SP4
  • xen >= 4.11.3_04-2.23.1
  • xen-devel >= 4.11.3_04-2.23.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2020-1138
SUSE Linux Enterprise Software Development Kit 12 SP5
  • xen >= 4.12.2_04-3.11.1
  • xen-devel >= 4.12.2_04-3.11.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2020-1139
SUSE OpenStack Cloud 7
  • xen >= 4.7.6_08-43.64.1
  • xen-doc-html >= 4.7.6_08-43.64.1
  • xen-libs >= 4.7.6_08-43.64.1
  • xen-libs-32bit >= 4.7.6_08-43.64.1
  • xen-tools >= 4.7.6_08-43.64.1
  • xen-tools-domU >= 4.7.6_08-43.64.1
Patchnames:
SUSE-OpenStack-Cloud-7-2020-2234
SUSE OpenStack Cloud 8
  • xen >= 4.9.4_06-3.62.1
  • xen-doc-html >= 4.9.4_06-3.62.1
  • xen-libs >= 4.9.4_06-3.62.1
  • xen-libs-32bit >= 4.9.4_06-3.62.1
  • xen-tools >= 4.9.4_06-3.62.1
  • xen-tools-domU >= 4.9.4_06-3.62.1
Patchnames:
SUSE-OpenStack-Cloud-8-2020-1630
SUSE OpenStack Cloud Crowbar 8
  • xen >= 4.9.4_06-3.62.1
  • xen-doc-html >= 4.9.4_06-3.62.1
  • xen-libs >= 4.9.4_06-3.62.1
  • xen-libs-32bit >= 4.9.4_06-3.62.1
  • xen-tools >= 4.9.4_06-3.62.1
  • xen-tools-domU >= 4.9.4_06-3.62.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2020-1630
openSUSE Leap 15.1
  • xen >= 4.12.2_04-lp151.2.15.1
  • xen-debugsource >= 4.12.2_04-lp151.2.15.1
  • xen-devel >= 4.12.2_04-lp151.2.15.1
  • xen-doc-html >= 4.12.2_04-lp151.2.15.1
  • xen-libs >= 4.12.2_04-lp151.2.15.1
  • xen-libs-32bit >= 4.12.2_04-lp151.2.15.1
  • xen-libs-32bit-debuginfo >= 4.12.2_04-lp151.2.15.1
  • xen-libs-debuginfo >= 4.12.2_04-lp151.2.15.1
  • xen-tools >= 4.12.2_04-lp151.2.15.1
  • xen-tools-debuginfo >= 4.12.2_04-lp151.2.15.1
  • xen-tools-domU >= 4.12.2_04-lp151.2.15.1
  • xen-tools-domU-debuginfo >= 4.12.2_04-lp151.2.15.1
Patchnames:
openSUSE-2020-599


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 3.0 xen Affected
SUSE Container as a Service Platform 1.0 xen Affected
SUSE Container as a Service Platform 2.0 xen Affected
SUSE Linux Enterprise 15-SP1 Module for Basesystem xen Released
SUSE Linux Enterprise 15-SP1 Module for Server Applications xen Released
SUSE Linux Enterprise High Performance Computing 12 SP4 xen Released
SUSE Linux Enterprise High Performance Computing 12 SP5 xen Released
SUSE Linux Enterprise High Performance Computing 15 LTSS xen Released
SUSE Linux Enterprise Server 11 SP1 xen Affected
SUSE Linux Enterprise Server 11 SP3 xen Released
SUSE Linux Enterprise Server 11 SP4 LTSS xen Released
SUSE Linux Enterprise Server 12 SP1 LTSS xen Affected
SUSE Linux Enterprise Server 12 SP2 BCL xen Released
SUSE Linux Enterprise Server 12 SP2 LTSS xen Released
SUSE Linux Enterprise Server 12 SP3 BCL xen Released
SUSE Linux Enterprise Server 12 SP3 LTSS xen Released
SUSE Linux Enterprise Server 12 SP4 xen Released
SUSE Linux Enterprise Server 12 SP5 xen Released
SUSE Linux Enterprise Server ESPOS 15 xen Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 xen Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 xen Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 xen Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 xen Released
SUSE Linux Enterprise Software Development Kit 12 SP4 xen Released
SUSE Linux Enterprise Software Development Kit 12 SP5 xen Released