Upstream information

CVE-2020-10759 at MITRE

Description

A PGP signature bypass flaw was found in fwupd (all versions), which could lead to the installation of unsigned firmware. As per upstream, a signature bypass is theoretically possible, but not practical because the Linux Vendor Firmware Service (LVFS) is either not implemented or enabled in versions of fwupd shipped with Red Hat Enterprise Linux 7 and 8. The highest threat from this vulnerability is to confidentiality and integrity.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 3.3
Vector AV:L/AC:M/Au:N/C:P/I:P/A:N
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6 7.4
Vector CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Access Vector Local Network
Access Complexity Low High
Privileges Required High None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1172643 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • fwupd >= 1.0.9-6.3.1
  • fwupd-devel >= 1.0.9-6.3.1
  • fwupd-lang >= 1.0.9-6.3.1
  • libfwupd2 >= 1.0.9-6.3.1
  • typelib-1_0-Fwupd-2_0 >= 1.0.9-6.3.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP1-2020-1681
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
  • fwupd >= 1.2.14-5.8.2
  • fwupd-devel >= 1.2.14-5.8.2
  • fwupd-lang >= 1.2.14-5.8.2
  • libfwupd2 >= 1.2.14-5.8.2
  • typelib-1_0-Fwupd-2_0 >= 1.2.14-5.8.2
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP2-2021-1107
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
  • fwupd >= 1.5.8-1.13
  • fwupd-devel >= 1.5.8-1.13
  • fwupd-lang >= 1.5.8-1.13
  • fwupdtpmevlog >= 1.5.8-1.13
  • jcat-tool >= 0.1.3-1.38
  • libfwupd2 >= 1.5.8-1.13
  • libfwupdplugin1 >= 1.5.8-1.13
  • libjcat-devel >= 0.1.3-1.38
  • libjcat1 >= 0.1.3-1.38
  • typelib-1_0-Fwupd-2_0 >= 1.5.8-1.13
  • typelib-1_0-FwupdPlugin-1_0 >= 1.5.8-1.13
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • dfu-tool >= 1.0.9-6.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-1681
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • dfu-tool >= 1.2.14-5.8.2
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2021-1107
openSUSE Leap 15.1
  • dfu-tool >= 1.0.9-lp151.2.3.1
  • dfu-tool-debuginfo >= 1.0.9-lp151.2.3.1
  • fwupd >= 1.0.9-lp151.2.3.1
  • fwupd-debuginfo >= 1.0.9-lp151.2.3.1
  • fwupd-debugsource >= 1.0.9-lp151.2.3.1
  • fwupd-devel >= 1.0.9-lp151.2.3.1
  • fwupd-lang >= 1.0.9-lp151.2.3.1
  • libfwupd2 >= 1.0.9-lp151.2.3.1
  • libfwupd2-debuginfo >= 1.0.9-lp151.2.3.1
  • typelib-1_0-Fwupd-2_0 >= 1.0.9-lp151.2.3.1
Patchnames:
openSUSE-2020-849
openSUSE Leap 15.2
  • dfu-tool >= 1.2.14-lp152.3.9.1
  • dfu-tool-debuginfo >= 1.2.14-lp152.3.9.1
  • fwupd >= 1.2.14-lp152.3.9.1
  • fwupd-debuginfo >= 1.2.14-lp152.3.9.1
  • fwupd-debugsource >= 1.2.14-lp152.3.9.1
  • fwupd-devel >= 1.2.14-lp152.3.9.1
  • fwupd-lang >= 1.2.14-lp152.3.9.1
  • libfwupd2 >= 1.2.14-lp152.3.9.1
  • libfwupd2-debuginfo >= 1.2.14-lp152.3.9.1
  • typelib-1_0-Fwupd-2_0 >= 1.2.14-lp152.3.9.1
Patchnames:
openSUSE-2021-522
openSUSE Tumbleweed
  • dfu-tool >= 1.5.8-1.5
  • fwupd >= 1.5.8-1.5
  • fwupd-devel >= 1.5.8-1.5
  • fwupd-lang >= 1.5.8-1.5
  • fwupdtpmevlog >= 1.5.8-1.5
  • jcat-tool >= 0.1.3-1.8
  • libfwupd2 >= 1.5.8-1.5
  • libfwupdplugin1 >= 1.5.8-1.5
  • libjcat-devel >= 0.1.3-1.8
  • libjcat1 >= 0.1.3-1.8
  • typelib-1_0-Fwupd-2_0 >= 1.5.8-1.5
  • typelib-1_0-FwupdPlugin-1_0 >= 1.5.8-1.5
  • typelib-1_0-Jcat-1_0 >= 0.1.3-1.8
Patchnames:
openSUSE Tumbleweed GA dfu-tool-1.5.8-1.5
openSUSE Tumbleweed GA jcat-tool-0.1.3-1.8


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 fwupd Released
SUSE Enterprise Storage 6 fwupd Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS fwupd Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 fwupd Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 fwupd Released
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux fwupd Released
SUSE Linux Enterprise Server 15 SP1 LTSS fwupd Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 fwupd Released
SUSE Manager Proxy 4.0 fwupd Released
SUSE Manager Retail Branch Server 4.0 fwupd Released
SUSE Manager Server 4.0 fwupd Released