Upstream information

CVE-2019-7664 at MITRE

Description

In elfutils 0.175, a negative-sized memcpy is attempted in elf_cvt_note in libelf/note_xlate.h because of an incorrect overflow check. Crafted elf input causes a segmentation fault, leading to denial of service (program crash).

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 3.3
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
Access Vector Local Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High Low
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1125008 [RESOLVED / INVALID]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container bci/bci-init:15.3.17.33
Container bci/bci-minimal:15.3.29.28
Container bci/nodejs:12-16.122
Container bci/python:3.9-18.43
Container ses/7.1/ceph/grafana:8.3.5.2.2.217
Container ses/7.1/ceph/haproxy:2.0.14.3.5.153
Container ses/7.1/ceph/keepalived:2.0.19.3.5.144
Container ses/7.1/ceph/prometheus-alertmanager:0.23.0.3.2.201
Container ses/7.1/ceph/prometheus-node-exporter:1.3.0.3.2.202
Container ses/7.1/ceph/prometheus-server:2.32.1.3.2.195
Container ses/7.1/ceph/prometheus-snmp_notifier:1.2.1.2.2.186
Container ses/7.1/cephcsi/cephcsi:3.5.1.0.3.2.345
Container ses/7.1/cephcsi/csi-attacher:v3.4.0-rev1-build2.2.201
Container ses/7.1/cephcsi/csi-node-driver-registrar:v2.5.0-rev1-build2.2.209
Container ses/7.1/cephcsi/csi-provisioner:v3.1.0-rev1-build2.2.206
Container ses/7.1/cephcsi/csi-resizer:v1.4.0-rev1-build2.2.203
Container ses/7.1/cephcsi/csi-snapshotter:v5.0.1-rev1-build2.2.200
Container ses/7.1/rook/ceph:1.8.10.0.4.5.106
Container suse/sle15:15.3.17.20.8
  • libdw1 >= 0.177-150300.11.3.1
  • libebl-plugins >= 0.177-150300.11.3.1
  • libelf1 >= 0.177-150300.11.3.1
Container suse/sle-micro-rancher/5.2:latest
Image SLES15-SP3-CHOST-BYOS-Aliyun
Image SLES15-SP3-CHOST-BYOS-Azure
Image SLES15-SP3-CHOST-BYOS-EC2
Image SLES15-SP3-CHOST-BYOS-GCE
  • elfutils >= 0.177-150300.11.3.1
  • libasm1 >= 0.177-150300.11.3.1
  • libdw1 >= 0.177-150300.11.3.1
  • libebl-plugins >= 0.177-150300.11.3.1
  • libelf1 >= 0.177-150300.11.3.1
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Basesystem 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Storage 7.1
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • dwarves >= 1.22-150300.7.3.1
  • elfutils >= 0.177-150300.11.3.1
  • elfutils-lang >= 0.177-150300.11.3.1
  • libasm-devel >= 0.177-150300.11.3.1
  • libasm1 >= 0.177-150300.11.3.1
  • libdw-devel >= 0.177-150300.11.3.1
  • libdw1 >= 0.177-150300.11.3.1
  • libdw1-32bit >= 0.177-150300.11.3.1
  • libdwarves-devel >= 1.22-150300.7.3.1
  • libdwarves-devel-32bit >= 1.22-150300.7.3.1
  • libdwarves1 >= 1.22-150300.7.3.1
  • libdwarves1-32bit >= 1.22-150300.7.3.1
  • libebl-devel >= 0.177-150300.11.3.1
  • libebl-plugins >= 0.177-150300.11.3.1
  • libebl-plugins-32bit >= 0.177-150300.11.3.1
  • libelf-devel >= 0.177-150300.11.3.1
  • libelf1 >= 0.177-150300.11.3.1
  • libelf1-32bit >= 0.177-150300.11.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2022-2614
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • elfutils >= 0.185-150400.3.35
  • elfutils-lang >= 0.185-150400.3.35
  • libasm-devel >= 0.185-150400.3.35
  • libasm1 >= 0.185-150400.3.35
  • libdw-devel >= 0.185-150400.3.35
  • libdw1 >= 0.185-150400.3.35
  • libdw1-32bit >= 0.185-150400.3.35
  • libelf-devel >= 0.185-150400.3.35
  • libelf1 >= 0.185-150400.3.35
  • libelf1-32bit >= 0.185-150400.3.35
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA elfutils-0.185-150400.3.35
SUSE Linux Enterprise Micro 5.1
  • dwarves >= 1.22-150300.7.3.1
  • elfutils >= 0.177-150300.11.3.1
  • libasm1 >= 0.177-150300.11.3.1
  • libdw1 >= 0.177-150300.11.3.1
  • libdwarves-devel >= 1.22-150300.7.3.1
  • libdwarves1 >= 1.22-150300.7.3.1
  • libebl-plugins >= 0.177-150300.11.3.1
  • libelf1 >= 0.177-150300.11.3.1
Patchnames:
SUSE-SUSE-MicroOS-5.1-2022-2614
SUSE Linux Enterprise Micro 5.2
  • dwarves >= 1.22-150300.7.3.1
  • elfutils >= 0.177-150300.11.3.1
  • libasm1 >= 0.177-150300.11.3.1
  • libdw1 >= 0.177-150300.11.3.1
  • libdwarves-devel >= 1.22-150300.7.3.1
  • libdwarves1 >= 1.22-150300.7.3.1
  • libebl-plugins >= 0.177-150300.11.3.1
  • libelf1 >= 0.177-150300.11.3.1
Patchnames:
SUSE-SUSE-MicroOS-5.2-2022-2614
openSUSE Leap 15.3
  • dwarves >= 1.22-150300.7.3.1
  • elfutils >= 0.177-150300.11.3.1
  • elfutils-lang >= 0.177-150300.11.3.1
  • libasm-devel >= 0.177-150300.11.3.1
  • libasm1 >= 0.177-150300.11.3.1
  • libasm1-32bit >= 0.177-150300.11.3.1
  • libdw-devel >= 0.177-150300.11.3.1
  • libdw1 >= 0.177-150300.11.3.1
  • libdw1-32bit >= 0.177-150300.11.3.1
  • libdwarves-devel >= 1.22-150300.7.3.1
  • libdwarves-devel-32bit >= 1.22-150300.7.3.1
  • libdwarves1 >= 1.22-150300.7.3.1
  • libdwarves1-32bit >= 1.22-150300.7.3.1
  • libebl-devel >= 0.177-150300.11.3.1
  • libebl-plugins >= 0.177-150300.11.3.1
  • libebl-plugins-32bit >= 0.177-150300.11.3.1
  • libelf-devel >= 0.177-150300.11.3.1
  • libelf-devel-32bit >= 0.177-150300.11.3.1
  • libelf1 >= 0.177-150300.11.3.1
  • libelf1-32bit >= 0.177-150300.11.3.1
Patchnames:
openSUSE-SLE-15.3-2022-2614
openSUSE Leap 15.4
  • elfutils >= 0.185-150400.3.35
  • elfutils-lang >= 0.185-150400.3.35
  • libasm1 >= 0.185-150400.3.35
  • libdw1 >= 0.185-150400.3.35
  • libdw1-32bit >= 0.185-150400.3.35
  • libelf1 >= 0.185-150400.3.35
  • libelf1-32bit >= 0.185-150400.3.35
Patchnames:
openSUSE Leap 15.4 GA elfutils-0.185-150400.3.35
openSUSE Leap Micro 5.2
  • dwarves >= 1.22-150300.7.3.1
  • elfutils >= 0.177-150300.11.3.1
  • libasm1 >= 0.177-150300.11.3.1
  • libdw1 >= 0.177-150300.11.3.1
  • libdwarves-devel >= 1.22-150300.7.3.1
  • libdwarves1 >= 1.22-150300.7.3.1
  • libebl-plugins >= 0.177-150300.11.3.1
  • libelf1 >= 0.177-150300.11.3.1
Patchnames:
openSUSE-Leap-Micro-5.2-2022-2614
openSUSE Tumbleweed
  • debuginfod-dummy-client >= 0.185-3.1
  • elfutils >= 0.185-3.1
  • elfutils-lang >= 0.185-3.1
  • libasm-devel >= 0.185-3.1
  • libasm1 >= 0.185-3.1
  • libasm1-32bit >= 0.185-3.1
  • libdebuginfod-dummy-devel >= 0.185-3.1
  • libdebuginfod1-dummy >= 0.185-3.1
  • libdw-devel >= 0.185-3.1
  • libdw1 >= 0.185-3.1
  • libdw1-32bit >= 0.185-3.1
  • libelf-devel >= 0.185-3.1
  • libelf-devel-32bit >= 0.185-3.1
  • libelf1 >= 0.185-3.1
  • libelf1-32bit >= 0.185-3.1
Patchnames:
openSUSE Tumbleweed GA debuginfod-dummy-client-0.185-3.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
Magnum Orchestration elfutils Not affected
SLES for SAP Applications elfutils Not affected
SLES15-EC2-CHOST-HVM-BYOS elfutils Analysis
SLES15-SP1-CHOST-BYOS-Azure elfutils Analysis
SLES15-SP1-CHOST-BYOS-EC2 elfutils Analysis
SLES15-SP1-CHOST-BYOS-GCE elfutils Analysis
SLES15-SP2-CHOST-BYOS-Aliyun elfutils Analysis
SLES15-SP2-CHOST-BYOS-Azure elfutils Analysis
SLES15-SP2-CHOST-BYOS-EC2 elfutils Analysis
SLES15-SP2-CHOST-BYOS-GCE elfutils Analysis
SLES15-SP3-CHOST-BYOS-Aliyun elfutils Released
SLES15-SP3-CHOST-BYOS-Azure elfutils Released
SLES15-SP3-CHOST-BYOS-EC2 elfutils Released
SLES15-SP3-CHOST-BYOS-GCE elfutils Released
SLES15-SP4-CHOST-BYOS elfutils Already fixed
SLES15-SP4-CHOST-BYOS-Aliyun elfutils Already fixed
SLES15-SP4-CHOST-BYOS-Azure elfutils Already fixed
SLES15-SP4-CHOST-BYOS-EC2 elfutils Already fixed
SLES15-SP4-CHOST-BYOS-GCE elfutils Already fixed
SUSE CaaS Platform 3.0 elfutils Not affected
SUSE Container as a Service Platform 1.0 elfutils Affected
SUSE Container as a Service Platform 2.0 elfutils Not affected
SUSE Linux Enterprise Desktop 11 SP4 elfutils Not affected
SUSE Linux Enterprise Desktop 12 SP3 elfutils Not affected
SUSE Linux Enterprise Desktop 12 SP4 elfutils Not affected
SUSE Linux Enterprise Desktop 15 elfutils Not affected
SUSE Linux Enterprise Desktop 15 SP3 elfutils Released
SUSE Linux Enterprise High Performance Computing 12 SP4 elfutils Not affected
SUSE Linux Enterprise High Performance Computing 15 elfutils Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS elfutils Analysis
SUSE Linux Enterprise High Performance Computing 15 SP3 elfutils Released
SUSE Linux Enterprise Micro 5.0 elfutils Analysis
SUSE Linux Enterprise Micro 5.1 elfutils Released
SUSE Linux Enterprise Micro 5.2 elfutils Released
SUSE Linux Enterprise Micro for Rancher 5.2 elfutils Released
SUSE Linux Enterprise Module for Basesystem 15 elfutils Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 elfutils Released
SUSE Linux Enterprise Server 11 SP3 LTSS elfutils Not affected
SUSE Linux Enterprise Server 11 SP4 elfutils Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS elfutils Not affected
SUSE Linux Enterprise Server 12 LTSS elfutils Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS elfutils Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS elfutils Not affected
SUSE Linux Enterprise Server 12 SP3 elfutils Not affected
SUSE Linux Enterprise Server 12 SP4 elfutils Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS elfutils Affected
SUSE Linux Enterprise Server 15 elfutils Not affected
SUSE Linux Enterprise Server 15 SP3 elfutils Released
SUSE Linux Enterprise Server for SAP Applications 11 SP4 elfutils Not affected
SUSE Linux Enterprise Server for SAP Applications 12 elfutils Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 elfutils Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 elfutils Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 elfutils Not affected
SUSE Linux Enterprise Server for SAP Applications 15 elfutils Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 elfutils Released
SUSE Linux Enterprise Software Development Kit 11 SP4 elfutils Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 elfutils Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 elfutils Not affected
SUSE Linux Enterprise Storage 7.1 elfutils Released
SUSE Manager Proxy 4.2 elfutils Released
SUSE Manager Retail Branch Server 4.2 elfutils Released
SUSE Manager Server 4.2 elfutils Released
suse/sles12sp3 elfutilsAffected
suse/sles/15.3/libguestfs-tools:0.45.0 elfutilsAnalysis
suse/sle-micro-rancher/5.3
suse/sles/15.4/libguestfs-tools:0.49.0
elfutilsAlready fixed
suse/sle-micro-rancher/5.2 elfutilsReleased