Upstream information

CVE-2019-7146 at MITRE

Description

In elfutils 0.175, there is a buffer over-read in the ebl_object_note function in eblobjnote.c in libebl. Remote attackers could leverage this vulnerability to cause a denial-of-service via a crafted elf file, as demonstrated by eu-readelf.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

SUSE Bugzilla entry: 1123545 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 elfutils Not affected
CaaS Platform 2.0 elfutils Not affected
CaaS Platform 3.0 elfutils Not affected
OpenStack Cloud Magnum Orchestration 7.0 elfutils Not affected
SUSE Linux Enterprise Desktop 12 SP3 elfutils Not affected
SUSE Linux Enterprise Desktop 12 SP4 elfutils Not affected
SUSE Linux Enterprise High Performance Computing 12 elfutils Not affected
SUSE Linux Enterprise Module for Basesystem 15 GA elfutils Not affected
SUSE Linux Enterprise SDK 11 SP4 elfutils Not affected
SUSE Linux Enterprise SDK 12 SP4 elfutils Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS elfutils Not affected
SUSE Linux Enterprise Server 11 SP4 elfutils Not affected
SUSE Linux Enterprise Server 12 GA LTSS elfutils Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS elfutils Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS elfutils Not affected
SUSE Linux Enterprise Server 12 SP3 elfutils Not affected
SUSE Linux Enterprise Server 12 SP4 elfutils Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 elfutils Not affected
SUSE Linux Enterprise Server for SAP Applications 12 GA elfutils Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 elfutils Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 elfutils Not affected