Upstream information

CVE-2019-5544 at MITRE

Description

OpenSLP as used in ESXi and the Horizon DaaS appliances has a heap overwrite issue. VMware has evaluated the severity of this issue to be in the Critical severity range with a maximum CVSSv3 base score of 9.8.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v3 Scores
  SUSE
Base Score 9.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1157869 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 12 SP5
  • openslp >= 2.0.0-18.20.2
  • openslp-32bit >= 2.0.0-18.20.2
  • openslp-server >= 2.0.0-18.20.2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 3.0 openslp Not affected
SUSE Container as a Service Platform 1.0 openslp Affected
SUSE Container as a Service Platform 2.0 openslp Not affected
SUSE Linux Enterprise Desktop 12 SP4 openslp Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 openslp Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 openslp Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS openslp Not affected
SUSE Linux Enterprise Micro 5.0 openslp Not affected
SUSE Linux Enterprise Micro 5.1 openslp Not affected
SUSE Linux Enterprise Module for Basesystem 15 openslp Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 openslp Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 openslp Not affected
SUSE Linux Enterprise Module for Server Applications 15 openslp Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP1 openslp Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP3 openslp Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS openslp Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS openslp Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS openslp Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS openslp Not affected
SUSE Linux Enterprise Server 12 SP4 openslp Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS openslp Not affected
SUSE Linux Enterprise Server 12 SP5 openslp Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 openslp Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 openslp Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 openslp Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 openslp Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 openslp Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 openslp Not affected