Upstream information

CVE-2019-25076 at MITRE

Description

The TSS (Tuple Space Search) algorithm in Open vSwitch 2.x through 2.17.2 and 3.0.0 allows remote attackers to cause a denial of service (delays of legitimate traffic) via crafted packet data that requires excessive evaluation time within the packet classification algorithm for the MegaFlow cache, aka a Tuple Space Explosion (TSE) attack.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database
Base Score 5.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:L
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Changed
Confidentiality Impact None
Integrity Impact None
Availability Impact Low
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1203284 [RESOLVED / WONTFIX]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 openvswitch Won't fix
SUSE Linux Enterprise High Performance Computing 12 SP5 openvswitch Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP5 openvswitch Won't fix
SUSE Linux Enterprise Module for Legacy 15 SP5 openvswitch Won't fix
SUSE Linux Enterprise Module for Package Hub 15 SP4 openvswitch Won't fix
SUSE Linux Enterprise Module for Package Hub 15 SP5 openvswitch Won't fix
SUSE Linux Enterprise Real Time 15 SP3 openvswitch Won't fix
SUSE Linux Enterprise Server 12 SP5 openvswitch Won't fix
SUSE Linux Enterprise Server 15 SP5 openvswitch Won't fix
SUSE Linux Enterprise Server for SAP Applications 12 SP5 openvswitch Won't fix
SUSE Linux Enterprise Server for SAP Applications 15 SP4 openvswitch Won't fix
SUSE Linux Enterprise Server for SAP Applications 15 SP5 openvswitch Won't fix
SUSE Manager Proxy 4.3 openvswitch Won't fix
SUSE Manager Retail Branch Server 4.3 openvswitch Won't fix
SUSE Manager Server 4.3 openvswitch Won't fix
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 openvswitch Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP1 openvswitch Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS openvswitch Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS openvswitch Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP2 openvswitch Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS openvswitch Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS openvswitch Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP3 openvswitch Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS openvswitch Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS openvswitch Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP4 openvswitch Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS openvswitch Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS openvswitch Won't fix
SUSE Linux Enterprise High Performance Computing 15-ESPOS openvswitch Won't fix
SUSE Linux Enterprise High Performance Computing 15-LTSS openvswitch Unsupported
SUSE Linux Enterprise Module for Server Applications 15 SP2 openvswitch Won't fix
SUSE Linux Enterprise Module for Server Applications 15 SP3 openvswitch Unsupported
SUSE Linux Enterprise Module for Server Applications 15 SP4 openvswitch Won't fix
SUSE Linux Enterprise Server 12 SP2-BCL openvswitch Won't fix
SUSE Linux Enterprise Server 15 SP2 openvswitch Won't fix
SUSE Linux Enterprise Server 15 SP2-LTSS openvswitch Won't fix
SUSE Linux Enterprise Server 15 SP3 openvswitch Unsupported
SUSE Linux Enterprise Server 15 SP3-LTSS openvswitch Won't fix
SUSE Linux Enterprise Server 15 SP4 openvswitch Won't fix
SUSE Linux Enterprise Server 15 SP4-LTSS openvswitch Won't fix
SUSE Linux Enterprise Server 15-ESPOS openvswitch Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 openvswitch Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 openvswitch Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP3 openvswitch Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 openvswitch Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP1 openvswitch Won't fix
SUSE Linux Enterprise Server for SAP Applications 15 SP2 openvswitch Won't fix
SUSE Linux Enterprise Server for SAP Applications 15 SP3 openvswitch Unsupported
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 openvswitch Won't fix
SUSE CaaS Platform 4.0 openvswitch Won't fix
SUSE Enterprise Storage 6 openvswitch Affected
SUSE Enterprise Storage 7 openvswitch Won't fix
SUSE Linux Enterprise Module for Package Hub 15 SP1 openvswitch Won't fix
SUSE Linux Enterprise Module for Package Hub 15 SP2 openvswitch Won't fix
SUSE Linux Enterprise Module for Package Hub 15 SP3 openvswitch Won't fix
SUSE Linux Enterprise Module for Server Applications 15 openvswitch Won't fix
SUSE Linux Enterprise Module for Server Applications 15 SP1 openvswitch Won't fix
SUSE Linux Enterprise Real Time 15 SP2 openvswitch Won't fix
SUSE Linux Enterprise Real Time 15 SP4 openvswitch Won't fix
SUSE Linux Enterprise Server 12 SP2 openvswitch Won't fix
SUSE Linux Enterprise Server 12 SP2-ESPOS openvswitch Won't fix
SUSE Linux Enterprise Server 12 SP2-LTSS openvswitch Won't fix
SUSE Linux Enterprise Server 12 SP3 openvswitch Won't fix
SUSE Linux Enterprise Server 12 SP3-BCL openvswitch Unsupported
SUSE Linux Enterprise Server 12 SP3-ESPOS openvswitch Won't fix
SUSE Linux Enterprise Server 12 SP3-LTSS openvswitch Won't fix
SUSE Linux Enterprise Server 12 SP4 openvswitch Won't fix
SUSE Linux Enterprise Server 12 SP4-ESPOS openvswitch Won't fix
SUSE Linux Enterprise Server 12 SP4-LTSS openvswitch Won't fix
SUSE Linux Enterprise Server 15 openvswitch Won't fix
SUSE Linux Enterprise Server 15 SP1 openvswitch Won't fix
SUSE Linux Enterprise Server 15 SP1-BCL openvswitch Won't fix
SUSE Linux Enterprise Server 15 SP1-LTSS openvswitch Won't fix
SUSE Linux Enterprise Server 15 SP2-BCL openvswitch Won't fix
SUSE Linux Enterprise Server 15 SP3-BCL openvswitch Won't fix
SUSE Linux Enterprise Server 15-LTSS openvswitch Unsupported
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 openvswitch Won't fix
SUSE Linux Enterprise Server for SAP Applications 12 SP2 openvswitch Won't fix
SUSE Linux Enterprise Server for SAP Applications 12 SP3 openvswitch Won't fix
SUSE Linux Enterprise Server for SAP Applications 12 SP4 openvswitch Won't fix
SUSE Manager Proxy 4.0 openvswitch Won't fix
SUSE Manager Proxy 4.1 openvswitch Unsupported
SUSE Manager Proxy 4.2 openvswitch Unsupported
SUSE Manager Retail Branch Server 4.0 openvswitch Won't fix
SUSE Manager Retail Branch Server 4.1 openvswitch Unsupported
SUSE Manager Retail Branch Server 4.2 openvswitch Unsupported
SUSE Manager Server 4.0 openvswitch Won't fix
SUSE Manager Server 4.1 openvswitch Unsupported
SUSE Manager Server 4.2 openvswitch Unsupported
SUSE OpenStack Cloud 7 openvswitch Won't fix
SUSE OpenStack Cloud 8 openvswitch Won't fix
SUSE OpenStack Cloud 9 openvswitch Won't fix
SUSE OpenStack Cloud Crowbar 8 openvswitch Won't fix
SUSE OpenStack Cloud Crowbar 9 openvswitch Won't fix


SUSE Timeline for this CVE

CVE page created: Fri Sep 9 08:00:04 2022
CVE page last modified: Thu Feb 1 01:35:37 2024