Upstream information

CVE-2019-15846 at MITRE

Description

Exim before 4.92.2 allows remote attackers to execute arbitrary code as root via a trailing backslash.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 10
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1149182 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 15.0
  • exim >= 4.88-lp150.3.9.1
  • exim-debuginfo >= 4.88-lp150.3.9.1
  • exim-debugsource >= 4.88-lp150.3.9.1
  • eximon >= 4.88-lp150.3.9.1
  • eximon-debuginfo >= 4.88-lp150.3.9.1
  • eximstats-html >= 4.88-lp150.3.9.1
Patchnames:
openSUSE-2019-2093
openSUSE Leap 15.1
  • exim >= 4.88-lp151.4.9.1
  • exim-debuginfo >= 4.88-lp151.4.9.1
  • exim-debugsource >= 4.88-lp151.4.9.1
  • eximon >= 4.88-lp151.4.9.1
  • eximon-debuginfo >= 4.88-lp151.4.9.1
  • eximstats-html >= 4.88-lp151.4.9.1
Patchnames:
openSUSE-2019-2093