Upstream information

CVE-2019-13917 at MITRE

Description

Exim 4.85 through 4.92 (fixed in 4.92.1) allows remote code execution as root in some unusual configurations that use the ${sort } expansion for items that can be controlled by an attacker (e.g., $local_part or $domain).

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 10
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 1142207 [RESOLVED / FIXED]

SUSE Security Advisories:
  • TID7024110, published Tue Sep 17 22:57:48 CEST 2019

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 15.0
  • exim >= 4.88-lp150.3.6.1
  • exim-debuginfo >= 4.88-lp150.3.6.1
  • exim-debugsource >= 4.88-lp150.3.6.1
  • eximon >= 4.88-lp150.3.6.1
  • eximon-debuginfo >= 4.88-lp150.3.6.1
  • eximstats-html >= 4.88-lp150.3.6.1
Patchnames:
openSUSE-2019-1812
openSUSE Leap 15.1
  • exim >= 4.88-lp151.4.6.1
  • exim-debuginfo >= 4.88-lp151.4.6.1
  • exim-debugsource >= 4.88-lp151.4.6.1
  • eximon >= 4.88-lp151.4.6.1
  • eximon-debuginfo >= 4.88-lp151.4.6.1
  • eximstats-html >= 4.88-lp151.4.6.1
Patchnames:
openSUSE-2019-1812