Upstream information

CVE-2019-10208 at MITRE

Description

A flaw was discovered in postgresql versions 9.4.x before 9.4.24, 9.5.x before 9.5.19, 9.6.x before 9.6.15, 10.x before 10.10 and 11.x before 11.5 where arbitrary SQL statements can be executed given a suitable SECURITY DEFINER function. An attacker, with EXECUTE permission on the function, can execute arbitrary SQL as the owner of the function.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/Au:S/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  SUSE
Base Score 7.5
Vector AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity High
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.0
SUSE Bugzilla entry: 1145092 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • postgresql96 >= 9.6.15-3.29.1
  • postgresql96-contrib >= 9.6.15-3.29.1
  • postgresql96-docs >= 9.6.15-3.29.1
  • postgresql96-libs >= 9.6.15-3.29.1
  • postgresql96-plperl >= 9.6.15-3.29.1
  • postgresql96-plpython >= 9.6.15-3.29.1
  • postgresql96-pltcl >= 9.6.15-3.29.1
  • postgresql96-server >= 9.6.15-3.29.1
Patchnames:
HPE-Helion-OpenStack-8-2019-2159
SUSE Enterprise Storage 4
  • postgresql94 >= 9.4.24-21.25.1
  • postgresql94-contrib >= 9.4.24-21.25.1
  • postgresql94-docs >= 9.4.24-21.25.1
  • postgresql94-plperl >= 9.4.24-21.25.1
  • postgresql94-plpython >= 9.4.24-21.25.1
  • postgresql94-pltcl >= 9.4.24-21.25.1
  • postgresql94-server >= 9.4.24-21.25.1
  • postgresql96 >= 9.6.15-3.29.1
  • postgresql96-contrib >= 9.6.15-3.29.1
  • postgresql96-docs >= 9.6.15-3.29.1
  • postgresql96-libs >= 9.6.15-3.29.1
  • postgresql96-plperl >= 9.6.15-3.29.1
  • postgresql96-plpython >= 9.6.15-3.29.1
  • postgresql96-pltcl >= 9.6.15-3.29.1
  • postgresql96-server >= 9.6.15-3.29.1
Patchnames:
SUSE-Storage-4-2019-2158
SUSE-Storage-4-2019-2159
SUSE Enterprise Storage 5
  • postgresql96 >= 9.6.15-3.29.1
  • postgresql96-contrib >= 9.6.15-3.29.1
  • postgresql96-docs >= 9.6.15-3.29.1
  • postgresql96-libs >= 9.6.15-3.29.1
  • postgresql96-plperl >= 9.6.15-3.29.1
  • postgresql96-plpython >= 9.6.15-3.29.1
  • postgresql96-pltcl >= 9.6.15-3.29.1
  • postgresql96-server >= 9.6.15-3.29.1
Patchnames:
SUSE-Storage-5-2019-2159
SUSE Linux Enterprise Desktop 12 SP4
  • libecpg6 >= 10.10-1.15.1
  • libpq5 >= 10.10-1.15.1
  • libpq5-32bit >= 10.10-1.15.1
  • postgresql10 >= 10.10-1.15.1
  • postgresql10-libs >= 10.10-1.15.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-2269
SUSE Linux Enterprise Module for Basesystem 15
  • libpq5 >= 10.10-4.16.1
  • postgresql10 >= 10.10-4.16.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-2228
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libpq5 >= 10.10-8.6.1
  • postgresql10 >= 10.10-8.6.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2019-2707
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • libpq5-32bit >= 10.10-4.16.1
  • postgresql10 >= 10.10-4.16.1
  • postgresql10-test >= 10.10-4.16.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-2228
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • libecpg6-32bit >= 10.10-8.6.1
  • libpq5-32bit >= 10.10-8.6.1
  • postgresql10 >= 10.10-8.6.1
  • postgresql10-test >= 10.10-8.6.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2707
SUSE Linux Enterprise Module for Server Applications 15
  • libecpg6 >= 10.10-4.16.1
  • postgresql10 >= 10.10-4.16.1
  • postgresql10-contrib >= 10.10-4.16.1
  • postgresql10-devel >= 10.10-4.16.1
  • postgresql10-docs >= 10.10-4.16.1
  • postgresql10-plperl >= 10.10-4.16.1
  • postgresql10-plpython >= 10.10-4.16.1
  • postgresql10-pltcl >= 10.10-4.16.1
  • postgresql10-server >= 10.10-4.16.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-2019-2228
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • libecpg6 >= 10.10-8.6.1
  • postgresql10 >= 10.10-8.6.1
  • postgresql10-contrib >= 10.10-8.6.1
  • postgresql10-devel >= 10.10-8.6.1
  • postgresql10-docs >= 10.10-8.6.1
  • postgresql10-plperl >= 10.10-8.6.1
  • postgresql10-plpython >= 10.10-8.6.1
  • postgresql10-pltcl >= 10.10-8.6.1
  • postgresql10-server >= 10.10-8.6.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP1-2019-2707
SUSE Linux Enterprise Module for additional PackageHub packages 15
  • postgresql10 >= 10.10-4.16.1
  • postgresql10-test >= 10.10-4.16.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-2019-2228
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • postgresql94 >= 9.4.24-21.25.1
  • postgresql94-contrib >= 9.4.24-21.25.1
  • postgresql94-docs >= 9.4.24-21.25.1
  • postgresql94-plperl >= 9.4.24-21.25.1
  • postgresql94-plpython >= 9.4.24-21.25.1
  • postgresql94-pltcl >= 9.4.24-21.25.1
  • postgresql94-server >= 9.4.24-21.25.1
  • postgresql96 >= 9.6.15-3.29.1
  • postgresql96-contrib >= 9.6.15-3.29.1
  • postgresql96-docs >= 9.6.15-3.29.1
  • postgresql96-libs >= 9.6.15-3.29.1
  • postgresql96-plperl >= 9.6.15-3.29.1
  • postgresql96-plpython >= 9.6.15-3.29.1
  • postgresql96-pltcl >= 9.6.15-3.29.1
  • postgresql96-server >= 9.6.15-3.29.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2019-2158
SUSE-SLE-POS-12-SP2-CLIENT-2019-2159
SUSE Linux Enterprise Server 12 SP1-LTSS
  • postgresql94 >= 9.4.24-21.25.1
  • postgresql94-contrib >= 9.4.24-21.25.1
  • postgresql94-docs >= 9.4.24-21.25.1
  • postgresql94-plperl >= 9.4.24-21.25.1
  • postgresql94-plpython >= 9.4.24-21.25.1
  • postgresql94-pltcl >= 9.4.24-21.25.1
  • postgresql94-server >= 9.4.24-21.25.1
  • postgresql96 >= 9.6.15-3.29.1
  • postgresql96-contrib >= 9.6.15-3.29.1
  • postgresql96-docs >= 9.6.15-3.29.1
  • postgresql96-libs >= 9.6.15-3.29.1
  • postgresql96-plperl >= 9.6.15-3.29.1
  • postgresql96-plpython >= 9.6.15-3.29.1
  • postgresql96-pltcl >= 9.6.15-3.29.1
  • postgresql96-server >= 9.6.15-3.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-2158
SUSE-SLE-SERVER-12-SP1-2019-2159
SUSE Linux Enterprise Server 12 SP2-BCL
  • postgresql94 >= 9.4.24-21.25.1
  • postgresql94-contrib >= 9.4.24-21.25.1
  • postgresql94-docs >= 9.4.24-21.25.1
  • postgresql94-plperl >= 9.4.24-21.25.1
  • postgresql94-plpython >= 9.4.24-21.25.1
  • postgresql94-pltcl >= 9.4.24-21.25.1
  • postgresql94-server >= 9.4.24-21.25.1
  • postgresql96 >= 9.6.15-3.29.1
  • postgresql96-contrib >= 9.6.15-3.29.1
  • postgresql96-docs >= 9.6.15-3.29.1
  • postgresql96-libs >= 9.6.15-3.29.1
  • postgresql96-plperl >= 9.6.15-3.29.1
  • postgresql96-plpython >= 9.6.15-3.29.1
  • postgresql96-pltcl >= 9.6.15-3.29.1
  • postgresql96-server >= 9.6.15-3.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-2158
SUSE-SLE-SERVER-12-SP2-BCL-2019-2159
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • postgresql94 >= 9.4.24-21.25.1
  • postgresql94-contrib >= 9.4.24-21.25.1
  • postgresql94-docs >= 9.4.24-21.25.1
  • postgresql94-plperl >= 9.4.24-21.25.1
  • postgresql94-plpython >= 9.4.24-21.25.1
  • postgresql94-pltcl >= 9.4.24-21.25.1
  • postgresql94-server >= 9.4.24-21.25.1
  • postgresql96 >= 9.6.15-3.29.1
  • postgresql96-contrib >= 9.6.15-3.29.1
  • postgresql96-docs >= 9.6.15-3.29.1
  • postgresql96-libs >= 9.6.15-3.29.1
  • postgresql96-plperl >= 9.6.15-3.29.1
  • postgresql96-plpython >= 9.6.15-3.29.1
  • postgresql96-pltcl >= 9.6.15-3.29.1
  • postgresql96-server >= 9.6.15-3.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-2158
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-2159
SUSE Linux Enterprise Server 12 SP2-LTSS
  • postgresql94 >= 9.4.24-21.25.1
  • postgresql94-contrib >= 9.4.24-21.25.1
  • postgresql94-docs >= 9.4.24-21.25.1
  • postgresql94-plperl >= 9.4.24-21.25.1
  • postgresql94-plpython >= 9.4.24-21.25.1
  • postgresql94-pltcl >= 9.4.24-21.25.1
  • postgresql94-server >= 9.4.24-21.25.1
  • postgresql96 >= 9.6.15-3.29.1
  • postgresql96-contrib >= 9.6.15-3.29.1
  • postgresql96-docs >= 9.6.15-3.29.1
  • postgresql96-libs >= 9.6.15-3.29.1
  • postgresql96-plperl >= 9.6.15-3.29.1
  • postgresql96-plpython >= 9.6.15-3.29.1
  • postgresql96-pltcl >= 9.6.15-3.29.1
  • postgresql96-server >= 9.6.15-3.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-2158
SUSE-SLE-SERVER-12-SP2-2019-2159
SUSE Linux Enterprise Server 12 SP3-BCL
  • postgresql96 >= 9.6.15-3.29.1
  • postgresql96-contrib >= 9.6.15-3.29.1
  • postgresql96-docs >= 9.6.15-3.29.1
  • postgresql96-libs >= 9.6.15-3.29.1
  • postgresql96-plperl >= 9.6.15-3.29.1
  • postgresql96-plpython >= 9.6.15-3.29.1
  • postgresql96-pltcl >= 9.6.15-3.29.1
  • postgresql96-server >= 9.6.15-3.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2019-2159
SUSE Linux Enterprise Server 12 SP3-ESPOS
  • postgresql96 >= 9.6.15-3.29.1
  • postgresql96-contrib >= 9.6.15-3.29.1
  • postgresql96-docs >= 9.6.15-3.29.1
  • postgresql96-libs >= 9.6.15-3.29.1
  • postgresql96-plperl >= 9.6.15-3.29.1
  • postgresql96-plpython >= 9.6.15-3.29.1
  • postgresql96-pltcl >= 9.6.15-3.29.1
  • postgresql96-server >= 9.6.15-3.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2019-2159
SUSE Linux Enterprise Server 12 SP3-LTSS
  • postgresql96 >= 9.6.15-3.29.1
  • postgresql96-contrib >= 9.6.15-3.29.1
  • postgresql96-docs >= 9.6.15-3.29.1
  • postgresql96-libs >= 9.6.15-3.29.1
  • postgresql96-plperl >= 9.6.15-3.29.1
  • postgresql96-plpython >= 9.6.15-3.29.1
  • postgresql96-pltcl >= 9.6.15-3.29.1
  • postgresql96-server >= 9.6.15-3.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-2159
SUSE Linux Enterprise Server 12 SP4
  • libecpg6 >= 10.10-1.15.1
  • libpq5 >= 10.10-1.15.1
  • libpq5-32bit >= 10.10-1.15.1
  • postgresql10 >= 10.10-1.15.1
  • postgresql10-contrib >= 10.10-1.15.1
  • postgresql10-docs >= 10.10-1.15.1
  • postgresql10-libs >= 10.10-1.15.1
  • postgresql10-plperl >= 10.10-1.15.1
  • postgresql10-plpython >= 10.10-1.15.1
  • postgresql10-pltcl >= 10.10-1.15.1
  • postgresql10-server >= 10.10-1.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-2269
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • postgresql94 >= 9.4.24-21.25.1
  • postgresql94-contrib >= 9.4.24-21.25.1
  • postgresql94-docs >= 9.4.24-21.25.1
  • postgresql94-plperl >= 9.4.24-21.25.1
  • postgresql94-plpython >= 9.4.24-21.25.1
  • postgresql94-pltcl >= 9.4.24-21.25.1
  • postgresql94-server >= 9.4.24-21.25.1
  • postgresql96 >= 9.6.15-3.29.1
  • postgresql96-contrib >= 9.6.15-3.29.1
  • postgresql96-docs >= 9.6.15-3.29.1
  • postgresql96-libs >= 9.6.15-3.29.1
  • postgresql96-plperl >= 9.6.15-3.29.1
  • postgresql96-plpython >= 9.6.15-3.29.1
  • postgresql96-pltcl >= 9.6.15-3.29.1
  • postgresql96-server >= 9.6.15-3.29.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-2158
SUSE-SLE-SAP-12-SP1-2019-2159
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • postgresql94 >= 9.4.24-21.25.1
  • postgresql94-contrib >= 9.4.24-21.25.1
  • postgresql94-docs >= 9.4.24-21.25.1
  • postgresql94-plperl >= 9.4.24-21.25.1
  • postgresql94-plpython >= 9.4.24-21.25.1
  • postgresql94-pltcl >= 9.4.24-21.25.1
  • postgresql94-server >= 9.4.24-21.25.1
  • postgresql96 >= 9.6.15-3.29.1
  • postgresql96-contrib >= 9.6.15-3.29.1
  • postgresql96-docs >= 9.6.15-3.29.1
  • postgresql96-libs >= 9.6.15-3.29.1
  • postgresql96-plperl >= 9.6.15-3.29.1
  • postgresql96-plpython >= 9.6.15-3.29.1
  • postgresql96-pltcl >= 9.6.15-3.29.1
  • postgresql96-server >= 9.6.15-3.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-2158
SUSE-SLE-SERVER-12-SP1-2019-2159
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • postgresql94 >= 9.4.24-21.25.1
  • postgresql94-contrib >= 9.4.24-21.25.1
  • postgresql94-docs >= 9.4.24-21.25.1
  • postgresql94-plperl >= 9.4.24-21.25.1
  • postgresql94-plpython >= 9.4.24-21.25.1
  • postgresql94-pltcl >= 9.4.24-21.25.1
  • postgresql94-server >= 9.4.24-21.25.1
  • postgresql96 >= 9.6.15-3.29.1
  • postgresql96-contrib >= 9.6.15-3.29.1
  • postgresql96-docs >= 9.6.15-3.29.1
  • postgresql96-libs >= 9.6.15-3.29.1
  • postgresql96-plperl >= 9.6.15-3.29.1
  • postgresql96-plpython >= 9.6.15-3.29.1
  • postgresql96-pltcl >= 9.6.15-3.29.1
  • postgresql96-server >= 9.6.15-3.29.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-2158
SUSE-SLE-SAP-12-SP2-2019-2159
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • postgresql94 >= 9.4.24-21.25.1
  • postgresql94-contrib >= 9.4.24-21.25.1
  • postgresql94-docs >= 9.4.24-21.25.1
  • postgresql94-plperl >= 9.4.24-21.25.1
  • postgresql94-plpython >= 9.4.24-21.25.1
  • postgresql94-pltcl >= 9.4.24-21.25.1
  • postgresql94-server >= 9.4.24-21.25.1
  • postgresql96 >= 9.6.15-3.29.1
  • postgresql96-contrib >= 9.6.15-3.29.1
  • postgresql96-docs >= 9.6.15-3.29.1
  • postgresql96-libs >= 9.6.15-3.29.1
  • postgresql96-plperl >= 9.6.15-3.29.1
  • postgresql96-plpython >= 9.6.15-3.29.1
  • postgresql96-pltcl >= 9.6.15-3.29.1
  • postgresql96-server >= 9.6.15-3.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-2158
SUSE-SLE-SERVER-12-SP2-BCL-2019-2159
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • postgresql94 >= 9.4.24-21.25.1
  • postgresql94-contrib >= 9.4.24-21.25.1
  • postgresql94-docs >= 9.4.24-21.25.1
  • postgresql94-plperl >= 9.4.24-21.25.1
  • postgresql94-plpython >= 9.4.24-21.25.1
  • postgresql94-pltcl >= 9.4.24-21.25.1
  • postgresql94-server >= 9.4.24-21.25.1
  • postgresql96 >= 9.6.15-3.29.1
  • postgresql96-contrib >= 9.6.15-3.29.1
  • postgresql96-docs >= 9.6.15-3.29.1
  • postgresql96-libs >= 9.6.15-3.29.1
  • postgresql96-plperl >= 9.6.15-3.29.1
  • postgresql96-plpython >= 9.6.15-3.29.1
  • postgresql96-pltcl >= 9.6.15-3.29.1
  • postgresql96-server >= 9.6.15-3.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-2158
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-2159
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • postgresql94 >= 9.4.24-21.25.1
  • postgresql94-contrib >= 9.4.24-21.25.1
  • postgresql94-docs >= 9.4.24-21.25.1
  • postgresql94-plperl >= 9.4.24-21.25.1
  • postgresql94-plpython >= 9.4.24-21.25.1
  • postgresql94-pltcl >= 9.4.24-21.25.1
  • postgresql94-server >= 9.4.24-21.25.1
  • postgresql96 >= 9.6.15-3.29.1
  • postgresql96-contrib >= 9.6.15-3.29.1
  • postgresql96-docs >= 9.6.15-3.29.1
  • postgresql96-libs >= 9.6.15-3.29.1
  • postgresql96-plperl >= 9.6.15-3.29.1
  • postgresql96-plpython >= 9.6.15-3.29.1
  • postgresql96-pltcl >= 9.6.15-3.29.1
  • postgresql96-server >= 9.6.15-3.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-2158
SUSE-SLE-SERVER-12-SP2-2019-2159
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • postgresql96 >= 9.6.15-3.29.1
  • postgresql96-contrib >= 9.6.15-3.29.1
  • postgresql96-docs >= 9.6.15-3.29.1
  • postgresql96-libs >= 9.6.15-3.29.1
  • postgresql96-plperl >= 9.6.15-3.29.1
  • postgresql96-plpython >= 9.6.15-3.29.1
  • postgresql96-pltcl >= 9.6.15-3.29.1
  • postgresql96-server >= 9.6.15-3.29.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2019-2159
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • postgresql96 >= 9.6.15-3.29.1
  • postgresql96-contrib >= 9.6.15-3.29.1
  • postgresql96-docs >= 9.6.15-3.29.1
  • postgresql96-libs >= 9.6.15-3.29.1
  • postgresql96-plperl >= 9.6.15-3.29.1
  • postgresql96-plpython >= 9.6.15-3.29.1
  • postgresql96-pltcl >= 9.6.15-3.29.1
  • postgresql96-server >= 9.6.15-3.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2019-2159
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • postgresql96 >= 9.6.15-3.29.1
  • postgresql96-contrib >= 9.6.15-3.29.1
  • postgresql96-docs >= 9.6.15-3.29.1
  • postgresql96-libs >= 9.6.15-3.29.1
  • postgresql96-plperl >= 9.6.15-3.29.1
  • postgresql96-plpython >= 9.6.15-3.29.1
  • postgresql96-pltcl >= 9.6.15-3.29.1
  • postgresql96-server >= 9.6.15-3.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2019-2159
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • postgresql96 >= 9.6.15-3.29.1
  • postgresql96-contrib >= 9.6.15-3.29.1
  • postgresql96-docs >= 9.6.15-3.29.1
  • postgresql96-libs >= 9.6.15-3.29.1
  • postgresql96-plperl >= 9.6.15-3.29.1
  • postgresql96-plpython >= 9.6.15-3.29.1
  • postgresql96-pltcl >= 9.6.15-3.29.1
  • postgresql96-server >= 9.6.15-3.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-2159
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libecpg6 >= 10.10-1.15.1
  • libpq5 >= 10.10-1.15.1
  • libpq5-32bit >= 10.10-1.15.1
  • postgresql10 >= 10.10-1.15.1
  • postgresql10-contrib >= 10.10-1.15.1
  • postgresql10-docs >= 10.10-1.15.1
  • postgresql10-libs >= 10.10-1.15.1
  • postgresql10-plperl >= 10.10-1.15.1
  • postgresql10-plpython >= 10.10-1.15.1
  • postgresql10-pltcl >= 10.10-1.15.1
  • postgresql10-server >= 10.10-1.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-2269
SUSE Linux Enterprise Software Development Kit 12 SP4
  • postgresql10-devel >= 10.10-1.15.1
  • postgresql10-libs >= 10.10-1.15.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-2269
SUSE OpenStack Cloud 7
  • postgresql94 >= 9.4.24-21.25.1
  • postgresql94-contrib >= 9.4.24-21.25.1
  • postgresql94-docs >= 9.4.24-21.25.1
  • postgresql94-plperl >= 9.4.24-21.25.1
  • postgresql94-plpython >= 9.4.24-21.25.1
  • postgresql94-pltcl >= 9.4.24-21.25.1
  • postgresql94-server >= 9.4.24-21.25.1
  • postgresql96 >= 9.6.15-3.29.1
  • postgresql96-contrib >= 9.6.15-3.29.1
  • postgresql96-docs >= 9.6.15-3.29.1
  • postgresql96-libs >= 9.6.15-3.29.1
  • postgresql96-plperl >= 9.6.15-3.29.1
  • postgresql96-plpython >= 9.6.15-3.29.1
  • postgresql96-pltcl >= 9.6.15-3.29.1
  • postgresql96-server >= 9.6.15-3.29.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-2158
SUSE-OpenStack-Cloud-7-2019-2159
SUSE OpenStack Cloud 8
  • postgresql96 >= 9.6.15-3.29.1
  • postgresql96-contrib >= 9.6.15-3.29.1
  • postgresql96-docs >= 9.6.15-3.29.1
  • postgresql96-libs >= 9.6.15-3.29.1
  • postgresql96-plperl >= 9.6.15-3.29.1
  • postgresql96-plpython >= 9.6.15-3.29.1
  • postgresql96-pltcl >= 9.6.15-3.29.1
  • postgresql96-server >= 9.6.15-3.29.1
Patchnames:
SUSE-OpenStack-Cloud-8-2019-2159
SUSE OpenStack Cloud Crowbar 8
  • postgresql96 >= 9.6.15-3.29.1
  • postgresql96-contrib >= 9.6.15-3.29.1
  • postgresql96-docs >= 9.6.15-3.29.1
  • postgresql96-libs >= 9.6.15-3.29.1
  • postgresql96-plperl >= 9.6.15-3.29.1
  • postgresql96-plpython >= 9.6.15-3.29.1
  • postgresql96-pltcl >= 9.6.15-3.29.1
  • postgresql96-server >= 9.6.15-3.29.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2019-2159
openSUSE Leap 15.0
  • libecpg6 >= 10.10-lp150.3.13.1
  • libecpg6-32bit >= 10.10-lp150.3.13.1
  • libecpg6-32bit-debuginfo >= 10.10-lp150.3.13.1
  • libecpg6-debuginfo >= 10.10-lp150.3.13.1
  • libpq5 >= 10.10-lp150.3.13.1
  • libpq5-32bit >= 10.10-lp150.3.13.1
  • libpq5-32bit-debuginfo >= 10.10-lp150.3.13.1
  • libpq5-debuginfo >= 10.10-lp150.3.13.1
  • postgresql10 >= 10.10-lp150.3.13.1
  • postgresql10-contrib >= 10.10-lp150.3.13.1
  • postgresql10-contrib-debuginfo >= 10.10-lp150.3.13.1
  • postgresql10-debuginfo >= 10.10-lp150.3.13.1
  • postgresql10-debugsource >= 10.10-lp150.3.13.1
  • postgresql10-devel >= 10.10-lp150.3.13.1
  • postgresql10-devel-debuginfo >= 10.10-lp150.3.13.1
  • postgresql10-docs >= 10.10-lp150.3.13.1
  • postgresql10-plperl >= 10.10-lp150.3.13.1
  • postgresql10-plperl-debuginfo >= 10.10-lp150.3.13.1
  • postgresql10-plpython >= 10.10-lp150.3.13.1
  • postgresql10-plpython-debuginfo >= 10.10-lp150.3.13.1
  • postgresql10-pltcl >= 10.10-lp150.3.13.1
  • postgresql10-pltcl-debuginfo >= 10.10-lp150.3.13.1
  • postgresql10-server >= 10.10-lp150.3.13.1
  • postgresql10-server-debuginfo >= 10.10-lp150.3.13.1
  • postgresql10-test >= 10.10-lp150.3.13.1
Patchnames:
openSUSE-2019-2062
openSUSE Leap 15.1
  • libecpg6 >= 10.10-lp151.2.6.1
  • libecpg6-32bit >= 10.10-lp151.2.6.1
  • libecpg6-32bit-debuginfo >= 10.10-lp151.2.6.1
  • libecpg6-debuginfo >= 10.10-lp151.2.6.1
  • libpq5 >= 10.10-lp151.2.6.1
  • libpq5-32bit >= 10.10-lp151.2.6.1
  • libpq5-32bit-debuginfo >= 10.10-lp151.2.6.1
  • libpq5-debuginfo >= 10.10-lp151.2.6.1
  • postgresql10 >= 10.10-lp151.2.6.1
  • postgresql10-contrib >= 10.10-lp151.2.6.1
  • postgresql10-contrib-debuginfo >= 10.10-lp151.2.6.1
  • postgresql10-debuginfo >= 10.10-lp151.2.6.1
  • postgresql10-debugsource >= 10.10-lp151.2.6.1
  • postgresql10-devel >= 10.10-lp151.2.6.1
  • postgresql10-devel-debuginfo >= 10.10-lp151.2.6.1
  • postgresql10-docs >= 10.10-lp151.2.6.1
  • postgresql10-plperl >= 10.10-lp151.2.6.1
  • postgresql10-plperl-debuginfo >= 10.10-lp151.2.6.1
  • postgresql10-plpython >= 10.10-lp151.2.6.1
  • postgresql10-plpython-debuginfo >= 10.10-lp151.2.6.1
  • postgresql10-pltcl >= 10.10-lp151.2.6.1
  • postgresql10-pltcl-debuginfo >= 10.10-lp151.2.6.1
  • postgresql10-server >= 10.10-lp151.2.6.1
  • postgresql10-server-debuginfo >= 10.10-lp151.2.6.1
  • postgresql10-test >= 10.10-lp151.2.6.1
Patchnames:
openSUSE-2019-2062


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 postgresql10 Unsupported
SUSE Linux Enterprise Desktop 12 SP3 postgresql96 Unsupported
SUSE Linux Enterprise Desktop 12 SP4 postgresql10 Released
SUSE Linux Enterprise High Performance Computing 12 postgresql10 Released
SUSE Linux Enterprise Module for Basesystem 15 GA postgresql Not affected
SUSE Linux Enterprise Module for Basesystem 15 GA postgresql10 Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 postgresql Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 postgresql10 Released
SUSE Linux Enterprise Module for Server Applications 15 GA postgresql Not affected
SUSE Linux Enterprise Module for Server Applications 15 GA postgresql10 Released
SUSE Linux Enterprise Module for Server Applications 15 SP1 postgresql Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP1 postgresql10 Released
SUSE Linux Enterprise Server 11 SP3 LTSS postgresql Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS postgresql94 Unsupported
SUSE Linux Enterprise Server 11 SP4 LTSS postgresql94 Affected
SUSE Linux Enterprise Server 12 GA LTSS postgresql94 Unsupported
SUSE Linux Enterprise Server 12 GA LTSS postgresql96 Unsupported
SUSE Linux Enterprise Server 12 SP1 LTSS postgresql94 Released
SUSE Linux Enterprise Server 12 SP1 LTSS postgresql96 Released
SUSE Linux Enterprise Server 12 SP2 LTSS postgresql94 Released
SUSE Linux Enterprise Server 12 SP2 LTSS postgresql96 Released
SUSE Linux Enterprise Server 12 SP3 postgresql10 Affected
SUSE Linux Enterprise Server 12 SP3 postgresql96 Unsupported
SUSE Linux Enterprise Server 12 SP3 LTSS postgresql96 Released
SUSE Linux Enterprise Server 12 SP4 postgresql10 Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 postgresql Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 postgresql94 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 GA postgresql94 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP2 postgresql94 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 postgresql96 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 postgresql10 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 postgresql96 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 postgresql10 Released