Upstream information

CVE-2019-10143 at MITRE

Description

** DISPUTED ** It was discovered freeradius up to and including version 3.0.19 does not correctly configure logrotate, allowing a local attacker who already has control of the radiusd user to escalate his privileges to root, by tricking logrotate into writing a radiusd-writable file to a directory normally inaccessible by the radiusd user. NOTE: the upstream software maintainer has stated "there is simply no way for anyone to gain privileges through this alleged issue."

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.9
Vector AV:L/AC:M/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7 6.4
Vector CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
Access Vector Local Local
Access Complexity High High
Privileges Required Low High
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1136195 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Performance Computing 12 freeradius-server Affected
SUSE Linux Enterprise Module for Server Applications 15 GA freeradius-server Already fixed
SUSE Linux Enterprise SDK 12 SP3 freeradius-server Already fixed
SUSE Linux Enterprise SDK 12 SP4 freeradius-server Affected
SUSE Linux Enterprise Server 11 SP3 LTSS freeradius-server Already fixed
SUSE Linux Enterprise Server 11 SP4 LTSS freeradius-server Already fixed
SUSE Linux Enterprise Server 12 GA LTSS freeradius-server Already fixed
SUSE Linux Enterprise Server 12 SP1 LTSS freeradius-server Already fixed
SUSE Linux Enterprise Server 12 SP2 LTSS freeradius-server Already fixed
SUSE Linux Enterprise Server 12 SP3 freeradius-server Already fixed
SUSE Linux Enterprise Server 12 SP4 freeradius-server Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 freeradius-server Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 GA freeradius-server Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP2 freeradius-server Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP3 freeradius-server Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 freeradius-server Affected