Upstream information

CVE-2019-1002101 at MITRE

Description

The kubectl cp command allows copying files between containers and the user machine. To copy files from a container, Kubernetes creates a tar inside the container, copies it over the network, and kubectl unpacks it on the user’s machine. If the tar binary in the container is malicious, it could run any code and output unexpected, malicious results. An attacker could use this to write files to any path on the user’s machine when kubectl cp is called, limited only by the system permissions of the local user. The untar function can both create and follow symbolic links. The issue is resolved in kubectl v1.11.9, v1.12.7, v1.13.5, and v1.14.0.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.8
Vector AV:N/AC:M/Au:N/C:N/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 5.3
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N
Attack Vector Local Network
Attack Complexity Low High
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact High High
Availability Impact None None
CVSSv3 Version 3 3
SUSE Bugzilla entries: 1131056 [RESOLVED / FIXED], 1138929 [RESOLVED / FIXED], 1144507 [REOPENED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • k3s >= 1.21.3+k3s1-1.2
Patchnames:
openSUSE Tumbleweed GA k3s-1.21.3+k3s1-1.2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise High Performance Computing 12 kubernetes Not affected
SUSE Linux Enterprise Module for Public Cloud 12 kubernetes Not affected
SUSE Linux Enterprise Server 12 SP5 kubernetes Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 kubernetes Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 SP1 kubernetes Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS kubernetes Released
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS kubernetes Released
SUSE Linux Enterprise Module for Containers 15 SP1 kubernetes Affected
SUSE Linux Enterprise Server 12 SP4 kubernetes Not affected
SUSE Linux Enterprise Server 15 SP1 kubernetes Affected
SUSE Linux Enterprise Server 15 SP1-LTSS kubernetes Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 kubernetes Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 kubernetes Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 kubernetes Affected
Products past their end of life and not receiving proactive updates anymore.
Magnum Orchestration 7 kubernetes Not affected
SUSE CaaS Platform 3.0 kubernetes Affected
SUSE CaaS Platform 4.0 kubernetes Released
SUSE CaaS Platform 4.5 kubernetes-1.18 Affected
SUSE Container as a Service Platform 1.0 kubernetes Affected
SUSE Container as a Service Platform 2.0 kubernetes Not affected
SUSE Enterprise Storage 6 kubernetes Released
SUSE Linux Enterprise Server 12 kubernetes Not affected
SUSE Linux Enterprise Server 12 SP3 kubernetes Not affected
SUSE Linux Enterprise Server 15 SP1-BCL kubernetes Affected
SUSE Linux Enterprise Server for SAP Applications 12 kubernetes Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 kubernetes Not affected
SUSE Manager Proxy 4.0 kubernetes Affected
SUSE Manager Retail Branch Server 4.0 kubernetes Affected
SUSE Manager Server 4.0 kubernetes Affected


SUSE Timeline for this CVE

CVE page created: Fri Mar 29 20:24:55 2019
CVE page last modified: Fri Feb 10 15:32:05 2023