Upstream information

CVE-2018-20533 at MITRE

Description

There is a NULL pointer dereference at ext/testcase.c (function testcase_str2dep_complex) in libsolvext.a in libsolv through 0.7.2 that will cause a denial of service.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 1120630 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • libsolv >= 0.6.36-2.27.19.8
  • libsolv-tools >= 0.6.36-2.27.19.8
  • libzypp >= 16.20.2-27.60.4
  • perl-solv >= 0.6.36-2.27.19.8
  • python-solv >= 0.6.36-2.27.19.8
  • zypper >= 1.13.54-18.40.2
  • zypper-log >= 1.13.54-18.40.2
Patchnames:
HPE-Helion-OpenStack-8-2019-2265
SUSE CaaS Platform 3.0
  • libsolv >= 0.6.36-2.27.19.8
  • libsolv-tools >= 0.6.36-2.27.19.8
  • libzypp >= 16.20.2-27.60.4
  • zypper >= 1.13.54-18.40.2
Patchnames:
SUSE-CAASP-3.0-2019-1972
SUSE-CAASP-3.0-2019-2265
SUSE Enterprise Storage 4
  • libsolv >= 0.6.36-2.27.19.8
  • libsolv-tools >= 0.6.36-2.27.19.8
  • libzypp >= 16.20.2-27.60.4
  • perl-solv >= 0.6.36-2.27.19.8
  • python-solv >= 0.6.36-2.27.19.8
  • zypper >= 1.13.54-18.40.2
  • zypper-log >= 1.13.54-18.40.2
Patchnames:
SUSE-Storage-4-2019-2265
SUSE Enterprise Storage 5
  • libsolv >= 0.6.36-2.27.19.8
  • libsolv-tools >= 0.6.36-2.27.19.8
  • libzypp >= 16.20.2-27.60.4
  • perl-solv >= 0.6.36-2.27.19.8
  • python-solv >= 0.6.36-2.27.19.8
  • zypper >= 1.13.54-18.40.2
  • zypper-log >= 1.13.54-18.40.2
Patchnames:
SUSE-Storage-5-2019-1972
SUSE-Storage-5-2019-2265
SUSE Linux Enterprise Desktop 12 SP4
  • libsolv >= 0.6.36-2.27.19.8
  • libsolv-tools >= 0.6.36-2.27.19.8
  • libzypp >= 16.20.2-27.60.4
  • python-solv >= 0.6.36-2.27.19.8
  • zypper >= 1.13.54-18.40.2
  • zypper-log >= 1.13.54-18.40.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-1972
SUSE-SLE-DESKTOP-12-SP4-2019-2265
SUSE Linux Enterprise Installer Updates 15
  • libsolv >= 0.7.5-3.12.2
  • libsolv-tools >= 0.7.5-3.12.2
  • libyui-ncurses-pkg >= 2.48.5.2-3.5.2
  • libyui-ncurses-pkg8 >= 2.48.5.2-3.5.2
  • libyui-qt-pkg >= 2.45.15.2-3.5.3
  • libyui-qt-pkg8 >= 2.45.15.2-3.5.3
  • libzypp >= 17.12.0-3.23.6
  • yast2-pkg-bindings >= 4.0.13-3.7.2
  • zypper >= 1.14.28-3.18.6
Patchnames:
SUSE-SLE-INSTALLER-15-2019-2030
SUSE Linux Enterprise Module for Basesystem 15
  • libsolv >= 0.7.5-3.12.2
  • libsolv-devel >= 0.7.5-3.12.2
  • libsolv-tools >= 0.7.5-3.12.2
  • libyui-ncurses-pkg >= 2.48.5.2-3.5.2
  • libyui-ncurses-pkg-devel >= 2.48.5.2-3.5.2
  • libyui-ncurses-pkg-doc >= 2.48.5.2-3.5.3
  • libyui-ncurses-pkg8 >= 2.48.5.2-3.5.2
  • libyui-qt-pkg >= 2.45.15.2-3.5.3
  • libyui-qt-pkg-doc >= 2.45.15.2-3.5.3
  • libyui-qt-pkg8 >= 2.45.15.2-3.5.3
  • libzypp >= 17.12.0-3.23.6
  • libzypp-devel >= 17.12.0-3.23.6
  • python-solv >= 0.7.5-3.12.2
  • yast2-pkg-bindings >= 4.0.13-3.7.2
  • zypper >= 1.14.28-3.18.6
  • zypper-log >= 1.14.28-3.18.6
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-2030
SUSE Linux Enterprise Module for Desktop Applications 15
  • PackageKit >= 1.1.10-4.10.4
  • PackageKit-backend-zypp >= 1.1.10-4.10.4
  • PackageKit-devel >= 1.1.10-4.10.4
  • PackageKit-lang >= 1.1.10-4.10.4
  • libpackagekit-glib2-18 >= 1.1.10-4.10.4
  • libpackagekit-glib2-devel >= 1.1.10-4.10.4
  • libyui-qt-pkg >= 2.45.15.2-3.5.3
  • libyui-qt-pkg-devel >= 2.45.15.2-3.5.3
  • typelib-1_0-PackageKitGlib-1_0 >= 1.1.10-4.10.4
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2019-2030
SUSE Linux Enterprise Module for Development Tools 15
  • libsolv >= 0.7.5-3.12.2
  • perl-solv >= 0.7.5-3.12.2
  • python3-solv >= 0.7.5-3.12.2
  • ruby-solv >= 0.7.5-3.12.2
Patchnames:
SUSE-SLE-Module-Development-Tools-15-2019-2030
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • PackageKit >= 1.1.10-4.10.4
  • PackageKit-branding-upstream >= 1.1.10-4.10.4
  • libsolv >= 0.7.5-3.12.2
  • libsolv-demo >= 0.7.5-3.12.2
  • libzypp >= 17.12.0-3.23.6
  • libzypp-devel-doc >= 17.12.0-3.23.6
  • yast2-pkg-bindings-devel-doc >= 4.0.13-3.7.2
  • zypper >= 1.14.28-3.18.6
  • zypper-aptitude >= 1.14.28-3.18.6
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-2030
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • libsolv >= 0.7.5-3.12.2
  • libsolv-demo >= 0.7.5-3.12.2
  • libyui-ncurses-pkg >= 2.48.5.2-3.5.2
  • libyui-ncurses-pkg8 >= 2.48.5.2-3.5.2
  • libyui-qt-pkg >= 2.45.15.2-3.5.3
  • libyui-qt-pkg8 >= 2.45.15.2-3.5.3
  • libzypp >= 17.12.0-3.23.6
  • libzypp-devel-doc >= 17.12.0-3.23.6
  • python-solv >= 0.7.5-3.12.2
  • zypper >= 1.14.28-3.18.6
  • zypper-aptitude >= 1.14.28-3.18.6
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2030
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • libsolv >= 0.6.36-2.27.19.8
  • libsolv-tools >= 0.6.36-2.27.19.8
  • libzypp >= 16.20.2-27.60.4
  • perl-solv >= 0.6.36-2.27.19.8
  • python-solv >= 0.6.36-2.27.19.8
  • zypper >= 1.13.54-18.40.2
  • zypper-log >= 1.13.54-18.40.2
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2019-2265
SUSE Linux Enterprise Server 12 SP2-BCL
  • libsolv >= 0.6.36-2.27.19.8
  • libsolv-tools >= 0.6.36-2.27.19.8
  • libzypp >= 16.20.2-27.60.4
  • perl-solv >= 0.6.36-2.27.19.8
  • python-solv >= 0.6.36-2.27.19.8
  • zypper >= 1.13.54-18.40.2
  • zypper-log >= 1.13.54-18.40.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-2265
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • libsolv >= 0.6.36-2.27.19.8
  • libsolv-tools >= 0.6.36-2.27.19.8
  • libzypp >= 16.20.2-27.60.4
  • perl-solv >= 0.6.36-2.27.19.8
  • python-solv >= 0.6.36-2.27.19.8
  • zypper >= 1.13.54-18.40.2
  • zypper-log >= 1.13.54-18.40.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-2265
SUSE Linux Enterprise Server 12 SP2-LTSS
  • libsolv >= 0.6.36-2.27.19.8
  • libsolv-tools >= 0.6.36-2.27.19.8
  • libzypp >= 16.20.2-27.60.4
  • perl-solv >= 0.6.36-2.27.19.8
  • python-solv >= 0.6.36-2.27.19.8
  • zypper >= 1.13.54-18.40.2
  • zypper-log >= 1.13.54-18.40.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-2265
SUSE Linux Enterprise Server 12 SP3-BCL
  • libsolv >= 0.6.36-2.27.19.8
  • libsolv-tools >= 0.6.36-2.27.19.8
  • libzypp >= 16.20.2-27.60.4
  • perl-solv >= 0.6.36-2.27.19.8
  • python-solv >= 0.6.36-2.27.19.8
  • zypper >= 1.13.54-18.40.2
  • zypper-log >= 1.13.54-18.40.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2019-2265
SUSE Linux Enterprise Server 12 SP3-ESPOS
  • libsolv >= 0.6.36-2.27.19.8
  • libsolv-tools >= 0.6.36-2.27.19.8
  • libzypp >= 16.20.2-27.60.4
  • perl-solv >= 0.6.36-2.27.19.8
  • python-solv >= 0.6.36-2.27.19.8
  • zypper >= 1.13.54-18.40.2
  • zypper-log >= 1.13.54-18.40.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2019-2265
SUSE Linux Enterprise Server 12 SP3-LTSS
  • libsolv >= 0.6.36-2.27.19.8
  • libsolv-tools >= 0.6.36-2.27.19.8
  • libzypp >= 16.20.2-27.60.4
  • perl-solv >= 0.6.36-2.27.19.8
  • python-solv >= 0.6.36-2.27.19.8
  • zypper >= 1.13.54-18.40.2
  • zypper-log >= 1.13.54-18.40.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-1972
SUSE-SLE-SERVER-12-SP3-2019-2265
SUSE Linux Enterprise Server 12 SP4
  • libsolv >= 0.6.36-2.27.19.8
  • libsolv-tools >= 0.6.36-2.27.19.8
  • libzypp >= 16.20.2-27.60.4
  • perl-solv >= 0.6.36-2.27.19.8
  • python-solv >= 0.6.36-2.27.19.8
  • zypper >= 1.13.54-18.40.2
  • zypper-log >= 1.13.54-18.40.2
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-1972
SUSE-SLE-SERVER-12-SP4-2019-2265
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libsolv >= 0.6.36-2.27.19.8
  • libsolv-tools >= 0.6.36-2.27.19.8
  • libzypp >= 16.20.2-27.60.4
  • perl-solv >= 0.6.36-2.27.19.8
  • python-solv >= 0.6.36-2.27.19.8
  • zypper >= 1.13.54-18.40.2
  • zypper-log >= 1.13.54-18.40.2
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-2265
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • libsolv >= 0.6.36-2.27.19.8
  • libsolv-tools >= 0.6.36-2.27.19.8
  • libzypp >= 16.20.2-27.60.4
  • perl-solv >= 0.6.36-2.27.19.8
  • python-solv >= 0.6.36-2.27.19.8
  • zypper >= 1.13.54-18.40.2
  • zypper-log >= 1.13.54-18.40.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-2265
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • libsolv >= 0.6.36-2.27.19.8
  • libsolv-tools >= 0.6.36-2.27.19.8
  • libzypp >= 16.20.2-27.60.4
  • perl-solv >= 0.6.36-2.27.19.8
  • python-solv >= 0.6.36-2.27.19.8
  • zypper >= 1.13.54-18.40.2
  • zypper-log >= 1.13.54-18.40.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-2265
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • libsolv >= 0.6.36-2.27.19.8
  • libsolv-tools >= 0.6.36-2.27.19.8
  • libzypp >= 16.20.2-27.60.4
  • perl-solv >= 0.6.36-2.27.19.8
  • python-solv >= 0.6.36-2.27.19.8
  • zypper >= 1.13.54-18.40.2
  • zypper-log >= 1.13.54-18.40.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-2265
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libsolv >= 0.6.36-2.27.19.8
  • libsolv-tools >= 0.6.36-2.27.19.8
  • libzypp >= 16.20.2-27.60.4
  • perl-solv >= 0.6.36-2.27.19.8
  • python-solv >= 0.6.36-2.27.19.8
  • zypper >= 1.13.54-18.40.2
  • zypper-log >= 1.13.54-18.40.2
Patchnames:
SUSE-SLE-SAP-12-SP3-2019-1972
SUSE-SLE-SAP-12-SP3-2019-2265
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • libsolv >= 0.6.36-2.27.19.8
  • libsolv-tools >= 0.6.36-2.27.19.8
  • libzypp >= 16.20.2-27.60.4
  • perl-solv >= 0.6.36-2.27.19.8
  • python-solv >= 0.6.36-2.27.19.8
  • zypper >= 1.13.54-18.40.2
  • zypper-log >= 1.13.54-18.40.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2019-2265
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • libsolv >= 0.6.36-2.27.19.8
  • libsolv-tools >= 0.6.36-2.27.19.8
  • libzypp >= 16.20.2-27.60.4
  • perl-solv >= 0.6.36-2.27.19.8
  • python-solv >= 0.6.36-2.27.19.8
  • zypper >= 1.13.54-18.40.2
  • zypper-log >= 1.13.54-18.40.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2019-2265
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • libsolv >= 0.6.36-2.27.19.8
  • libsolv-tools >= 0.6.36-2.27.19.8
  • libzypp >= 16.20.2-27.60.4
  • perl-solv >= 0.6.36-2.27.19.8
  • python-solv >= 0.6.36-2.27.19.8
  • zypper >= 1.13.54-18.40.2
  • zypper-log >= 1.13.54-18.40.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-1972
SUSE-SLE-SERVER-12-SP3-2019-2265
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libsolv >= 0.6.36-2.27.19.8
  • libsolv-tools >= 0.6.36-2.27.19.8
  • libzypp >= 16.20.2-27.60.4
  • perl-solv >= 0.6.36-2.27.19.8
  • python-solv >= 0.6.36-2.27.19.8
  • zypper >= 1.13.54-18.40.2
  • zypper-log >= 1.13.54-18.40.2
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-1972
SUSE-SLE-SERVER-12-SP4-2019-2265
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libsolv >= 0.6.36-2.16.2
  • libsolv-devel >= 0.6.36-2.16.2
  • libzypp >= 16.20.0-2.39.4
  • libzypp-devel >= 16.20.0-2.39.4
  • libzypp-devel-doc >= 16.20.0-2.39.4
  • perl-solv >= 0.6.36-2.16.2
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-1972
SUSE Linux Enterprise Workstation Extension 15
  • PackageKit >= 1.1.10-4.10.4
  • PackageKit-gstreamer-plugin >= 1.1.10-4.10.4
  • PackageKit-gtk3-module >= 1.1.10-4.10.4
Patchnames:
SUSE-SLE-Product-WE-15-2019-2030
SUSE OpenStack Cloud 7
  • libsolv >= 0.6.36-2.27.19.8
  • libsolv-tools >= 0.6.36-2.27.19.8
  • libzypp >= 16.20.2-27.60.4
  • perl-solv >= 0.6.36-2.27.19.8
  • python-solv >= 0.6.36-2.27.19.8
  • zypper >= 1.13.54-18.40.2
  • zypper-log >= 1.13.54-18.40.2
Patchnames:
SUSE-OpenStack-Cloud-7-2019-2265
SUSE OpenStack Cloud 8
  • libsolv >= 0.6.36-2.27.19.8
  • libsolv-tools >= 0.6.36-2.27.19.8
  • libzypp >= 16.20.2-27.60.4
  • perl-solv >= 0.6.36-2.27.19.8
  • python-solv >= 0.6.36-2.27.19.8
  • zypper >= 1.13.54-18.40.2
  • zypper-log >= 1.13.54-18.40.2
Patchnames:
SUSE-OpenStack-Cloud-8-2019-1972
SUSE-OpenStack-Cloud-8-2019-2265
SUSE OpenStack Cloud Crowbar 8
  • libsolv >= 0.6.36-2.27.19.8
  • libsolv-tools >= 0.6.36-2.27.19.8
  • libzypp >= 16.20.2-27.60.4
  • perl-solv >= 0.6.36-2.27.19.8
  • python-solv >= 0.6.36-2.27.19.8
  • zypper >= 1.13.54-18.40.2
  • zypper-log >= 1.13.54-18.40.2
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2019-2265
openSUSE Leap 15.0
  • PackageKit >= 1.1.10-lp150.11.1
  • PackageKit-backend-zypp >= 1.1.10-lp150.11.1
  • PackageKit-backend-zypp-debuginfo >= 1.1.10-lp150.11.1
  • PackageKit-branding-upstream >= 1.1.10-lp150.11.1
  • PackageKit-debuginfo >= 1.1.10-lp150.11.1
  • PackageKit-debugsource >= 1.1.10-lp150.11.1
  • PackageKit-devel >= 1.1.10-lp150.11.1
  • PackageKit-devel-debuginfo >= 1.1.10-lp150.11.1
  • PackageKit-gstreamer-plugin >= 1.1.10-lp150.11.1
  • PackageKit-gstreamer-plugin-debuginfo >= 1.1.10-lp150.11.1
  • PackageKit-gtk3-module >= 1.1.10-lp150.11.1
  • PackageKit-gtk3-module-debuginfo >= 1.1.10-lp150.11.1
  • PackageKit-lang >= 1.1.10-lp150.11.1
  • libpackagekit-glib2-18 >= 1.1.10-lp150.11.1
  • libpackagekit-glib2-18-32bit >= 1.1.10-lp150.11.1
  • libpackagekit-glib2-18-32bit-debuginfo >= 1.1.10-lp150.11.1
  • libpackagekit-glib2-18-debuginfo >= 1.1.10-lp150.11.1
  • libpackagekit-glib2-devel >= 1.1.10-lp150.11.1
  • libpackagekit-glib2-devel-32bit >= 1.1.10-lp150.11.1
  • libsolv >= 0.7.5-lp150.7.1
  • libsolv-debuginfo >= 0.7.5-lp150.7.1
  • libsolv-debugsource >= 0.7.5-lp150.7.1
  • libsolv-demo >= 0.7.5-lp150.7.1
  • libsolv-demo-debuginfo >= 0.7.5-lp150.7.1
  • libsolv-devel >= 0.7.5-lp150.7.1
  • libsolv-devel-debuginfo >= 0.7.5-lp150.7.1
  • libsolv-tools >= 0.7.5-lp150.7.1
  • libsolv-tools-debuginfo >= 0.7.5-lp150.7.1
  • libyui-ncurses-pkg >= 2.48.5.2-lp150.7.1
  • libyui-ncurses-pkg-debugsource >= 2.48.5.2-lp150.7.1
  • libyui-ncurses-pkg-devel >= 2.48.5.2-lp150.7.1
  • libyui-ncurses-pkg8 >= 2.48.5.2-lp150.7.1
  • libyui-ncurses-pkg8-debuginfo >= 2.48.5.2-lp150.7.1
  • libyui-qt-pkg >= 2.45.15.2-lp150.7.1
  • libyui-qt-pkg-debugsource >= 2.45.15.2-lp150.7.1
  • libyui-qt-pkg-devel >= 2.45.15.2-lp150.7.1
  • libyui-qt-pkg8 >= 2.45.15.2-lp150.7.1
  • libyui-qt-pkg8-debuginfo >= 2.45.15.2-lp150.7.1
  • libzypp >= 17.12.0-lp150.2.13.1
  • libzypp-debuginfo >= 17.12.0-lp150.2.13.1
  • libzypp-debugsource >= 17.12.0-lp150.2.13.1
  • libzypp-devel >= 17.12.0-lp150.2.13.1
  • libzypp-devel-doc >= 17.12.0-lp150.2.13.1
  • perl-solv >= 0.7.5-lp150.7.1
  • perl-solv-debuginfo >= 0.7.5-lp150.7.1
  • python-solv >= 0.7.5-lp150.7.1
  • python-solv-debuginfo >= 0.7.5-lp150.7.1
  • python3-solv >= 0.7.5-lp150.7.1
  • python3-solv-debuginfo >= 0.7.5-lp150.7.1
  • ruby-solv >= 0.7.5-lp150.7.1
  • ruby-solv-debuginfo >= 0.7.5-lp150.7.1
  • typelib-1_0-PackageKitGlib-1_0 >= 1.1.10-lp150.11.1
  • yast2-pkg-bindings >= 4.0.13-lp150.2.13.1
  • yast2-pkg-bindings-debuginfo >= 4.0.13-lp150.2.13.1
  • yast2-pkg-bindings-debugsource >= 4.0.13-lp150.2.13.1
  • zypper >= 1.14.28-lp150.2.13.1
  • zypper-aptitude >= 1.14.28-lp150.2.13.1
  • zypper-debuginfo >= 1.14.28-lp150.2.13.1
  • zypper-debugsource >= 1.14.28-lp150.2.13.1
  • zypper-log >= 1.14.28-lp150.2.13.1
  • zypper-needs-restarting >= 1.14.28-lp150.2.13.1
Patchnames:
openSUSE-2019-1927

List of packages in QA

Product(s) Package(s)
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libyui-ncurses-pkg >= 2.48.9-7.2.14
  • libyui-ncurses-pkg-debugsource >= 2.48.9-7.2.14
  • libyui-ncurses-pkg-devel >= 2.48.9-7.2.14
  • libyui-ncurses-pkg-doc >= 2.48.9-7.2.12
  • libyui-ncurses-pkg9 >= 2.48.9-7.2.14
  • libyui-ncurses-pkg9-debuginfo >= 2.48.9-7.2.14
  • libyui-qt-pkg >= 2.45.27-3.2.15
  • libyui-qt-pkg-debugsource >= 2.45.27-3.2.15
  • libyui-qt-pkg-doc >= 2.45.27-3.2.12
  • libyui-qt-pkg9 >= 2.45.27-3.2.15
  • libyui-qt-pkg9-debuginfo >= 2.45.27-3.2.15
  • yast2-pkg-bindings >= 4.1.2-3.2.14
  • yast2-pkg-bindings-debuginfo >= 4.1.2-3.2.14
  • yast2-pkg-bindings-debugsource >= 4.1.2-3.2.14
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • PackageKit >= 1.1.10-12.4.1
  • PackageKit-backend-zypp >= 1.1.10-12.4.1
  • PackageKit-backend-zypp-debuginfo >= 1.1.10-12.4.1
  • PackageKit-debuginfo >= 1.1.10-12.4.1
  • PackageKit-debugsource >= 1.1.10-12.4.1
  • PackageKit-devel >= 1.1.10-12.4.1
  • PackageKit-devel-debuginfo >= 1.1.10-12.4.1
  • PackageKit-lang >= 1.1.10-12.4.1
  • libpackagekit-glib2-18 >= 1.1.10-12.4.1
  • libpackagekit-glib2-18-debuginfo >= 1.1.10-12.4.1
  • libpackagekit-glib2-devel >= 1.1.10-12.4.1
  • libyui-qt-pkg >= 2.45.27-3.2.15
  • libyui-qt-pkg-debugsource >= 2.45.27-3.2.15
  • libyui-qt-pkg-devel >= 2.45.27-3.2.15
  • typelib-1_0-PackageKitGlib-1_0 >= 1.1.10-12.4.1
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • libsolv >= 0.7.5-3.7.10
  • libsolv-debuginfo >= 0.7.5-3.7.10
  • libsolv-debugsource >= 0.7.5-3.7.10
  • perl-solv >= 0.7.5-3.7.10
  • perl-solv-debuginfo >= 0.7.5-3.7.10
  • ruby-solv >= 0.7.5-3.7.10
  • ruby-solv-debuginfo >= 0.7.5-3.7.10
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • PackageKit >= 1.1.10-12.4.1
  • PackageKit-branding-upstream >= 1.1.10-12.4.1
  • PackageKit-debugsource >= 1.1.10-12.4.1
  • libpackagekit-glib2-18-32bit >= 1.1.10-12.4.1
  • libpackagekit-glib2-18-32bit-debuginfo >= 1.1.10-12.4.1
  • libpackagekit-glib2-devel-32bit >= 1.1.10-12.4.1
  • yast2-pkg-bindings-devel-doc >= 4.1.2-3.2.14
SUSE Linux Enterprise Workstation Extension 15 SP1
  • PackageKit >= 1.1.10-12.4.1
  • PackageKit-debuginfo >= 1.1.10-12.4.1
  • PackageKit-debugsource >= 1.1.10-12.4.1
  • PackageKit-gstreamer-plugin >= 1.1.10-12.4.1
  • PackageKit-gstreamer-plugin-debuginfo >= 1.1.10-12.4.1
  • PackageKit-gtk3-module >= 1.1.10-12.4.1
  • PackageKit-gtk3-module-debuginfo >= 1.1.10-12.4.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 libsolv Not affected
CaaS Platform 3.0 libsolv Released
OpenStack Cloud Magnum Orchestration 7.0 libsolv Not affected
SUSE Linux Enterprise Desktop 12 SP3 libsolv Not affected
SUSE Linux Enterprise Desktop 12 SP4 libsolv Released
SUSE Linux Enterprise High Performance Computing 12 libsolv Released
SUSE Linux Enterprise Module for Basesystem 15 GA libsolv Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 libsolv In progress
SUSE Linux Enterprise Module for Development Tools 15 GA libsolv Released
SUSE Linux Enterprise Module for Development Tools 15 SP1 libsolv In progress
SUSE Linux Enterprise SDK 12 SP3 libsolv Not affected
SUSE Linux Enterprise SDK 12 SP4 libsolv Released
SUSE Linux Enterprise Server 12 GA LTSS libsolv Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS libsolv Released
SUSE Linux Enterprise Server 12 SP3 libsolv Not affected
SUSE Linux Enterprise Server 12 SP4 libsolv Released
SUSE Linux Enterprise Server for SAP Applications 12 GA libsolv Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libsolv Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libsolv Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libsolv Released