Upstream information

CVE-2018-19568 at MITRE

Description

A floating point exception in kodak_radc_load_raw in dcraw through 9.28 could be used by attackers able to supply malicious files to crash an application that bundles the dcraw code.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 5.5
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Attack Vector Local Local
Attack Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1117436 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Package Hub 15 SP5
  • dcraw >= 9.28.0-150000.3.3.1
Patchnames:
SUSE Linux Enterprise Module for Package Hub 15 SP5 GA dcraw-9.28.0-150000.3.3.1
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • dcraw >= 9.28.0-3.3.1
  • dcraw-lang >= 9.28.0-3.3.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2022-1749
SUSE-SLE-WE-12-SP5-2022-1749
SUSE Linux Enterprise Software Development Kit 12 SP5
  • dcraw >= 9.28.0-3.3.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2022-1749
SUSE Linux Enterprise Workstation Extension 12 SP5
  • dcraw >= 9.28.0-3.3.1
  • dcraw-lang >= 9.28.0-3.3.1
Patchnames:
SUSE-SLE-WE-12-SP5-2022-1749
openSUSE Leap 15.3
  • dcraw >= 9.28.0-150000.3.3.1
  • dcraw-lang >= 9.28.0-150000.3.3.1
Patchnames:
openSUSE-SLE-15.3-2022-1277
openSUSE Tumbleweed
  • dcraw >= 9.28.0-2.1
  • dcraw-lang >= 9.28.0-2.1
Patchnames:
openSUSE Tumbleweed GA dcraw-9.28.0-2.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise Desktop 15 SP5 libraw Not affected
SUSE Linux Enterprise High Performance Computing 15 SP5 libraw Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP5 libraw Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP4 dcraw Affected
SUSE Linux Enterprise Module for Package Hub 15 SP4 libraw Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP5 dcraw Released
SUSE Linux Enterprise Module for Package Hub 15 SP5 libraw Not affected
SUSE Linux Enterprise Server 12 SP5 dcraw Released
SUSE Linux Enterprise Server 12 SP5 libraw Not affected
SUSE Linux Enterprise Server 15 SP5 libraw Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 dcraw Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libraw Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 libraw Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP5 libraw Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 dcraw Released
SUSE Linux Enterprise Software Development Kit 12 SP5 libraw Not affected
SUSE Linux Enterprise Workstation Extension 12 SP5 dcraw Released
SUSE Linux Enterprise Workstation Extension 12 SP5 libraw Not affected
SUSE Linux Enterprise Workstation Extension 15 SP5 libraw Not affected
SUSE Manager Proxy 4.3 libraw Not affected
SUSE Manager Retail Branch Server 4.3 libraw Not affected
SUSE Manager Server 4.3 libraw Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 libraw Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 libraw Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS libraw Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS libraw Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 libraw Not affected
SUSE Linux Enterprise Server 15 SP2 libraw Not affected
SUSE Linux Enterprise Server 15 SP3 libraw Not affected
SUSE Linux Enterprise Server 15 SP4 libraw Not affected
SUSE Linux Enterprise Server 15 SP4-LTSS libraw Not affected
SUSE Linux Enterprise Server for SAP Applications 15 libraw Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 libraw Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 libraw Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 libraw Not affected
Products past their end of life and not receiving proactive updates anymore.
SUSE Linux Enterprise Desktop 11 SP4 dcraw Unsupported
SUSE Linux Enterprise Desktop 12 dcraw Affected
SUSE Linux Enterprise Desktop 12 libraw Not affected
SUSE Linux Enterprise Desktop 12 SP1 dcraw Affected
SUSE Linux Enterprise Desktop 12 SP1 libraw Not affected
SUSE Linux Enterprise Desktop 12 SP2 dcraw Affected
SUSE Linux Enterprise Desktop 12 SP2 libraw Not affected
SUSE Linux Enterprise Desktop 12 SP3 dcraw Unsupported
SUSE Linux Enterprise Desktop 12 SP3 libraw Not affected
SUSE Linux Enterprise Desktop 12 SP4 dcraw Unsupported
SUSE Linux Enterprise Desktop 12 SP4 libraw Not affected
SUSE Linux Enterprise Desktop 15 libraw Not affected
SUSE Linux Enterprise Desktop 15 SP1 libraw Not affected
SUSE Linux Enterprise Desktop 15 SP2 libraw Not affected
SUSE Linux Enterprise Desktop 15 SP3 libraw Not affected
SUSE Linux Enterprise Real Time 15 SP4 libraw Not affected
SUSE Linux Enterprise Server 11 SP4 dcraw Unsupported
SUSE Linux Enterprise Server 12 dcraw Affected
SUSE Linux Enterprise Server 12 libraw Not affected
SUSE Linux Enterprise Server 12 SP1 dcraw Affected
SUSE Linux Enterprise Server 12 SP1 libraw Not affected
SUSE Linux Enterprise Server 12 SP2 dcraw Affected
SUSE Linux Enterprise Server 12 SP2 libraw Not affected
SUSE Linux Enterprise Server 12 SP3 dcraw Unsupported
SUSE Linux Enterprise Server 12 SP3 libraw Not affected
SUSE Linux Enterprise Server 12 SP4 dcraw Unsupported
SUSE Linux Enterprise Server 12 SP4 libraw Not affected
SUSE Linux Enterprise Server 15 libraw Not affected
SUSE Linux Enterprise Server 15 SP1 libraw Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 dcraw Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 dcraw Affected
SUSE Linux Enterprise Server for SAP Applications 12 libraw Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 dcraw Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 libraw Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 dcraw Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libraw Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 dcraw Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libraw Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 dcraw Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libraw Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 dcraw Unsupported
SUSE Linux Enterprise Software Development Kit 12 dcraw Affected
SUSE Linux Enterprise Software Development Kit 12 libraw Not affected
SUSE Linux Enterprise Software Development Kit 12 SP1 dcraw Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 libraw Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 dcraw Affected
SUSE Linux Enterprise Software Development Kit 12 SP2 libraw Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 dcraw Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP3 libraw Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 dcraw Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP4 libraw Not affected
SUSE Linux Enterprise Workstation Extension 12 dcraw Affected
SUSE Linux Enterprise Workstation Extension 12 libraw Not affected
SUSE Linux Enterprise Workstation Extension 12 SP1 dcraw Affected
SUSE Linux Enterprise Workstation Extension 12 SP1 libraw Not affected
SUSE Linux Enterprise Workstation Extension 12 SP2 dcraw Affected
SUSE Linux Enterprise Workstation Extension 12 SP2 libraw Not affected
SUSE Linux Enterprise Workstation Extension 12 SP3 dcraw Unsupported
SUSE Linux Enterprise Workstation Extension 12 SP3 libraw Not affected
SUSE Linux Enterprise Workstation Extension 12 SP4 dcraw Unsupported
SUSE Linux Enterprise Workstation Extension 12 SP4 libraw Not affected
SUSE Linux Enterprise Workstation Extension 15 libraw Not affected
SUSE Linux Enterprise Workstation Extension 15 SP1 libraw Not affected
SUSE Linux Enterprise Workstation Extension 15 SP2 libraw Not affected
SUSE Linux Enterprise Workstation Extension 15 SP3 libraw Not affected
SUSE Linux Enterprise Workstation Extension 15 SP4 libraw Not affected


SUSE Timeline for this CVE

CVE page created: Tue Nov 27 03:04:06 2018
CVE page last modified: Thu Feb 22 17:01:44 2024