Upstream information

CVE-2018-18311 at MITRE

Description

Perl before 5.26.3 and 5.28.x before 5.28.1 has a buffer overflow via a crafted regular expression that triggers invalid write operations.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 7.4
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network Local
Access Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
SUSE Bugzilla entry: 1114674 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
HPE-Helion-OpenStack-8-2019-2264
SUSE CaaS Platform 3.0
  • perl >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
Patchnames:
SUSE-CAASP-3.0-2019-2264
SUSE Enterprise Storage 4
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
SUSE-Storage-4-2019-2264
SUSE Enterprise Storage 5
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
SUSE-Storage-5-2019-2264
SUSE Linux Enterprise Desktop 12 SP4
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-2264
SUSE Linux Enterprise Module for Basesystem 15
  • perl >= 5.26.1-7.6.1
  • perl-base >= 5.26.1-7.6.1
  • perl-base-32bit >= 5.26.1-7.6.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-2984
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • perl >= 5.26.1-7.6.1
  • perl-base >= 5.26.1-7.6.1
  • perl-base-32bit >= 5.26.1-7.6.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA perl
SUSE Linux Enterprise Module for Development Tools 15
  • perl >= 5.26.1-7.6.1
  • perl-doc >= 5.26.1-7.6.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-2018-2984
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • perl-doc >= 5.26.1-7.6.1
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 SP1 GA perl-doc
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2019-2264
SUSE Linux Enterprise Server 12 SP1-LTSS
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-2264
SUSE Linux Enterprise Server 12 SP2-BCL
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-2264
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-2264
SUSE Linux Enterprise Server 12 SP2-LTSS
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-2264
SUSE Linux Enterprise Server 12 SP3-BCL
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2019-2264
SUSE Linux Enterprise Server 12 SP3-ESPOS
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2019-2264
SUSE Linux Enterprise Server 12 SP3-LTSS
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-2264
SUSE Linux Enterprise Server 12 SP4
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-2264
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-2264
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-2264
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-2264
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-2264
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-2264
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-2264
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2019-2264
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2019-2264
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2019-2264
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-2264
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-2264
SUSE OpenStack Cloud 7
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-2264
SUSE OpenStack Cloud 8
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
SUSE-OpenStack-Cloud-8-2019-2264
SUSE OpenStack Cloud Crowbar 8
  • perl >= 5.18.2-12.20.1
  • perl-32bit >= 5.18.2-12.20.1
  • perl-base >= 5.18.2-12.20.1
  • perl-doc >= 5.18.2-12.20.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2019-2264
openSUSE Leap 15.0
  • perl >= 5.26.1-lp150.6.6.1
  • perl-32bit >= 5.26.1-lp150.6.6.1
  • perl-32bit-debuginfo >= 5.26.1-lp150.6.6.1
  • perl-base >= 5.26.1-lp150.6.6.1
  • perl-base-32bit >= 5.26.1-lp150.6.6.1
  • perl-base-32bit-debuginfo >= 5.26.1-lp150.6.6.1
  • perl-base-debuginfo >= 5.26.1-lp150.6.6.1
  • perl-debuginfo >= 5.26.1-lp150.6.6.1
  • perl-debugsource >= 5.26.1-lp150.6.6.1
  • perl-doc >= 5.26.1-lp150.6.6.1
Patchnames:
openSUSE-2019-1029


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 perl Affected
CaaS Platform 2.0 perl Affected
CaaS Platform 3.0 perl Released
OpenStack Cloud Magnum Orchestration 7.0 perl Affected
SUSE Linux Enterprise Desktop 12 SP3 perl Affected
SUSE Linux Enterprise Desktop 12 SP4 perl Released
SUSE Linux Enterprise High Performance Computing 12 perl Released
SUSE Linux Enterprise Module for Basesystem 15 GA perl Released
SUSE Linux Enterprise Module for Development Tools 15 GA perl Released
SUSE Linux Enterprise SDK 11 SP4 perl Affected
SUSE Linux Enterprise Server 11 SP3 LTSS perl Affected
SUSE Linux Enterprise Server 11 SP4 perl Affected
SUSE Linux Enterprise Server 12 GA LTSS perl Affected
SUSE Linux Enterprise Server 12 SP1 LTSS perl Released
SUSE Linux Enterprise Server 12 SP2 LTSS perl Released
SUSE Linux Enterprise Server 12 SP3 perl Affected
SUSE Linux Enterprise Server 12 SP3 LTSS perl Released
SUSE Linux Enterprise Server 12 SP4 perl Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 perl Affected
SUSE Linux Enterprise Server for SAP Applications 12 GA perl Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 perl Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 perl Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 perl Released