Upstream information

CVE-2018-14665 at MITRE

Description

A flaw was found in xorg-x11-server before 1.20.3. An incorrect permission check for -modulepath and -logfile options when starting Xorg. X server allows unprivileged users with the ability to log in to the system via physical console to escalate their privileges and run arbitrary code under root privileges.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  SUSE
Base Score 8.4
Vector AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High

Note from the SUSE Security Team

This attack requires setuid root X Server. Since SUSE Linux Enterprise 12 we are not shipping setuid root xservers anymore, so we are not affected by this problem. The fix will be included in future releases in case local administrators have given out setuid root bits to the X server.

SUSE Bugzilla entries: 1111697 [RESOLVED / FIXED], 1112020 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP4
  • xorg-x11-server >= 1.19.6-2.1
  • xorg-x11-server-extra >= 1.19.6-2.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA xorg-x11-server
SUSE Linux Enterprise Module for Basesystem 15
  • xorg-x11-server >= 1.19.6-8.3.2
  • xorg-x11-server-extra >= 1.19.6-8.3.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-2617
SUSE Linux Enterprise Module for Development Tools 15
  • xorg-x11-server >= 1.19.6-8.3.2
  • xorg-x11-server-sdk >= 1.19.6-8.3.2
Patchnames:
SUSE-SLE-Module-Development-Tools-15-2018-2617
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • xorg-x11-server >= 1.19.6-8.3.2
  • xorg-x11-server-source >= 1.19.6-8.3.2
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2018-2617
SUSE Linux Enterprise Point of Sale 11 SP3
  • xorg-x11-Xvnc >= 7.4-27.122.21.1
  • xorg-x11-server >= 7.4-27.122.21.1
  • xorg-x11-server-extra >= 7.4-27.122.21.1
Patchnames:
sleposp3-xorg-x11-server-13843
SUSE Linux Enterprise Server 11 SP3-LTSS
  • xorg-x11-Xvnc >= 7.4-27.122.21.1
  • xorg-x11-server >= 7.4-27.122.21.1
  • xorg-x11-server-extra >= 7.4-27.122.21.1
Patchnames:
slessp3-xorg-x11-server-13843
SUSE Linux Enterprise Server 11 SP4
  • xorg-x11-Xvnc >= 7.4-27.122.21.1
  • xorg-x11-server >= 7.4-27.122.21.1
  • xorg-x11-server-extra >= 7.4-27.122.21.1
Patchnames:
slessp4-xorg-x11-server-13843
SUSE Linux Enterprise Server 12 SP4
  • xorg-x11-server >= 1.19.6-2.1
  • xorg-x11-server-extra >= 1.19.6-2.1
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA xorg-x11-server
SUSE Linux Enterprise Server for SAP Applications 11 SP3-LTSS
  • xorg-x11-Xvnc >= 7.4-27.122.21.1
  • xorg-x11-server >= 7.4-27.122.21.1
  • xorg-x11-server-extra >= 7.4-27.122.21.1
Patchnames:
slessp3-xorg-x11-server-13843
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • xorg-x11-Xvnc >= 7.4-27.122.21.1
  • xorg-x11-server >= 7.4-27.122.21.1
  • xorg-x11-server-extra >= 7.4-27.122.21.1
Patchnames:
slessp4-xorg-x11-server-13843
SUSE Linux Enterprise Software Development Kit 11 SP4
  • xorg-x11-server >= 7.4-27.122.21.1
  • xorg-x11-server-sdk >= 7.4-27.122.21.1
Patchnames:
sdksp4-xorg-x11-server-13843
SUSE Linux Enterprise Software Development Kit 12 SP4
  • xorg-x11-server-sdk >= 1.19.6-2.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA xorg-x11-server-sdk
SUSE Linux Enterprise Workstation Extension 15
  • xorg-x11-server >= 1.19.6-8.3.2
  • xorg-x11-server-wayland >= 1.19.6-8.3.2
Patchnames:
SUSE-SLE-Product-WE-15-2018-2617
openSUSE Leap 15.0
  • xorg-x11-server >= 1.19.6-lp150.7.3.1
  • xorg-x11-server-debuginfo >= 1.19.6-lp150.7.3.1
  • xorg-x11-server-debugsource >= 1.19.6-lp150.7.3.1
  • xorg-x11-server-extra >= 1.19.6-lp150.7.3.1
  • xorg-x11-server-extra-debuginfo >= 1.19.6-lp150.7.3.1
  • xorg-x11-server-sdk >= 1.19.6-lp150.7.3.1
  • xorg-x11-server-source >= 1.19.6-lp150.7.3.1
  • xorg-x11-server-wayland >= 1.19.6-lp150.7.3.1
  • xorg-x11-server-wayland-debuginfo >= 1.19.6-lp150.7.3.1
Patchnames:
openSUSE-2018-1420


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 xorg-x11-server Not affected
SUSE Linux Enterprise Module for Basesystem 15 GA xorg-x11-server Released
SUSE Linux Enterprise Module for Development Tools 15 GA xorg-x11-server Released
SUSE Linux Enterprise SDK 11 SP4 xorg-x11-server Released
SUSE Linux Enterprise SDK 12 SP3 xorg-x11-server Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS xorg-x11-server Released
SUSE Linux Enterprise Server 11 SP4 xorg-x11-server Released
SUSE Linux Enterprise Server 12 GA LTSS xorg-x11-server Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS xorg-x11-server Not affected
SUSE Linux Enterprise Server 12 SP3 xorg-x11-server Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 xorg-x11-server Not affected
SUSE Linux Enterprise Server for SAP Applications 12 GA xorg-x11-server Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 xorg-x11-server Not affected
SUSE Linux Enterprise Workstation Extension 15 GA xorg-x11-server Released