Upstream information

CVE-2018-11237 at MITRE

Description

An AVX-512-optimized implementation of the mempcpy function in the GNU C Library (aka glibc or libc6) 2.27 and earlier may write data beyond the target buffer, leading to a buffer overflow in __mempcpy_avx512_no_vzeroupper.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having not set severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  SUSE
Base Score 5.6
Vector AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact Low
Availability Impact Low
SUSE Bugzilla entries: 1092877 [RESOLVED / DUPLICATE], 1094154 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • glibc >= 2.22-62.13.2
  • glibc-locale >= 2.22-62.13.2
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2018-1077
SUSE CaaS Platform ALL
  • glibc >= 2.22-62.13.2
  • glibc-locale >= 2.22-62.13.2
Patchnames:
SUSE-CAASP-ALL-2018-1077
SUSE Enterprise Storage 4
  • glibc >= 2.22-62.13.2
  • glibc-32bit >= 2.22-62.13.2
  • glibc-devel >= 2.22-62.13.2
  • glibc-devel-32bit >= 2.22-62.13.2
  • glibc-html >= 2.22-62.13.2
  • glibc-i18ndata >= 2.22-62.13.2
  • glibc-info >= 2.22-62.13.2
  • glibc-locale >= 2.22-62.13.2
  • glibc-locale-32bit >= 2.22-62.13.2
  • glibc-profile >= 2.22-62.13.2
  • glibc-profile-32bit >= 2.22-62.13.2
  • nscd >= 2.22-62.13.2
Patchnames:
SUSE-Storage-4-2018-1077
SUSE Linux Enterprise Desktop 12 SP3
  • glibc >= 2.22-62.13.2
  • glibc-32bit >= 2.22-62.13.2
  • glibc-devel >= 2.22-62.13.2
  • glibc-devel-32bit >= 2.22-62.13.2
  • glibc-i18ndata >= 2.22-62.13.2
  • glibc-locale >= 2.22-62.13.2
  • glibc-locale-32bit >= 2.22-62.13.2
  • nscd >= 2.22-62.13.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-1077
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • glibc >= 2.22-62.13.2
  • glibc-32bit >= 2.22-62.13.2
  • glibc-devel >= 2.22-62.13.2
  • glibc-devel-32bit >= 2.22-62.13.2
  • glibc-html >= 2.22-62.13.2
  • glibc-i18ndata >= 2.22-62.13.2
  • glibc-info >= 2.22-62.13.2
  • glibc-locale >= 2.22-62.13.2
  • glibc-locale-32bit >= 2.22-62.13.2
  • glibc-profile >= 2.22-62.13.2
  • glibc-profile-32bit >= 2.22-62.13.2
  • nscd >= 2.22-62.13.2
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2018-1077
SUSE Linux Enterprise Server 12 SP2-LTSS
  • glibc >= 2.22-62.13.2
  • glibc-32bit >= 2.22-62.13.2
  • glibc-devel >= 2.22-62.13.2
  • glibc-devel-32bit >= 2.22-62.13.2
  • glibc-html >= 2.22-62.13.2
  • glibc-i18ndata >= 2.22-62.13.2
  • glibc-info >= 2.22-62.13.2
  • glibc-locale >= 2.22-62.13.2
  • glibc-locale-32bit >= 2.22-62.13.2
  • glibc-profile >= 2.22-62.13.2
  • glibc-profile-32bit >= 2.22-62.13.2
  • nscd >= 2.22-62.13.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-1077
SUSE Linux Enterprise Server 12 SP3
  • glibc >= 2.22-62.13.2
  • glibc-32bit >= 2.22-62.13.2
  • glibc-devel >= 2.22-62.13.2
  • glibc-devel-32bit >= 2.22-62.13.2
  • glibc-html >= 2.22-62.13.2
  • glibc-i18ndata >= 2.22-62.13.2
  • glibc-info >= 2.22-62.13.2
  • glibc-locale >= 2.22-62.13.2
  • glibc-locale-32bit >= 2.22-62.13.2
  • glibc-profile >= 2.22-62.13.2
  • glibc-profile-32bit >= 2.22-62.13.2
  • nscd >= 2.22-62.13.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1077
SUSE Linux Enterprise Software Development Kit 12 SP3
  • glibc >= 2.22-62.13.2
  • glibc-devel-static >= 2.22-62.13.2
  • glibc-info >= 2.22-62.13.2
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-1077
SUSE Linux Enterprise for SAP 12 SP2
  • glibc >= 2.22-62.13.2
  • glibc-32bit >= 2.22-62.13.2
  • glibc-devel >= 2.22-62.13.2
  • glibc-devel-32bit >= 2.22-62.13.2
  • glibc-html >= 2.22-62.13.2
  • glibc-i18ndata >= 2.22-62.13.2
  • glibc-info >= 2.22-62.13.2
  • glibc-locale >= 2.22-62.13.2
  • glibc-locale-32bit >= 2.22-62.13.2
  • glibc-profile >= 2.22-62.13.2
  • glibc-profile-32bit >= 2.22-62.13.2
  • nscd >= 2.22-62.13.2
Patchnames:
SUSE-SLE-SAP-12-SP2-2018-1077
SUSE OpenStack Cloud 7
  • glibc >= 2.22-62.13.2
  • glibc-32bit >= 2.22-62.13.2
  • glibc-devel >= 2.22-62.13.2
  • glibc-devel-32bit >= 2.22-62.13.2
  • glibc-html >= 2.22-62.13.2
  • glibc-i18ndata >= 2.22-62.13.2
  • glibc-info >= 2.22-62.13.2
  • glibc-locale >= 2.22-62.13.2
  • glibc-locale-32bit >= 2.22-62.13.2
  • glibc-profile >= 2.22-62.13.2
  • glibc-profile-32bit >= 2.22-62.13.2
  • nscd >= 2.22-62.13.2
Patchnames:
SUSE-OpenStack-Cloud-7-2018-1077
openSUSE Leap 15.0
  • glibc >= 2.26-lp150.11.3.2
  • glibc-32bit >= 2.26-lp150.11.3.2
  • glibc-32bit-debuginfo >= 2.26-lp150.11.3.2
  • glibc-debuginfo >= 2.26-lp150.11.3.2
  • glibc-debugsource >= 2.26-lp150.11.3.2
  • glibc-devel >= 2.26-lp150.11.3.2
  • glibc-devel-32bit >= 2.26-lp150.11.3.2
  • glibc-devel-32bit-debuginfo >= 2.26-lp150.11.3.2
  • glibc-devel-debuginfo >= 2.26-lp150.11.3.2
  • glibc-devel-static >= 2.26-lp150.11.3.2
  • glibc-devel-static-32bit >= 2.26-lp150.11.3.2
  • glibc-extra >= 2.26-lp150.11.3.2
  • glibc-extra-debuginfo >= 2.26-lp150.11.3.2
  • glibc-html >= 2.26-lp150.11.3.2
  • glibc-i18ndata >= 2.26-lp150.11.3.2
  • glibc-info >= 2.26-lp150.11.3.2
  • glibc-locale >= 2.26-lp150.11.3.2
  • glibc-locale-32bit >= 2.26-lp150.11.3.2
  • glibc-locale-32bit-debuginfo >= 2.26-lp150.11.3.2
  • glibc-locale-debuginfo >= 2.26-lp150.11.3.2
  • glibc-profile >= 2.26-lp150.11.3.2
  • glibc-profile-32bit >= 2.26-lp150.11.3.2
  • glibc-testsuite-src >= 2.26-lp150.11.3.2
  • glibc-utils >= 2.26-lp150.11.3.2
  • glibc-utils-32bit >= 2.26-lp150.11.3.2
  • glibc-utils-32bit-debuginfo >= 2.26-lp150.11.3.2
  • glibc-utils-debuginfo >= 2.26-lp150.11.3.2
  • glibc-utils-src >= 2.26-lp150.11.3.2
  • glibc-utils-src-debugsource >= 2.26-lp150.11.3.2
  • nscd >= 2.26-lp150.11.3.2
  • nscd-debuginfo >= 2.26-lp150.11.3.2
Patchnames:
openSUSE-2018-600
openSUSE Leap 42.3
  • glibc >= 2.22-19.1
  • glibc-32bit >= 2.22-19.2
  • glibc-debuginfo >= 2.22-19.1
  • glibc-debuginfo-32bit >= 2.22-19.2
  • glibc-debugsource >= 2.22-19.1
  • glibc-devel >= 2.22-19.1
  • glibc-devel-32bit >= 2.22-19.2
  • glibc-devel-debuginfo >= 2.22-19.1
  • glibc-devel-debuginfo-32bit >= 2.22-19.2
  • glibc-devel-static >= 2.22-19.1
  • glibc-devel-static-32bit >= 2.22-19.2
  • glibc-extra >= 2.22-19.1
  • glibc-extra-debuginfo >= 2.22-19.1
  • glibc-html >= 2.22-19.1
  • glibc-i18ndata >= 2.22-19.1
  • glibc-info >= 2.22-19.1
  • glibc-locale >= 2.22-19.1
  • glibc-locale-32bit >= 2.22-19.2
  • glibc-locale-debuginfo >= 2.22-19.1
  • glibc-locale-debuginfo-32bit >= 2.22-19.2
  • glibc-obsolete >= 2.22-19.1
  • glibc-obsolete-debuginfo >= 2.22-19.1
  • glibc-profile >= 2.22-19.1
  • glibc-profile-32bit >= 2.22-19.2
  • glibc-testsuite >= 2.22-19.2
  • glibc-utils >= 2.22-19.1
  • glibc-utils-32bit >= 2.22-19.1
  • glibc-utils-debuginfo >= 2.22-19.1
  • glibc-utils-debuginfo-32bit >= 2.22-19.1
  • glibc-utils-debugsource >= 2.22-19.1
  • nscd >= 2.22-19.1
  • nscd-debuginfo >= 2.22-19.1
Patchnames:
openSUSE-2018-567

List of packages in QA

Product(s) Package(s)
SUSE Linux Enterprise Module for Basesystem 15
  • glibc >= 2.26-13.3.1
  • glibc-32bit >= 2.26-13.3.1
  • glibc-32bit-debuginfo >= 2.26-13.3.1
  • glibc-debuginfo >= 2.26-13.3.1
  • glibc-debugsource >= 2.26-13.3.1
  • glibc-devel >= 2.26-13.3.1
  • glibc-devel-debuginfo >= 2.26-13.3.1
  • glibc-extra >= 2.26-13.3.1
  • glibc-extra-debuginfo >= 2.26-13.3.1
  • glibc-i18ndata >= 2.26-13.3.1
  • glibc-info >= 2.26-13.3.1
  • glibc-locale >= 2.26-13.3.1
  • glibc-locale-32bit >= 2.26-13.3.1
  • glibc-locale-32bit-debuginfo >= 2.26-13.3.1
  • glibc-locale-debuginfo >= 2.26-13.3.1
  • glibc-profile >= 2.26-13.3.1
  • nscd >= 2.26-13.3.1
  • nscd-debuginfo >= 2.26-13.3.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 glibc Released
OpenStack Cloud Magnum Orchestration 7.0 glibc Released
SUSE Linux Enterprise Desktop 12 SP2 glibc Affected
SUSE Linux Enterprise Desktop 12 SP3 glibc Released
SUSE Linux Enterprise Module for Basesystem 15 GA glibc In progress
SUSE Linux Enterprise Module for Development Tools 15 GA glibc In progress
SUSE Linux Enterprise SDK 11 SP4 glibc Not affected
SUSE Linux Enterprise SDK 12 SP2 glibc Affected
SUSE Linux Enterprise SDK 12 SP3 glibc Released
SUSE Linux Enterprise Server 11 SP3 LTSS glibc Not affected
SUSE Linux Enterprise Server 11 SP4 glibc Not affected
SUSE Linux Enterprise Server 12 SP2 glibc Affected
SUSE Linux Enterprise Server 12 SP2 LTSS glibc Released
SUSE Linux Enterprise Server 12 SP3 glibc Released