Upstream information

CVE-2018-1059 at MITRE

Description

The DPDK vhost-user interface does not check to verify that all the requested guest physical range is mapped and contiguous when performing Guest Physical Addresses to Host Virtual Addresses translations. This may lead to a malicious guest exposing vhost-user backend process memory. All versions before 18.02.1 are vulnerable.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.9
Vector AV:A/AC:M/Au:N/C:P/I:N/A:N
Access Vector Adjacent Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.1
Vector CVSS:3.0/AV:A/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N
Access Vector Adjacent Network
Access Complexity High
Privileges Required None
User Interaction None
Scope Changed
Confidentiality Impact High
Integrity Impact None
Availability Impact None
CVSSv3 Version 3
SUSE Bugzilla entries: 1089638 [RESOLVED / FIXED], 1090647 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP3
  • dpdk-devel >= 16.11.8-8.10.2
  • dpdk-thunderx-devel >= 16.11.8-8.10.2
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-1017
SUSE-SLE-SDK-12-SP3-2018-2795
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP4
  • dpdk-devel >= 17.11.4-3.6
  • dpdk-thunderx-devel >= 17.11.4-3.5
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA dpdk-devel-17.11.4-3.6
SUSE Linux Enterprise High Performance Computing 12 SP5
  • dpdk >= 18.11.2-1.59
  • dpdk-kmp-default >= 18.11.2_k4.12.14_120-1.59
  • dpdk-thunderx >= 18.11.2-1.51
  • dpdk-thunderx-kmp-default >= 18.11.2_k4.12.14_120-1.51
  • dpdk-tools >= 18.11.2-1.59
  • libdpdk-18_11 >= 18.11.2-1.59
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA dpdk-18.11.2-1.59
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Module for Server Applications 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Linux Enterprise Storage 6
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • dpdk >= 18.11-2.43
  • dpdk-devel >= 18.11-2.43
  • dpdk-kmp-default >= 18.11_k4.12.14_195-2.43
  • dpdk-tools >= 18.11-2.43
  • libdpdk-18_11 >= 18.11-2.43
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP1 GA dpdk-18.11-2.43
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Module for Server Applications 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Linux Enterprise Storage 7
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • dpdk >= 19.11.1-1.3
  • dpdk-devel >= 19.11.1-1.3
  • dpdk-kmp-default >= 19.11.1_k5.3.18_22-1.3
  • dpdk-thunderx >= 19.11.1-1.3
  • dpdk-thunderx-devel >= 19.11.1-1.3
  • dpdk-thunderx-kmp-default >= 19.11.1_k5.3.18_22-1.3
  • dpdk-tools >= 19.11.1-1.3
  • libdpdk-20_0 >= 19.11.1-1.3
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP2 GA dpdk-19.11.1-1.3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Server Applications 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Storage 7.1
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • dpdk >= 19.11.4-1.105
  • dpdk-devel >= 19.11.4-1.105
  • dpdk-kmp-default >= 19.11.4_k5.3.18_57-1.105
  • dpdk-thunderx >= 19.11.4-1.94
  • dpdk-thunderx-devel >= 19.11.4-1.94
  • dpdk-thunderx-kmp-default >= 19.11.4_k5.3.18_57-1.94
  • dpdk-tools >= 19.11.4-1.105
  • libdpdk-20_0 >= 19.11.4-1.105
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP3 GA dpdk-19.11.4-1.105
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Server Applications 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • dpdk >= 19.11.10-150400.2.10
  • dpdk-devel >= 19.11.10-150400.2.10
  • dpdk-kmp-default >= 19.11.10_k5.14.21_150400.22-150400.2.10
  • dpdk-thunderx >= 19.11.10-150400.2.8
  • dpdk-thunderx-devel >= 19.11.10-150400.2.8
  • dpdk-thunderx-kmp-default >= 19.11.10_k5.14.21_150400.22-150400.2.8
  • dpdk-tools >= 19.11.10-150400.2.10
  • libdpdk-20_0 >= 19.11.10-150400.2.10
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP4 GA dpdk-19.11.10-150400.2.10
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Module for Server Applications 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • dpdk >= 17.11.2-1.27
  • dpdk-devel >= 17.11.2-1.27
  • dpdk-kmp-default >= 17.11.2_k4.12.14_23-1.27
  • dpdk-tools >= 17.11.2-1.27
  • libdpdk-17_11-0 >= 17.11.2-1.27
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA dpdk-17.11.2-1.27
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • dpdk >= 16.11.8-8.10.2
  • dpdk-devel >= 16.11.8-8.10.2
  • dpdk-kmp-default >= 16.11.8_k4.4.156_94.64-8.10.2
  • dpdk-thunderx >= 16.11.8-8.10.2
  • dpdk-thunderx-devel >= 16.11.8-8.10.2
  • dpdk-thunderx-kmp-default >= 16.11.8_k4.4.156_94.64-8.10.2
  • dpdk-tools >= 16.11.8-8.10.2
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-1017
SUSE-SLE-SDK-12-SP3-2018-2795
SUSE-SLE-SERVER-12-SP3-2018-1017
SUSE-SLE-SERVER-12-SP3-2018-2795
SUSE Linux Enterprise Server 12 SP4
  • dpdk >= 17.11.4-3.6
  • dpdk-devel >= 17.11.4-3.6
  • dpdk-kmp-default >= 17.11.4_k4.12.14_94.41-3.6
  • dpdk-thunderx >= 17.11.4-3.5
  • dpdk-thunderx-devel >= 17.11.4-3.5
  • dpdk-thunderx-kmp-default >= 17.11.4_k4.12.14_94.41-3.5
  • dpdk-tools >= 17.11.4-3.6
  • libdpdk-17_11 >= 17.11.4-3.6
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA dpdk-17.11.4-3.6
SUSE Linux Enterprise Software Development Kit 12 SP4 GA dpdk-devel-17.11.4-3.6
SUSE Linux Enterprise Server 12 SP5
  • dpdk >= 18.11.2-1.59
  • dpdk-devel >= 18.11.2-1.59
  • dpdk-kmp-default >= 18.11.2_k4.12.14_120-1.59
  • dpdk-thunderx >= 18.11.2-1.51
  • dpdk-thunderx-devel >= 18.11.2-1.51
  • dpdk-thunderx-kmp-default >= 18.11.2_k4.12.14_120-1.51
  • dpdk-tools >= 18.11.2-1.59
  • libdpdk-18_11 >= 18.11.2-1.59
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA dpdk-18.11.2-1.59
SUSE Linux Enterprise Software Development Kit 12 SP5 GA dpdk-devel-18.11.2-1.59
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Software Development Kit 12 SP5
  • dpdk-devel >= 18.11.2-1.59
  • dpdk-thunderx-devel >= 18.11.2-1.51
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA dpdk-devel-18.11.2-1.59
openSUSE Tumbleweed
  • dpdk >= 19.11.8-2.7
  • dpdk-devel >= 19.11.8-2.7
  • dpdk-doc >= 19.11.8-2.7
  • dpdk-examples >= 19.11.8-2.7
  • dpdk-kmp-default >= 19.11.8_k5.13.13_1-2.7
  • dpdk-tools >= 19.11.8-2.7
  • libdpdk-20_0 >= 19.11.8-2.7
Patchnames:
openSUSE Tumbleweed GA dpdk-19.11.8-2.7


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 dpdk In progress
SUSE Linux Enterprise Desktop 12 SP2 dpdk Unsupported
SUSE Linux Enterprise Desktop 12 SP3 dpdk Released
SUSE Linux Enterprise High Performance Computing 12 SP5 dpdk Already fixed
SUSE Linux Enterprise High Performance Computing 15 LTSS dpdk Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2 dpdk Already fixed
SUSE Linux Enterprise Module for Server Applications 15 SP2 dpdk Already fixed
SUSE Linux Enterprise Server 12 SP2 dpdk Unsupported
SUSE Linux Enterprise Server 12 SP3 dpdk Released
SUSE Linux Enterprise Server 12 SP3 BCL dpdk In progress
SUSE Linux Enterprise Server 12 SP3 ESPOS dpdk In progress
SUSE Linux Enterprise Server 12 SP3 LTSS dpdk In progress
SUSE Linux Enterprise Server 12 SP4 ESPOS dpdk Already fixed
SUSE Linux Enterprise Server 12 SP4 LTSS dpdk Already fixed
SUSE Linux Enterprise Server 12 SP5 dpdk Already fixed
SUSE Linux Enterprise Server 15 ESPOS dpdk Already fixed
SUSE Linux Enterprise Server 15 LTSS dpdk Already fixed
SUSE Linux Enterprise Server 15 SP2 dpdk Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP2 dpdk Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 dpdk Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 dpdk Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 dpdk Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 dpdk Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP2 dpdk Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP2 dpdk Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP3 dpdk Released
SUSE Linux Enterprise Storage 7 dpdk Already fixed
SUSE Manager Proxy 4.1 dpdk Already fixed
SUSE Manager Retail Branch Server 4.1 dpdk Already fixed
SUSE Manager Server 4.1 dpdk Already fixed
SUSE OpenStack Cloud 8 dpdk In progress
SUSE OpenStack Cloud 9 dpdk Already fixed
SUSE OpenStack Cloud Crowbar 8 dpdk In progress
SUSE OpenStack Cloud Crowbar 9 dpdk Already fixed
SUSE Package Hub 15 SP2 dpdk Already fixed