Upstream information

CVE-2018-1002105 at MITRE


In all Kubernetes versions prior to v1.10.11, v1.11.5, and v1.12.3, incorrect handling of error responses to proxied upgrade requests in the kube-apiserver allowed specially crafted requests to establish a connection through the Kubernetes API server to backend servers, then send arbitrary requests over the same connection directly to the backend, authenticated with the Kubernetes API server's TLS credentials used to establish the backend connection.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 9.8
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entries: 1118198 [RESOLVED / DUPLICATE], 1118260 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform 3.0
  • caasp-container-manifests >= 3.0.0+git_r291_33f7b2d-3.6.3
  • cri-o >= 1.10.6-4.8.5
  • cri-tools >= 1.0.0beta2-3.3.3
  • kubernetes-client >= 1.10.11-4.8.2
  • kubernetes-common >= 1.10.11-4.8.2
  • kubernetes-kubelet >= 1.10.11-4.8.2
  • kubernetes-master >= 1.10.11-4.8.2
  • kubernetes-node >= 1.10.11-4.8.2
  • kubernetes-salt >= 3.0.0+git_r888_7af7095-3.33.2
openSUSE Leap 15.1
  • cri-o >= 1.17.1-lp151.2.2
  • cri-o-kubeadm-criconfig >= 1.17.1-lp151.2.2
  • cri-tools >= 1.18.0-lp151.2.1
  • go1.14 >= 1.14-lp151.6.1
  • go1.14-doc >= 1.14-lp151.6.1
  • go1.14-race >= 1.14-lp151.6.1
  • kubernetes-apiserver >= 1.18.0-lp151.5.1
  • kubernetes-client >= 1.18.0-lp151.5.1
  • kubernetes-controller-manager >= 1.18.0-lp151.5.1
  • kubernetes-kubeadm >= 1.18.0-lp151.5.1
  • kubernetes-kubelet-common >= 1.18.0-lp151.5.1
  • kubernetes-kubelet1.17 >= 1.18.0-lp151.5.1
  • kubernetes-kubelet1.18 >= 1.18.0-lp151.5.1
  • kubernetes-master >= 1.18.0-lp151.5.1
  • kubernetes-node >= 1.18.0-lp151.5.1
  • kubernetes-proxy >= 1.18.0-lp151.5.1
  • kubernetes-scheduler >= 1.18.0-lp151.5.1

Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
Magnum Orchestration kubernetes Affected
SUSE CaaS Platform 3.0 kubernetes Released
SUSE CaaS Platform 4.0 kubernetes Not affected
SUSE CaaS Platform 4.5 kubernetes-1.18 In progress
SUSE Container as a Service Platform 2.0 kubernetes Affected
SUSE Linux Enterprise Module for Containers 15 SP1 kubernetes Unsupported
SUSE Linux Enterprise Module for Public Cloud 12 kubernetes Affected