Upstream information

CVE-2018-10017 at MITRE

Description

soundlib/Snd_fx.cpp in OpenMPT before 1.27.07.00 and libopenmpt before 0.3.8 allows remote attackers to cause a denial of service (out-of-bounds read) via an IT or MO3 file with many nested pattern loops.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1089080 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • libmodplug-devel >= 0.3.9-3.3.1
  • libmodplug1 >= 0.3.9-3.3.1
  • libopenmpt-devel >= 0.3.9-3.3.1
  • libopenmpt0 >= 0.3.9-3.3.1
  • libopenmpt_modplug1 >= 0.3.9-3.3.1
SUSE Linux Enterprise Module for Desktop Applications 15
  • libmodplug-devel >= 0.3.9-3.3.1
  • libmodplug1 >= 0.3.9-3.3.1
  • libopenmpt >= 0.3.9-3.3.1
  • libopenmpt-devel >= 0.3.9-3.3.1
  • libopenmpt0 >= 0.3.9-3.3.1
  • libopenmpt_modplug1 >= 0.3.9-3.3.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2018-1323
openSUSE Leap 15.0
  • libmodplug-devel >= 0.3.9-lp150.2.3.1
  • libmodplug1 >= 0.3.9-lp150.2.3.1
  • libmodplug1-32bit >= 0.3.9-lp150.2.3.1
  • libmodplug1-32bit-debuginfo >= 0.3.9-lp150.2.3.1
  • libmodplug1-debuginfo >= 0.3.9-lp150.2.3.1
  • libopenmpt >= 0.3.9-lp150.2.3.1
  • libopenmpt-debugsource >= 0.3.9-lp150.2.3.1
  • libopenmpt-devel >= 0.3.9-lp150.2.3.1
  • libopenmpt0 >= 0.3.9-lp150.2.3.1
  • libopenmpt0-32bit >= 0.3.9-lp150.2.3.1
  • libopenmpt0-32bit-debuginfo >= 0.3.9-lp150.2.3.1
  • libopenmpt0-debuginfo >= 0.3.9-lp150.2.3.1
  • libopenmpt_modplug1 >= 0.3.9-lp150.2.3.1
  • libopenmpt_modplug1-32bit >= 0.3.9-lp150.2.3.1
  • libopenmpt_modplug1-32bit-debuginfo >= 0.3.9-lp150.2.3.1
  • libopenmpt_modplug1-debuginfo >= 0.3.9-lp150.2.3.1
  • openmpt123 >= 0.3.9-lp150.2.3.1
  • openmpt123-debuginfo >= 0.3.9-lp150.2.3.1
Patchnames:
openSUSE-2019-524


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise 15 Module for Desktop Applications libopenmpt Released
SUSE Linux Enterprise 15-SP1 Module for Desktop Applications libopenmpt Released
SUSE Linux Enterprise 15-SP2 Module for Desktop Applications libopenmpt Released