Upstream information

CVE-2018-1000801 at MITRE

Description

okular version 18.08 and earlier contains a Directory Traversal vulnerability in function "unpackDocumentArchive(...)" in "core/document.cpp" that can result in Arbitrary file creation on the user workstation. This attack appear to be exploitable via he victim must open a specially crafted Okular archive. This issue appears to have been corrected in version 18.08.1

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

SUSE Bugzilla entry: 1107591 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub for SUSE Linux Enterprise 12 SP3
  • okular >= 17.04.2-11.1
  • okular-debuginfo >= 17.04.2-11.1
  • okular-debugsource >= 17.04.2-11.1
  • okular-devel >= 17.04.2-11.1
  • okular-lang >= 17.04.2-11.1
Patchnames:
openSUSE-2018-1006
openSUSE Leap 15.0
  • okular >= 17.12.3-lp150.3.3.1
  • okular-debuginfo >= 17.12.3-lp150.3.3.1
  • okular-debugsource >= 17.12.3-lp150.3.3.1
  • okular-devel >= 17.12.3-lp150.3.3.1
  • okular-lang >= 17.12.3-lp150.3.3.1
Patchnames:
openSUSE-2018-1006
openSUSE Leap 42.3
  • okular >= 17.04.2-6.1
  • okular-debuginfo >= 17.04.2-6.1
  • okular-debugsource >= 17.04.2-6.1
  • okular-devel >= 17.04.2-6.1
  • okular-lang >= 17.04.2-6.1
Patchnames:
openSUSE-2018-1006