Upstream information

CVE-2018-1000226 at MITRE

Description

Cobbler version Verified as present in Cobbler versions 2.6.11+, but code inspection suggests at least 2.0.0+ or possibly even older versions may be vulnerable contains a Incorrect Access Control vulnerability in XMLRPC API (/cobbler_api) that can result in Privilege escalation, data manipulation or exfiltration, LDAP credential harvesting. This attack appear to be exploitable via "network connectivity". Taking advantage of improper validation of security tokens in API endpoints. Please note this is a different issue than CVE-2018-10931.

SUSE information

Overall state of this security issue: Revisit

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 9.1
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High None
CVSSv3 Version 3.0 3.0
SUSE Bugzilla entries: 1104190 [RESOLVED / FIXED], 1104287 [RESOLVED / FIXED], 1105440 [REOPENED], 1105442 [RESOLVED / FIXED], 1131852 [RESOLVED / DUPLICATE]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • cobbler >= 2.6.6-49.14.1
Patchnames:
HPE-Helion-OpenStack-8-2018-1795
SUSE Manager Proxy 3.1
  • release-notes-susemanager-proxy >= 3.1.8-0.15.29.1
Patchnames:
SUSE-SUSE-Manager-Proxy-3.1-2018-1849
SUSE Manager Server 3.0
  • cobbler >= 2.6.6-49.14.1
Patchnames:
SUSE-SUSE-Manager-Server-3.0-2018-1795
SUSE Manager Server 3.1
  • cobbler >= 2.6.6-5.17.1
  • release-notes-susemanager >= 3.1.8-5.38.1
Patchnames:
SUSE-SUSE-Manager-Server-3.1-2018-1832
SUSE-SUSE-Manager-Server-3.1-2018-1849
SUSE Manager Server 3.2
  • cobbler >= 2.6.6-6.7.1
Patchnames:
SUSE-SUSE-Manager-Server-3.2-2018-1788
SUSE Manager Tools 12
  • cobbler >= 2.6.6-49.14.1
  • koan >= 2.6.6-49.14.1
Patchnames:
SUSE-SLE-Manager-Tools-12-2018-1795
SUSE OpenStack Cloud 8
  • cobbler >= 2.6.6-49.14.1
Patchnames:
SUSE-OpenStack-Cloud-8-2018-1795
openSUSE Leap 42.3
  • cobbler >= 2.6.6-17.1
  • cobbler-tests >= 2.6.6-17.1
  • cobbler-web >= 2.6.6-17.1
  • koan >= 2.6.6-17.1
Patchnames:
openSUSE-2018-952


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 cobbler Affected
SUSE Linux Enterprise Client Tools for SUSE Manager 12 GA cobbler Affected
SUSE Linux Enterprise Module for SUSE Manager Server 4.0 GA cobbler Analysis
SUSE Manager Server 3.0 cobbler Affected
SUSE Manager Server 3.1 cobbler Affected
SUSE Manager Server 3.2 cobbler Affected
SUSE Openstack Cloud 8 cobbler Affected