Upstream information

CVE-2018-0739 at MITRE

Description

Constructed ASN.1 types with a recursive definition (such as can be found in PKCS7) could eventually exceed the stack given malicious input with excessive recursion. This could result in a Denial Of Service attack. There are no such structures used within SSL/TLS that come from untrusted sources so this is considered safe. Fixed in OpenSSL 1.1.0h (Affected 1.1.0-1.1.0g). Fixed in OpenSSL 1.0.2o (Affected 1.0.2b-1.0.2n).

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 7.5
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
SUSE Bugzilla entries: 1087102 [IN_PROGRESS], 1089997 [RESOLVED / FIXED], 1108542 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • libopenssl1_0_0 >= 1.0.2j-60.24.1
  • openssl >= 1.0.2j-60.24.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2018-624
SUSE CaaS Platform ALL
  • libopenssl1_0_0 >= 1.0.2j-60.24.1
  • openssl >= 1.0.2j-60.24.1
Patchnames:
SUSE-CAASP-ALL-2018-624
SUSE Linux Enterprise Desktop 12 SP2
  • libopenssl-devel >= 1.0.2j-60.24.1
  • libopenssl1_0_0 >= 1.0.2j-60.24.1
  • libopenssl1_0_0-32bit >= 1.0.2j-60.24.1
  • openssl >= 1.0.2j-60.24.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2018-624
SUSE Linux Enterprise Desktop 12 SP3
  • compat-openssl098 >= 0.9.8j-106.6.1
  • libopenssl-devel >= 1.0.2j-60.24.1
  • libopenssl0_9_8 >= 0.9.8j-106.6.1
  • libopenssl0_9_8-32bit >= 0.9.8j-106.6.1
  • libopenssl1_0_0 >= 1.0.2j-60.24.1
  • libopenssl1_0_0-32bit >= 1.0.2j-60.24.1
  • openssl >= 1.0.2j-60.24.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-1872
SUSE-SLE-DESKTOP-12-SP3-2018-624
SUSE Linux Enterprise Module for Basesystem 15
  • libopenssl-1_1-devel >= 1.1.0h-2.3
  • libopenssl1_1 >= 1.1.0h-2.3
  • libopenssl1_1-32bit >= 1.1.0h-2.3
  • libopenssl1_1-hmac >= 1.1.0h-2.3
  • libopenssl1_1-hmac-32bit >= 1.1.0h-2.3
  • openssl-1_1 >= 1.1.0h-2.3
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libopenssl-1_1-devel
SUSE Linux Enterprise Module for Legacy Software 12
  • compat-openssl098 >= 0.9.8j-106.6.1
  • libopenssl0_9_8 >= 0.9.8j-106.6.1
  • libopenssl0_9_8-32bit >= 0.9.8j-106.6.1
Patchnames:
SUSE-SLE-Module-Legacy-12-2018-1872
SUSE Linux Enterprise Module for Server Applications 15
  • ovmf >= 2017+git1510945757.b2662641d5-5.3.6
  • ovmf-tools >= 2017+git1510945757.b2662641d5-5.3.6
  • qemu-ovmf-x86_64 >= 2017+git1510945757.b2662641d5-5.3.6
  • qemu-uefi-aarch64 >= 2017+git1510945757.b2662641d5-5.3.6
Patchnames:
SUSE-SLE-Module-Server-Applications-15-2018-1399
SUSE Linux Enterprise Server 11 SP4
  • libopenssl0_9_8 >= 0.9.8j-0.106.9.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.106.9.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.106.9.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.106.9.1
  • libopenssl0_9_8-x86 >= 0.9.8j-0.106.9.1
  • openssl >= 0.9.8j-0.106.9.1
  • openssl-doc >= 0.9.8j-0.106.9.1
Patchnames:
slessp4-openssl-13565
SUSE Linux Enterprise Server 11-SECURITY
  • libopenssl1-devel >= 1.0.1g-0.58.9.1
  • libopenssl1_0_0 >= 1.0.1g-0.58.9.1
  • libopenssl1_0_0-32bit >= 1.0.1g-0.58.9.1
  • libopenssl1_0_0-x86 >= 1.0.1g-0.58.9.1
  • openssl1 >= 1.0.1g-0.58.9.1
  • openssl1-doc >= 1.0.1g-0.58.9.1
Patchnames:
secsp3-openssl1-13554
SUSE Linux Enterprise Server 12 SP1-LTSS
  • libopenssl1_0_0 >= 1.0.1i-54.11.1
  • libopenssl1_0_0-32bit >= 1.0.1i-54.11.1
  • libopenssl1_0_0-hmac >= 1.0.1i-54.11.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.1i-54.11.1
  • openssl >= 1.0.1i-54.11.1
  • openssl-doc >= 1.0.1i-54.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-601
SUSE Linux Enterprise Server 12 SP2
  • libopenssl-devel >= 1.0.2j-60.24.1
  • libopenssl1_0_0 >= 1.0.2j-60.24.1
  • libopenssl1_0_0-32bit >= 1.0.2j-60.24.1
  • libopenssl1_0_0-hmac >= 1.0.2j-60.24.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.2j-60.24.1
  • openssl >= 1.0.2j-60.24.1
  • openssl-doc >= 1.0.2j-60.24.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-624
SUSE Linux Enterprise Server 12 SP3
  • libopenssl-devel >= 1.0.2j-60.24.1
  • libopenssl1_0_0 >= 1.0.2j-60.24.1
  • libopenssl1_0_0-32bit >= 1.0.2j-60.24.1
  • libopenssl1_0_0-hmac >= 1.0.2j-60.24.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.2j-60.24.1
  • openssl >= 1.0.2j-60.24.1
  • openssl-doc >= 1.0.2j-60.24.1
  • ovmf >= 2017+git1492060560.b6d11d7c46-4.9.4
  • ovmf-tools >= 2017+git1492060560.b6d11d7c46-4.9.4
  • qemu-ovmf-x86_64 >= 2017+git1492060560.b6d11d7c46-4.9.4
  • qemu-uefi-aarch64 >= 2017+git1492060560.b6d11d7c46-4.9.4
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1470
SUSE-SLE-SERVER-12-SP3-2018-624
SUSE Linux Enterprise Server 12-LTSS
  • libopenssl1_0_0 >= 1.0.1i-27.31.1
  • libopenssl1_0_0-32bit >= 1.0.1i-27.31.1
  • libopenssl1_0_0-hmac >= 1.0.1i-27.31.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.1i-27.31.1
  • openssl >= 1.0.1i-27.31.1
  • openssl-doc >= 1.0.1i-27.31.1
Patchnames:
SUSE-SLE-SERVER-12-2018-608
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libopenssl-devel >= 1.0.2j-60.24.1
  • libopenssl1_0_0 >= 1.0.2j-60.24.1
  • libopenssl1_0_0-hmac >= 1.0.2j-60.24.1
  • openssl >= 1.0.2j-60.24.1
  • openssl-doc >= 1.0.2j-60.24.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2018-624
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • compat-openssl097g >= 0.9.7g-146.22.51.5.1
  • compat-openssl097g-32bit >= 0.9.7g-146.22.51.5.1
  • libopenssl0_9_8 >= 0.9.8j-0.106.9.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.106.9.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.106.9.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.106.9.1
  • libopenssl0_9_8-x86 >= 0.9.8j-0.106.9.1
  • openssl >= 0.9.8j-0.106.9.1
  • openssl-doc >= 0.9.8j-0.106.9.1
Patchnames:
slesappsp4-compat-openssl097g-13753
slessp4-openssl-13565
SUSE Linux Enterprise Server for SAP Applications 11-SECURITY
  • libopenssl1-devel >= 1.0.1g-0.58.9.1
  • libopenssl1_0_0 >= 1.0.1g-0.58.9.1
  • libopenssl1_0_0-32bit >= 1.0.1g-0.58.9.1
  • libopenssl1_0_0-x86 >= 1.0.1g-0.58.9.1
  • openssl1 >= 1.0.1g-0.58.9.1
  • openssl1-doc >= 1.0.1g-0.58.9.1
Patchnames:
secsp3-openssl1-13554
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • compat-openssl098 >= 0.9.8j-106.6.1
  • libopenssl0_9_8 >= 0.9.8j-106.6.1
  • libopenssl1_0_0 >= 1.0.1i-54.11.1
  • libopenssl1_0_0-32bit >= 1.0.1i-54.11.1
  • libopenssl1_0_0-hmac >= 1.0.1i-54.11.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.1i-54.11.1
  • openssl >= 1.0.1i-54.11.1
  • openssl-doc >= 1.0.1i-54.11.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2018-1872
SUSE-SLE-SAP-12-SP1-2018-601
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • libopenssl1_0_0 >= 1.0.1i-54.11.1
  • libopenssl1_0_0-32bit >= 1.0.1i-54.11.1
  • libopenssl1_0_0-hmac >= 1.0.1i-54.11.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.1i-54.11.1
  • openssl >= 1.0.1i-54.11.1
  • openssl-doc >= 1.0.1i-54.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-601
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • compat-openssl098 >= 0.9.8j-106.6.1
  • libopenssl-devel >= 1.0.2j-60.24.1
  • libopenssl0_9_8 >= 0.9.8j-106.6.1
  • libopenssl1_0_0 >= 1.0.2j-60.24.1
  • libopenssl1_0_0-32bit >= 1.0.2j-60.24.1
  • libopenssl1_0_0-hmac >= 1.0.2j-60.24.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.2j-60.24.1
  • openssl >= 1.0.2j-60.24.1
  • openssl-doc >= 1.0.2j-60.24.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2018-1872
SUSE-SLE-SERVER-12-SP2-2018-624
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • compat-openssl098 >= 0.9.8j-106.6.1
  • libopenssl-devel >= 1.0.2j-60.24.1
  • libopenssl0_9_8 >= 0.9.8j-106.6.1
  • libopenssl1_0_0 >= 1.0.2j-60.24.1
  • libopenssl1_0_0-32bit >= 1.0.2j-60.24.1
  • libopenssl1_0_0-hmac >= 1.0.2j-60.24.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.2j-60.24.1
  • openssl >= 1.0.2j-60.24.1
  • openssl-doc >= 1.0.2j-60.24.1
  • ovmf >= 2017+git1492060560.b6d11d7c46-4.9.4
  • ovmf-tools >= 2017+git1492060560.b6d11d7c46-4.9.4
  • qemu-ovmf-x86_64 >= 2017+git1492060560.b6d11d7c46-4.9.4
  • qemu-uefi-aarch64 >= 2017+git1492060560.b6d11d7c46-4.9.4
Patchnames:
SUSE-SLE-SAP-12-SP3-2018-1872
SUSE-SLE-SERVER-12-SP3-2018-1470
SUSE-SLE-SERVER-12-SP3-2018-624
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • libopenssl1_0_0 >= 1.0.1i-27.31.1
  • libopenssl1_0_0-32bit >= 1.0.1i-27.31.1
  • libopenssl1_0_0-hmac >= 1.0.1i-27.31.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.1i-27.31.1
  • openssl >= 1.0.1i-27.31.1
  • openssl-doc >= 1.0.1i-27.31.1
Patchnames:
SUSE-SLE-SERVER-12-2018-608
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libopenssl-devel >= 0.9.8j-0.106.9.1
  • libopenssl-devel-32bit >= 0.9.8j-0.106.9.1
  • openssl >= 0.9.8j-0.106.9.1
Patchnames:
sdksp4-openssl-13565
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libopenssl-devel >= 1.0.2j-60.24.1
  • openssl >= 1.0.2j-60.24.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2018-624
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libopenssl-devel >= 1.0.2j-60.24.1
  • openssl >= 1.0.2j-60.24.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-624
SUSE OpenStack Cloud 6
  • libopenssl1_0_0 >= 1.0.1i-54.11.1
  • libopenssl1_0_0-32bit >= 1.0.1i-54.11.1
  • libopenssl1_0_0-hmac >= 1.0.1i-54.11.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.1i-54.11.1
  • openssl >= 1.0.1i-54.11.1
  • openssl-doc >= 1.0.1i-54.11.1
Patchnames:
SUSE-OpenStack-Cloud-6-2018-601
SUSE Studio Onsite 1.3
  • libopenssl-devel >= 0.9.8j-0.106.9.1
  • openssl >= 0.9.8j-0.106.9.1
Patchnames:
slestso13-openssl-13565
openSUSE Leap 15.0
  • libopenssl1_1 >= 1.1.0h-lp150.2.1
  • libopenssl1_1-32bit >= 1.1.0h-lp150.2.1
  • openssl-1_1 >= 1.1.0h-lp150.2.1
  • ovmf >= 2017+git1510945757.b2662641d5-lp150.4.3.1
  • ovmf-tools >= 2017+git1510945757.b2662641d5-lp150.4.3.1
  • qemu-ovmf-ia32 >= 2017+git1510945757.b2662641d5-lp150.4.3.1
  • qemu-ovmf-x86_64 >= 2017+git1510945757.b2662641d5-lp150.4.3.1
  • qemu-ovmf-x86_64-debug >= 2017+git1510945757.b2662641d5-lp150.4.3.1
  • virtualbox-guest-kmp-default >= 5.2.10_k4.12.14_lp150.11-lp150.3.6
  • virtualbox-guest-tools >= 5.2.10-lp150.3.6
  • virtualbox-guest-x11 >= 5.2.10-lp150.3.6
Patchnames:
openSUSE Leap 15.0 GA libopenssl1_1
openSUSE Leap 15.0 GA virtualbox-guest-kmp-default
openSUSE-2018-807
openSUSE Leap 42.3
  • compat-openssl098 >= 0.9.8j-24.1
  • compat-openssl098-debugsource >= 0.9.8j-24.1
  • kbuild >= 0.1.9998svn3110-4.3.1
  • kbuild-debuginfo >= 0.1.9998svn3110-4.3.1
  • kbuild-debugsource >= 0.1.9998svn3110-4.3.1
  • libmysql56client18 >= 5.6.41-39.1
  • libmysql56client18-32bit >= 5.6.41-39.1
  • libmysql56client18-debuginfo >= 5.6.41-39.1
  • libmysql56client18-debuginfo-32bit >= 5.6.41-39.1
  • libmysql56client_r18 >= 5.6.41-39.1
  • libmysql56client_r18-32bit >= 5.6.41-39.1
  • libopenssl-devel >= 1.0.2j-19.1
  • libopenssl-devel-32bit >= 1.0.2j-19.1
  • libopenssl0_9_8 >= 0.9.8j-24.1
  • libopenssl0_9_8-32bit >= 0.9.8j-24.1
  • libopenssl0_9_8-debuginfo >= 0.9.8j-24.1
  • libopenssl0_9_8-debuginfo-32bit >= 0.9.8j-24.1
  • libopenssl1_0_0 >= 1.0.2j-19.1
  • libopenssl1_0_0-32bit >= 1.0.2j-19.1
  • libopenssl1_0_0-debuginfo >= 1.0.2j-19.1
  • libopenssl1_0_0-debuginfo-32bit >= 1.0.2j-19.1
  • libopenssl1_0_0-hmac >= 1.0.2j-19.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.2j-19.1
  • mysql-community-server >= 5.6.41-39.1
  • mysql-community-server-bench >= 5.6.41-39.1
  • mysql-community-server-bench-debuginfo >= 5.6.41-39.1
  • mysql-community-server-client >= 5.6.41-39.1
  • mysql-community-server-client-debuginfo >= 5.6.41-39.1
  • mysql-community-server-debuginfo >= 5.6.41-39.1
  • mysql-community-server-debugsource >= 5.6.41-39.1
  • mysql-community-server-errormessages >= 5.6.41-39.1
  • mysql-community-server-test >= 5.6.41-39.1
  • mysql-community-server-test-debuginfo >= 5.6.41-39.1
  • mysql-community-server-tools >= 5.6.41-39.1
  • mysql-community-server-tools-debuginfo >= 5.6.41-39.1
  • openssl >= 1.0.2j-19.1
  • openssl-cavs >= 1.0.2j-19.1
  • openssl-cavs-debuginfo >= 1.0.2j-19.1
  • openssl-debuginfo >= 1.0.2j-19.1
  • openssl-debugsource >= 1.0.2j-19.1
  • openssl-doc >= 1.0.2j-19.1
  • ovmf >= 2017+git1492060560.b6d11d7c46-10.1
  • ovmf-tools >= 2017+git1492060560.b6d11d7c46-10.1
  • python-virtualbox >= 5.2.18-56.1
  • python-virtualbox-debuginfo >= 5.2.18-56.1
  • qemu-ovmf-ia32 >= 2017+git1492060560.b6d11d7c46-10.1
  • qemu-ovmf-x86_64 >= 2017+git1492060560.b6d11d7c46-10.1
  • qemu-ovmf-x86_64-debug >= 2017+git1492060560.b6d11d7c46-10.1
  • virtualbox >= 5.2.18-56.1
  • virtualbox-debuginfo >= 5.2.18-56.1
  • virtualbox-debugsource >= 5.2.18-56.1
  • virtualbox-devel >= 5.2.18-56.1
  • virtualbox-guest-desktop-icons >= 5.2.18-56.1
  • virtualbox-guest-kmp-default >= 5.2.18_k4.4.143_65-56.1
  • virtualbox-guest-kmp-default-debuginfo >= 5.2.18_k4.4.143_65-56.1
  • virtualbox-guest-source >= 5.2.18-56.1
  • virtualbox-guest-tools >= 5.2.18-56.1
  • virtualbox-guest-tools-debuginfo >= 5.2.18-56.1
  • virtualbox-guest-x11 >= 5.2.18-56.1
  • virtualbox-guest-x11-debuginfo >= 5.2.18-56.1
  • virtualbox-host-kmp-default >= 5.2.18_k4.4.143_65-56.1
  • virtualbox-host-kmp-default-debuginfo >= 5.2.18_k4.4.143_65-56.1
  • virtualbox-host-source >= 5.2.18-56.1
  • virtualbox-qt >= 5.2.18-56.1
  • virtualbox-qt-debuginfo >= 5.2.18-56.1
  • virtualbox-vnc >= 5.2.18-56.1
  • virtualbox-websrv >= 5.2.18-56.1
  • virtualbox-websrv-debuginfo >= 5.2.18-56.1
Patchnames:
openSUSE-2018-361
openSUSE-2018-389
openSUSE-2018-823
openSUSE-2018-844
openSUSE-2018-938
openSUSE-2018-997


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 openssl Released
OpenStack Cloud Magnum Orchestration 7.0 openssl Released
SUSE Linux Enterprise Desktop 12 SP2 compat-openssl098 Affected
SUSE Linux Enterprise Desktop 12 SP2 openssl Released
SUSE Linux Enterprise Desktop 12 SP3 compat-openssl098 Released
SUSE Linux Enterprise Desktop 12 SP3 openssl Released
SUSE Linux Enterprise Module for Legacy Software 12 compat-openssl098 Released
SUSE Linux Enterprise SDK 11 SP4 openssl Released
SUSE Linux Enterprise SDK 12 SP2 openssl Released
SUSE Linux Enterprise SDK 12 SP3 openssl Released
SUSE Linux Enterprise Security Module 11.3 GA openssl1 Released
SUSE Linux Enterprise Server 11 SP3 LTSS openssl Already fixed
SUSE Linux Enterprise Server 11 SP4 openssl Released
SUSE Linux Enterprise Server 12 GA LTSS openssl Released
SUSE Linux Enterprise Server 12 SP1 LTSS openssl Released
SUSE Linux Enterprise Server 12 SP2 openssl Released
SUSE Linux Enterprise Server 12 SP3 openssl Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 compat-openssl097g Ignore
SUSE Linux Enterprise Server for SAP Applications 11 SP4 compat-openssl097g Released
SUSE Linux Enterprise Server for SAP Applications 12 SP1 compat-openssl098 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 compat-openssl098 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 compat-openssl098 Released
SUSE Studio Onsite 1.3 openssl Released