Upstream information

CVE-2017-7479 at MITRE

Description

OpenVPN versions before 2.3.15 and before 2.4.2 are vulnerable to reachable assertion when packet-ID counter rolls over resulting into Denial of Service of server by authenticated attacker.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.00
Vector AV:N/AC:L/Au:S/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High

This issue is currently rated as having important severity.

SUSE Bugzilla entries: 1038711 [NEW], 1038713 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • openvpn >= 2.3.8-16.14.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-998
SUSE Linux Enterprise Server 12 SP2
  • openvpn >= 2.3.8-16.14.1
  • openvpn-auth-pam-plugin >= 2.3.8-16.14.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-998
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • openvpn >= 2.3.8-16.14.1
  • openvpn-auth-pam-plugin >= 2.3.8-16.14.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-998
openSUSE Leap 42.2
  • openvpn >= 2.3.8-8.6.1
  • openvpn-auth-pam-plugin >= 2.3.8-8.6.1
  • openvpn-auth-pam-plugin-debuginfo >= 2.3.8-8.6.1
  • openvpn-debuginfo >= 2.3.8-8.6.1
  • openvpn-debugsource >= 2.3.8-8.6.1
  • openvpn-devel >= 2.3.8-8.6.1
  • openvpn-down-root-plugin >= 2.3.8-8.6.1
  • openvpn-down-root-plugin-debuginfo >= 2.3.8-8.6.1
Patchnames:
openSUSE-2017-717

List of packages in QA

Product(s) Package(s)
SUSE Linux Enterprise Server 11-SECURITY
  • openvpn-openssl1 >= 2.3.2-0.9.1
  • openvpn-openssl1-down-root-plugin >= 2.3.2-0.9.1