Upstream information

CVE-2017-5978 at MITRE

Description

The zzip_mem_entry_new function in memdisk.c in zziplib 0.13.62 allows remote attackers to cause a denial of service (out-of-bounds read and crash) via a crafted ZIP file.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.30
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 5.5
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 1024533 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • libzzip-0-13 >= 0.13.62-9.1
  • zziplib >= 0.13.62-9.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-638
SUSE Linux Enterprise Desktop 12 SP2
  • libzzip-0-13 >= 0.13.62-9.1
  • zziplib >= 0.13.62-9.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-638
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libzzip-0-13 >= 0.13.62-9.1
  • zziplib >= 0.13.62-9.1
  • zziplib-devel >= 0.13.62-9.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2017-638
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libzzip-0-13 >= 0.13.62-9.1
  • zziplib >= 0.13.62-9.1
  • zziplib-devel >= 0.13.62-9.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-638
SUSE Linux Enterprise Workstation Extension 12 SP1
  • libzzip-0-13 >= 0.13.62-9.1
  • zziplib >= 0.13.62-9.1
Patchnames:
SUSE-SLE-WE-12-SP1-2017-638
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libzzip-0-13 >= 0.13.62-9.1
  • zziplib >= 0.13.62-9.1
Patchnames:
SUSE-SLE-WE-12-SP2-2017-638
openSUSE Leap 42.1
  • libzzip-0-13 >= 0.13.62-10.1
  • libzzip-0-13-32bit >= 0.13.62-10.1
  • libzzip-0-13-debuginfo >= 0.13.62-10.1
  • libzzip-0-13-debuginfo-32bit >= 0.13.62-10.1
  • zziplib >= 0.13.62-10.1
  • zziplib-debugsource >= 0.13.62-10.1
  • zziplib-devel >= 0.13.62-10.1
  • zziplib-devel-32bit >= 0.13.62-10.1
  • zziplib-devel-debuginfo >= 0.13.62-10.1
  • zziplib-devel-debuginfo-32bit >= 0.13.62-10.1
Patchnames:
openSUSE-2017-554
openSUSE Leap 42.2
  • libzzip-0-13 >= 0.13.62-10.3.1
  • libzzip-0-13-32bit >= 0.13.62-10.3.1
  • libzzip-0-13-debuginfo >= 0.13.62-10.3.1
  • libzzip-0-13-debuginfo-32bit >= 0.13.62-10.3.1
  • zziplib >= 0.13.62-10.3.1
  • zziplib-debugsource >= 0.13.62-10.3.1
  • zziplib-devel >= 0.13.62-10.3.1
  • zziplib-devel-32bit >= 0.13.62-10.3.1
  • zziplib-devel-debuginfo >= 0.13.62-10.3.1
  • zziplib-devel-debuginfo-32bit >= 0.13.62-10.3.1
Patchnames:
openSUSE-2017-554