Upstream information

CVE-2017-5029 at MITRE

Description

The xsltAddTextString function in transform.c in libxslt 1.1.29, as used in Blink in Google Chrome prior to 57.0.2987.98 for Mac, Windows, and Linux and 57.0.2987.108 for Android, lacked a check for integer overflow during a size calculation, which allowed a remote attacker to perform an out of bounds memory write via a crafted HTML page.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.8 3.3
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:L/AC:M/Au:N/C:N/I:P/A:P
Access Vector Network Local
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Partial None
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.8
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entries: 1028848 [RESOLVED / FIXED], 1028875 [RESOLVED / DUPLICATE], 1035905 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • libxslt >= 1.1.28-16.1
  • libxslt-tools >= 1.1.28-16.1
  • libxslt1 >= 1.1.28-16.1
  • libxslt1-32bit >= 1.1.28-16.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-793
SUSE Linux Enterprise Desktop 12 SP2
  • libxslt >= 1.1.28-16.1
  • libxslt-tools >= 1.1.28-16.1
  • libxslt1 >= 1.1.28-16.1
  • libxslt1-32bit >= 1.1.28-16.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-793
SUSE Linux Enterprise Desktop 12 SP3
  • libxslt-tools >= 1.1.28-16.1
  • libxslt1 >= 1.1.28-16.1
  • libxslt1-32bit >= 1.1.28-16.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libxslt-tools
SUSE Linux Enterprise Server 11 SP4
  • libxslt >= 1.1.24-19.33.1
  • libxslt-32bit >= 1.1.24-19.33.1
  • libxslt-x86 >= 1.1.24-19.33.1
Patchnames:
slessp4-libxslt-13104
SUSE Linux Enterprise Server 12 SP1
  • libxslt >= 1.1.28-16.1
  • libxslt-tools >= 1.1.28-16.1
  • libxslt1 >= 1.1.28-16.1
  • libxslt1-32bit >= 1.1.28-16.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-793
SUSE Linux Enterprise Server 12 SP2
  • libxslt >= 1.1.28-16.1
  • libxslt-tools >= 1.1.28-16.1
  • libxslt1 >= 1.1.28-16.1
  • libxslt1-32bit >= 1.1.28-16.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-793
SUSE Linux Enterprise Server 12 SP3
  • libxslt-tools >= 1.1.28-16.1
  • libxslt1 >= 1.1.28-16.1
  • libxslt1-32bit >= 1.1.28-16.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libxslt-tools
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libxslt >= 1.1.28-16.1
  • libxslt-tools >= 1.1.28-16.1
  • libxslt1 >= 1.1.28-16.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-793
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libxslt >= 1.1.24-19.33.1
  • libxslt-devel >= 1.1.24-19.33.1
  • libxslt-devel-32bit >= 1.1.24-19.33.1
  • libxslt-python >= 1.1.24-19.33.3
Patchnames:
sdksp4-libxslt-13104
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libxslt >= 1.1.28-16.1
  • libxslt-devel >= 1.1.28-16.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2017-793
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libxslt >= 1.1.28-16.1
  • libxslt-devel >= 1.1.28-16.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-793
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libxslt-devel >= 1.1.28-16.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libxslt-devel
openSUSE Leap 42.1
  • chromedriver >= 57.0.2987.98-105.2
  • chromedriver-debuginfo >= 57.0.2987.98-105.2
  • chromium >= 57.0.2987.98-105.2
  • chromium-debuginfo >= 57.0.2987.98-105.2
  • chromium-debugsource >= 57.0.2987.98-105.2
Patchnames:
openSUSE-2017-353
openSUSE Leap 42.2
  • chromedriver >= 57.0.2987.98-105.2
  • chromedriver-debuginfo >= 57.0.2987.98-105.2
  • chromium >= 57.0.2987.98-105.2
  • chromium-debuginfo >= 57.0.2987.98-105.2
  • chromium-debugsource >= 57.0.2987.98-105.2
  • libxslt >= 1.1.28-10.3.1
  • libxslt-debugsource >= 1.1.28-10.3.1
  • libxslt-devel >= 1.1.28-10.3.1
  • libxslt-devel-32bit >= 1.1.28-10.3.1
  • libxslt-python >= 1.1.28-10.3.1
  • libxslt-python-debuginfo >= 1.1.28-10.3.1
  • libxslt-python-debugsource >= 1.1.28-10.3.1
  • libxslt-tools >= 1.1.28-10.3.1
  • libxslt-tools-debuginfo >= 1.1.28-10.3.1
  • libxslt1 >= 1.1.28-10.3.1
  • libxslt1-32bit >= 1.1.28-10.3.1
  • libxslt1-debuginfo >= 1.1.28-10.3.1
  • libxslt1-debuginfo-32bit >= 1.1.28-10.3.1
Patchnames:
openSUSE-2017-353
openSUSE-2017-609
openSUSE Leap 42.3
  • libxslt-devel >= 1.1.28-12.1
  • libxslt-tools >= 1.1.28-12.1
  • libxslt1 >= 1.1.28-12.1
  • libxslt1-32bit >= 1.1.28-12.1
Patchnames:
openSUSE Leap 42.3 GA libxslt-devel


List of planned updates

The following information is the current evaluation information for this security issue. It might neither be accurate nor complete, Use at own risk.
Product(s) Source package
  • SUSE Linux Enterprise Server 11 SP3 LTSS
  • SUSE Linux Enterprise Server 12 GA
libxslt


Status of this issue by product and package

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 libxslt Released
SUSE Linux Enterprise Desktop 12 SP2 libxslt Released
SUSE Linux Enterprise SDK 11 SP4 libxslt Released
SUSE Linux Enterprise SDK 12 SP1 libxslt Released
SUSE Linux Enterprise SDK 12 SP2 libxslt Released
SUSE Linux Enterprise Server 11 SP3 LTSS libxslt Affected
SUSE Linux Enterprise Server 11 SP4 libxslt Released
SUSE Linux Enterprise Server 12 GA libxslt Affected
SUSE Linux Enterprise Server 12 SP1 libxslt Released
SUSE Linux Enterprise Server 12 SP2 libxslt Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry Pi libxslt Released