Upstream information

CVE-2017-17917 at MITRE

Description

** DISPUTED ** SQL injection vulnerability in the 'where' method in Ruby on Rails 5.1.4 and earlier allows remote attackers to execute arbitrary SQL commands via the 'id' parameter. NOTE: The vendor disputes this issue because the documentation states that this method is not intended for use with untrusted input.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  SUSE
Base Score 4.7
Vector AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L
Access Vector Network
Access Complexity Low
Privileges Required High
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact Low
Availability Impact Low
SUSE Bugzilla entry: 1074347 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Lifecycle Management Server 1.3 rubygem-rails-3_2 Not affected
SUSE Linux Enterprise SDK 11 SP4 rubygem-rails-3_2 Not affected
SUSE Openstack Cloud 6 rubygem-rails-4_2 Not affected
SUSE Openstack Cloud 7 rubygem-rails-4_2 Not affected
SUSE Storage 3 rubygem-rails-4_2 Not affected
SUSE Storage 4 rubygem-rails-4_2 Not affected
SUSE Studio Onsite 1.3 rubygem-rails-3_2 Not affected