Upstream information

CVE-2017-16660 at MITRE

Description

Cacti 1.1.27 allows remote authenticated administrators to conduct Remote Code Execution attacks by placing the Log Path under the web root, and then making a remote_agent.php request containing PHP code in a Client-ip header.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9
Vector AV:N/AC:L/Au:S/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 1067164 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 42.2
  • cacti >= 1.1.28-16.13.1
  • cacti-doc >= 1.1.28-16.13.1
  • cacti-spine >= 1.1.28-7.13.1
  • cacti-spine-debuginfo >= 1.1.28-7.13.1
  • cacti-spine-debugsource >= 1.1.28-7.13.1
Patchnames:
openSUSE-2017-1290
openSUSE Leap 42.3
  • cacti >= 1.1.28-29.1
  • cacti-doc >= 1.1.28-29.1
  • cacti-spine >= 1.1.28-20.1
  • cacti-spine-debuginfo >= 1.1.28-20.1
  • cacti-spine-debugsource >= 1.1.28-20.1
Patchnames:
openSUSE-2017-1290